summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-01 22:42:26 +0100
committerSam James <sam@gentoo.org>2022-09-03 01:34:04 +0100
commitbd4d42f83c774c36bf879a5b7ec89d373546743e (patch)
treee6933ccc0ee465f50e92b32a0ae451a27d1be375
parentsys-process/criu: add additional glibc-2.36 fix (diff)
downloadgentoo-bd4d42f8.tar.gz
gentoo-bd4d42f8.tar.bz2
gentoo-bd4d42f8.zip
net-misc/curl: drop USE=threads
USE=threads is a terrible USE flag (not the fault of net-misc/curl or its maintainer) and we're looking to get rid of it entirely. This is motivated further by the fact users have USE=threads in make.conf seeking performance improvements and such (which is understandable) but as per below, it can lead to conflicting and inconsistent effects. (In particular, anyone with USE="threads" in make.conf (don't do this for the reasons below!) will end up with a REQUIRED_USE issue between the now-default USE=adns and USE=threads). There are a few possibilities with threads support: 1. Upstreams always have threads support (hence USE=threads is only affecting a "handful" of packages anyway, not every single package, as many will just always be using pthreads and there's no way of disabling it); 2. The "threads" toggle means enabling some experimental or legacy implementation (think e.g. dev-lang/perl, which uses USE=ithreads for this, as it breaks ABI) (also applies to net-misc/curl given USE=threads doesn't help with the adns functionality many applications desire, see linked bug); 3. Not having "threads" on enables some experimental or legacy implementation again (this *again* applies to net-misc/curl given USE="-adns -threads" leaves us with a dodgy implementation as well). Commit 60b7aaa7a70149751446237d7207ff1ca20c256e enabled adns by default (IUSE=+adns). This commit drops USE=threads entirely and makes the default pthreads with adns opt-in with IUSE=+adns still. Now, the ebuild previously had REQUIRED_USE="threads? ( !adns )". I can't see a reason for this other than making the previous situation "meaningful", i.e. allowing people to decisively choose which is used at runtime, as while curl can build with both threads and adns, I think adns ends up preferred at runtime. With this change and given all of the above, we actually want adns to take priority if it's set, as threads will just be the default, so drop the REQUIRED_USE. Bug: https://bugs.gentoo.org/699632 See: 60b7aaa7a70149751446237d7207ff1ca20c256e Signed-off-by: Sam James <sam@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/27111 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/curl/curl-7.85.0-r1.ebuild (renamed from net-misc/curl/curl-7.85.0.ebuild)10
1 files changed, 4 insertions, 6 deletions
diff --git a/net-misc/curl/curl-7.85.0.ebuild b/net-misc/curl/curl-7.85.0-r1.ebuild
index 15c6bef88efc..dfa9c49ff480 100644
--- a/net-misc/curl/curl-7.85.0.ebuild
+++ b/net-misc/curl/curl-7.85.0-r1.ebuild
@@ -13,15 +13,13 @@ SRC_URI="https://curl.haxx.se/download/${P}.tar.xz
LICENSE="curl"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="+adns alt-svc brotli +ftp gnutls gopher hsts +http2 idn +imap ipv6 kerberos ldap mbedtls nss +openssl +pop3 +progress-meter rtmp samba +smtp ssh ssl sslv3 static-libs test telnet +tftp threads zstd"
+IUSE="+adns alt-svc brotli +ftp gnutls gopher hsts +http2 idn +imap ipv6 kerberos ldap mbedtls nss +openssl +pop3 +progress-meter rtmp samba +smtp ssh ssl sslv3 static-libs test telnet +tftp zstd"
IUSE+=" curl_ssl_gnutls curl_ssl_mbedtls curl_ssl_nss +curl_ssl_openssl"
IUSE+=" nghttp3 quiche"
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/danielstenberg.asc
-# c-ares must be disabled for threads
-# only one default ssl provider can be enabled
+# Only one default ssl provider can be enabled
REQUIRED_USE="
- threads? ( !adns )
ssl? (
^^ (
curl_ssl_gnutls
@@ -202,8 +200,8 @@ multilib_src_configure() {
--enable-proxy
--disable-sspi
$(use_enable static-libs static)
- $(use_enable threads threaded-resolver)
- $(use_enable threads pthreads)
+ --enable-pthreads
+ --enable-threaded-resolver
--disable-versioned-symbols
--without-amissl
--without-bearssl