summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-06-17 12:17:42 -0700
committerZac Medico <zmedico@gentoo.org>2019-06-17 12:43:38 -0700
commitbd66f06b5bc5e0b650dd0844cfed1ddeed4c20c1 (patch)
treee3e9e63edb8da7913f5972af0f7f7208d0b1a616
parentdev-lang/vala: stable 0.40.15 for sparc, bug #685254 (diff)
downloadgentoo-bd66f06b.tar.gz
gentoo-bd66f06b.tar.bz2
gentoo-bd66f06b.zip
dev-util/bazel: Bump to version 0.27.0
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--dev-util/bazel/Manifest1
-rw-r--r--dev-util/bazel/bazel-0.27.0.ebuild121
2 files changed, 122 insertions, 0 deletions
diff --git a/dev-util/bazel/Manifest b/dev-util/bazel/Manifest
index d97e520cf9c3..928675d71438 100644
--- a/dev-util/bazel/Manifest
+++ b/dev-util/bazel/Manifest
@@ -2,3 +2,4 @@ DIST bazel-0.20.0-dist.zip 87602213 BLAKE2B 0d10fc89a8bc2bf91a67317d42302b894abb
DIST bazel-0.22.0-dist.zip 88633015 BLAKE2B 7cb7ef53c9acb4089b92d82679ad82739fd3c1fd3af7147e13b1474353fdf4cba1f58deed6d1880ec85fe5a07940b8df14af2701361d86e638b5c0e6924300c1 SHA512 b93cd21f0f164c118b90efba761a9492eb9894e24f13ff468defd12b86c7e67f16e51060ac2fc4c2f8dbf51b1c833d41b255fdd8107988e5babf093cfc5b3254
DIST bazel-0.24.1-dist.zip 174691842 BLAKE2B 56d42421ac6f5513f019f3b71ca0c5e7b499c199dd8d9f22ca4fdca832527a1974afffccd6bff6b1d29dc3156ee28ba7f91a9a37f2f8524da5c5f30645be97aa SHA512 a78c871eb517ec53a0d1d9592887288fa54e5e9f44b0b7dba44792a74a1ba0c98e38ff2f6094ab6e8b3add3ec4a0188de3b2489d94d419373e210d16db641774
DIST bazel-0.26.1-dist.zip 244633948 BLAKE2B 667078bda6e52f696127b7a4914ec52ab67a84f89ac957304a281268615158cc813d7d7cdac58b336dd8ef1d3cd117f1474f64f741e0a3119034dc43ca3b58b0 SHA512 f43f156947c2e9effb1f3ab79235d47d00254103b5a5aac62001008403216b2330c9062ce85d42be4fa582ad52d14ba52a47875df40c58a7e18c391684407574
+DIST bazel-0.27.0-dist.zip 247946763 BLAKE2B f061793de89144c77bd42de56c495e8b3399ac1892bdd2b0e210102ea1c2835a848432b2964ddcc6ebe77aa580efa378d46afad1faa6dec0831666f201a6dd74 SHA512 f5c6a0c789eb55790479ff839f7f959e7d0e46e5f14b5cdcd720e4dc2c36122345c9dcd6bfa803f88fb5264553a3d63ae0c8e4c7b9779bfc65183e2aaee5a666
diff --git a/dev-util/bazel/bazel-0.27.0.ebuild b/dev-util/bazel/bazel-0.27.0.ebuild
new file mode 100644
index 000000000000..3011c92b93f3
--- /dev/null
+++ b/dev-util/bazel/bazel-0.27.0.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 java-pkg-2 multiprocessing
+
+DESCRIPTION="Fast and correct automated build system"
+HOMEPAGE="https://bazel.build/"
+
+SRC_URI="https://github.com/bazelbuild/bazel/releases/download/${PV}/${P}-dist.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples test tools"
+# strip corrupts the bazel binary
+RESTRICT="strip test? ( network-sandbox ) !test? ( test )"
+RDEPEND=">=virtual/jdk-1.8:*"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ app-arch/zip"
+
+S="${WORKDIR}"
+QA_FLAGS_IGNORED="usr/bin/bazel"
+
+bazel-get-flags() {
+ local i fs=()
+ for i in ${CFLAGS}; do
+ fs+=( "--copt=${i}" "--host_copt=${i}" )
+ done
+ for i in ${CXXFLAGS}; do
+ fs+=( "--cxxopt=${i}" "--host_cxxopt=${i}" )
+ done
+ for i in ${CPPFLAGS}; do
+ fs+=( "--copt=${i}" "--host_copt=${i}" )
+ fs+=( "--cxxopt=${i}" "--host_cxxopt=${i}" )
+ done
+ for i in ${LDFLAGS}; do
+ fs+=( "--linkopt=${i}" "--host_linkopt=${i}" )
+ done
+ echo "${fs[*]}"
+}
+
+pkg_setup() {
+ echo ${PATH} | grep -q ccache && \
+ ewarn "${PN} usually fails to compile with ccache, you have been warned"
+ java-pkg-2_pkg_setup
+}
+
+src_unpack() {
+ # Only unpack the main distfile
+ unpack ${P}-dist.zip
+}
+
+src_prepare() {
+ default
+
+ # F: fopen_wr
+ # S: deny
+ # P: /proc/self/setgroups
+ # A: /proc/self/setgroups
+ # R: /proc/24939/setgroups
+ # C: /usr/lib/systemd/systemd
+ addpredict /proc
+
+ # Use standalone strategy to deactivate the bazel sandbox, since it
+ # conflicts with FEATURES=sandbox.
+ cat > "${T}/bazelrc" <<-EOF || die
+ build --verbose_failures
+ build --spawn_strategy=standalone --genrule_strategy=standalone
+
+ build --distdir="${S}/derived/distdir/"
+ build --jobs=$(makeopts_jobs) $(bazel-get-flags)
+
+ test --verbose_failures --verbose_test_summary
+ test --spawn_strategy=standalone --genrule_strategy=standalone
+ EOF
+}
+
+src_compile() {
+ export EXTRA_BAZEL_ARGS="--jobs=$(makeopts_jobs) --host_javabase=@local_jdk//:jdk"
+ VERBOSE=yes ./compile.sh || die
+
+ ./scripts/generate_bash_completion.sh \
+ --bazel=output/bazel \
+ --output=bazel-complete.bash \
+ --prepend=scripts/bazel-complete-header.bash \
+ --prepend=scripts/bazel-complete-template.bash
+}
+
+src_test() {
+ output/bazel test \
+ --verbose_failures \
+ --spawn_strategy=standalone \
+ --genrule_strategy=standalone \
+ --verbose_test_summary \
+ examples/cpp:hello-success_test || die
+ output/bazel shutdown
+}
+
+src_install() {
+ dobin output/bazel
+ newbashcomp bazel-complete.bash ${PN}
+ bashcomp_alias ${PN} ibazel
+ insinto /usr/share/zsh/site-functions
+ doins scripts/zsh_completion/_bazel
+
+ if use examples; then
+ docinto examples
+ dodoc -r examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ # could really build tools but I don't know which ones
+ # are actually used
+ if use tools; then
+ docinto tools
+ dodoc -r tools/*
+ docompress -x /usr/share/doc/${PF}/tools
+ fi
+}