summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-09-03 14:45:38 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-09-03 14:45:38 +0200
commitbd74f943caafaffd064dd2757276bfc5e232eb15 (patch)
tree087e5e88489c7933b64e04f5f9188f18428732d4
parentnet-libs/libupnp: drop 1.14.12-r1 (diff)
downloadgentoo-bd74f943.tar.gz
gentoo-bd74f943.tar.bz2
gentoo-bd74f943.zip
media-libs/gmmlib: add 22.1.8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--media-libs/gmmlib/Manifest1
-rw-r--r--media-libs/gmmlib/gmmlib-22.1.8.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/gmmlib/Manifest b/media-libs/gmmlib/Manifest
index f13806182fdc..fc04dc498418 100644
--- a/media-libs/gmmlib/Manifest
+++ b/media-libs/gmmlib/Manifest
@@ -1 +1,2 @@
DIST intel-gmmlib-22.1.7.tar.gz 818408 BLAKE2B b7123b571bfdb2f363bb7824264b9c2ad85c5e58f2978c0fa20010c8a890157bf10da7c772b9ad987078784bf37192ec0e8e14b73980af15329609649e817fd6 SHA512 0dbf972ecd61f84b9932eb6735c73e424861f7841bee8a5e76cd4d8d28ebf7641e475f9cdb1015b4f20aca08591f8f52631ebc209efa339753b47b3a121a38fb
+DIST intel-gmmlib-22.1.8.tar.gz 818360 BLAKE2B 5a7dadaead925eddfe52770c73eea92b8f071b498a2ed8d23928c93ba3d0284d9046339b7eb641918b17bf13bbcffc071ba71ba47cc53760258b1bb39f175e17 SHA512 4520105c7ceaae30e592acce7bae65841ecdb5d74c888cf03a2308a94a63d998941665794933c8247dbae841d13386ee99b365de0c6a5676acc960386c19ca2c
diff --git a/media-libs/gmmlib/gmmlib-22.1.8.ebuild b/media-libs/gmmlib/gmmlib-22.1.8.ebuild
new file mode 100644
index 000000000000..598b7721fb10
--- /dev/null
+++ b/media-libs/gmmlib/gmmlib-22.1.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+
+inherit cmake
+
+DESCRIPTION="Intel Graphics Memory Management Library"
+HOMEPAGE="https://github.com/intel/gmmlib"
+SRC_URI="https://github.com/intel/gmmlib/archive/intel-${P}.tar.gz"
+S="${WORKDIR}/${PN}-intel-${P}"
+
+KEYWORDS="~amd64"
+LICENSE="MIT"
+SLOT="0/12.1"
+IUSE="+custom-cflags test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20.2.2_conditional_testing.patch
+ "${FILESDIR}"/${PN}-20.3.2_cmake_project.patch
+ "${FILESDIR}"/${PN}-22.1.1_custom_cflags.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ -DBUILD_TYPE="Release"
+ -DOVERRIDE_COMPILER_FLAGS="$(usex !custom-cflags)"
+ )
+
+ cmake_src_configure
+}