summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-23 22:16:32 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-23 22:16:32 +0200
commitbd7d1de2c485ade6ab3900d92bc7fa592ad9e33b (patch)
tree0698f92e21de65f2630292d7442c6971f4ea7a74
parentdev-util/bear: add py3.9 support to 2.4.4 (diff)
downloadgentoo-bd7d1de2c485ade6ab3900d92bc7fa592ad9e33b.tar.gz
gentoo-bd7d1de2c485ade6ab3900d92bc7fa592ad9e33b.tar.bz2
gentoo-bd7d1de2c485ade6ab3900d92bc7fa592ad9e33b.zip
dev-python/sqlalchemy: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sqlalchemy/Manifest1
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-1.3.23.ebuild67
2 files changed, 0 insertions, 68 deletions
diff --git a/dev-python/sqlalchemy/Manifest b/dev-python/sqlalchemy/Manifest
index e8f84a62573b..cace5abe2426 100644
--- a/dev-python/sqlalchemy/Manifest
+++ b/dev-python/sqlalchemy/Manifest
@@ -1,3 +1,2 @@
-DIST SQLAlchemy-1.3.23.tar.gz 6313652 BLAKE2B e87f67ee7ee70036b94e1708c1a59f58b1f8abad23aa26c74e2a9a2172bee5a6411b2be95bff0f1c6e39d3a0de0839adc6b43f4cde597a18d4cf930e4c37b11e SHA512 dcd1a0878fd58ee49691bb7e8a2571cb40cc942380a4fe0e66d3abb1723830f178e7b3944c5c2d69bd3aaff04cd2ca171bbabbe34f59f54bcf4b9ee2782f9570
DIST SQLAlchemy-1.3.24.tar.gz 6353598 BLAKE2B 6eb92b20fa3412a1f1398e18e902e3338320973287afa4a37477ec28d47e7422a19c3a60e6290a6da7b23512c0d818a26400958d02097def778c917f098bb3db SHA512 4f5f0a23e80e1cebe541f8748a7e794e8964d986252803b3289a7cea732ad22557e00221775332e2766b6ff16ad5d9069223f441f8880ca6d0c47011f15fee5b
DIST SQLAlchemy-1.4.11.tar.gz 7551299 BLAKE2B 65f560223f1f1656ec90a2b46b5447e92908cb7a8124f1a16f59ae04e5c22b9c4b7a30cbc0d1c8ebf31d31f544619223bdff0546fcfe6124195c4430bc8167c5 SHA512 28d5da109d754183e7f1887c652c47cd7162afec285a44ed6bc51566dc40d43cdb8cd1794f93f31b2e085488025f04243613d500936c220aaab3aedb75fb6dcd
diff --git a/dev-python/sqlalchemy/sqlalchemy-1.3.23.ebuild b/dev-python/sqlalchemy/sqlalchemy-1.3.23.ebuild
deleted file mode 100644
index b536d9b3320a..000000000000
--- a/dev-python/sqlalchemy/sqlalchemy-1.3.23.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
-PYTHON_REQ_USE="sqlite?"
-
-inherit distutils-r1 optfeature
-
-MY_PN="SQLAlchemy"
-MY_P="${MY_PN}-${PV/_beta/b}"
-
-DESCRIPTION="Python SQL toolkit and Object Relational Mapper"
-HOMEPAGE="https://www.sqlalchemy.org/ https://pypi.org/project/SQLAlchemy/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="examples +sqlite test"
-
-# Use pytest-xdist to speed up tests
-BDEPEND="
- test? (
- $(python_gen_impl_dep sqlite)
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- # Ported part of those commits to fix failing tests:
- # https://github.com/sqlalchemy/sqlalchemy/commit/c68f9fb87868c45fcadcc942ce4a35f10ff2f7ea
- # https://github.com/sqlalchemy/sqlalchemy/commit/a9b068ae564e5e775e312373088545b75aeaa1b0
- # https://github.com/sqlalchemy/sqlalchemy/commit/9e31fc74089cf565df5f275d22eb8ae5414d6e45
- "${FILESDIR}/sqlalchemy-1.3.20-pypy3.patch"
-)
-
-distutils_enable_tests pytest
-
-python_test() {
- # Use all CPUs with pytest-xdist
- pytest -n auto -vv || die "Tests failed with ${EPYTHON}"
-}
-
-python_prepare_all() {
- # Disable tests hardcoding function call counts specific to Python versions.
- rm -r test/aaa_profiling || die
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- dodoc -r examples
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- optfeature "MySQL support" dev-python/mysqlclient dev-python/pymysql \
- dev-python/mysql-connector-python
- optfeature "mssql support" dev-python/pymssql
- optfeature "postgresql support" dev-python/psycopg:2
-}