summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2021-09-14 18:49:27 +0200
committerStephan Hartmann <sultan@gentoo.org>2021-09-14 18:50:07 +0200
commitbd95389a13d2c51f12f6b09115543962a00ac58e (patch)
tree94cc04cfd917ad84f2e838a60ed61c990e119b8f
parentapp-crypt/yubikey-manager: add github upstream metadata (diff)
downloadgentoo-bd95389a.tar.gz
gentoo-bd95389a.tar.bz2
gentoo-bd95389a.zip
www-client/chromium: don't inherit PYTHONPATH from environment
Closes: https://bugs.gentoo.org/812689 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
-rw-r--r--www-client/chromium/chromium-93.0.4577.63.ebuild3
-rw-r--r--www-client/chromium/chromium-93.0.4577.82.ebuild3
-rw-r--r--www-client/chromium/chromium-94.0.4606.41.ebuild3
-rw-r--r--www-client/chromium/chromium-95.0.4636.4.ebuild3
4 files changed, 12 insertions, 0 deletions
diff --git a/www-client/chromium/chromium-93.0.4577.63.ebuild b/www-client/chromium/chromium-93.0.4577.63.ebuild
index 2a9d81c8d47f..9859d219d34f 100644
--- a/www-client/chromium/chromium-93.0.4577.63.ebuild
+++ b/www-client/chromium/chromium-93.0.4577.63.ebuild
@@ -799,6 +799,9 @@ src_compile() {
# Calling this here supports resumption via FEATURES=keepwork
python_setup
+ # Don't inherit PYTHONPATH from environment, bug #789021, #812689
+ local -x PYTHONPATH=
+
#"${EPYTHON}" tools/clang/scripts/update.py --force-local-build --gcc-toolchain /usr --skip-checkout --use-system-cmake --without-android || die
# Build mksnapshot and pax-mark it.
diff --git a/www-client/chromium/chromium-93.0.4577.82.ebuild b/www-client/chromium/chromium-93.0.4577.82.ebuild
index e68575687a20..f27fa58924e2 100644
--- a/www-client/chromium/chromium-93.0.4577.82.ebuild
+++ b/www-client/chromium/chromium-93.0.4577.82.ebuild
@@ -800,6 +800,9 @@ src_compile() {
# Calling this here supports resumption via FEATURES=keepwork
python_setup
+ # Don't inherit PYTHONPATH from environment, bug #789021, #812689
+ local -x PYTHONPATH=
+
#"${EPYTHON}" tools/clang/scripts/update.py --force-local-build --gcc-toolchain /usr --skip-checkout --use-system-cmake --without-android || die
# Build mksnapshot and pax-mark it.
diff --git a/www-client/chromium/chromium-94.0.4606.41.ebuild b/www-client/chromium/chromium-94.0.4606.41.ebuild
index 3fbd84fcf2db..5b78ebe944a8 100644
--- a/www-client/chromium/chromium-94.0.4606.41.ebuild
+++ b/www-client/chromium/chromium-94.0.4606.41.ebuild
@@ -790,6 +790,9 @@ src_compile() {
# Calling this here supports resumption via FEATURES=keepwork
python_setup
+ # Don't inherit PYTHONPATH from environment, bug #789021, #812689
+ local -x PYTHONPATH=
+
#"${EPYTHON}" tools/clang/scripts/update.py --force-local-build --gcc-toolchain /usr --skip-checkout --use-system-cmake --without-android || die
# Build mksnapshot and pax-mark it.
diff --git a/www-client/chromium/chromium-95.0.4636.4.ebuild b/www-client/chromium/chromium-95.0.4636.4.ebuild
index 02edb1ff6045..bd299825d135 100644
--- a/www-client/chromium/chromium-95.0.4636.4.ebuild
+++ b/www-client/chromium/chromium-95.0.4636.4.ebuild
@@ -791,6 +791,9 @@ src_compile() {
# Calling this here supports resumption via FEATURES=keepwork
python_setup
+ # Don't inherit PYTHONPATH from environment, bug #789021, #812689
+ local -x PYTHONPATH=
+
#"${EPYTHON}" tools/clang/scripts/update.py --force-local-build --gcc-toolchain /usr --skip-checkout --use-system-cmake --without-android || die
# Build mksnapshot and pax-mark it.