summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-04-25 13:56:51 -0500
committerAustin English <wizardedit@gentoo.org>2016-04-25 13:59:07 -0500
commitbd9688779a75331f5c27e4f65952e8421716ed82 (patch)
tree8c21edf77ab39ade66c7530385798beb5485cd59
parentdev-util/eric: fix file collision (diff)
downloadgentoo-bd968877.tar.gz
gentoo-bd968877.tar.bz2
gentoo-bd968877.zip
app-admin/amazon-ec2-init: revbump amazon-ec2-init-20101127 to -r1 and update to EAPI=6
Package-Manager: portage-2.2.26
-rw-r--r--app-admin/amazon-ec2-init/amazon-ec2-init-20101127-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/amazon-ec2-init/amazon-ec2-init-20101127-r1.ebuild b/app-admin/amazon-ec2-init/amazon-ec2-init-20101127-r1.ebuild
new file mode 100644
index 000000000000..2455a7bb844d
--- /dev/null
+++ b/app-admin/amazon-ec2-init/amazon-ec2-init-20101127-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+DESCRIPTION="Init script to setup Amazon EC2 instance parameters"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI=""
+
+# Amazon only provides x86 and amd64 Linux Xen guests, possibly FreeBSD,
+# so just don't go adding further keywords.
+KEYWORDS="-* ~amd64 ~x86"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="net-misc/wget"
+DEPEND=""
+
+src_install() {
+ newinitd "${FILESDIR}/amazon-ec2.init" amazon-ec2
+}
+
+pkg_postinst() {
+ elog "Remember to add amazon-ec2 init script to your boot runlevel"
+ elog "otherwise it won't bring up the correct interfaces and won't."
+ elog "start before the hostname has been set."
+}