summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-03 07:39:26 +0100
committerSam James <sam@gentoo.org>2023-04-03 07:39:52 +0100
commitbdac487a18df8385251bac0d45433f1a8dc8ceb4 (patch)
tree4645c27c5e21d6995f03e11f2ab0a339e16d1d82
parentdev-libs/libffi: backport HPPA improvements (diff)
downloadgentoo-bdac487a18df8385251bac0d45433f1a8dc8ceb4.tar.gz
gentoo-bdac487a18df8385251bac0d45433f1a8dc8ceb4.tar.bz2
gentoo-bdac487a18df8385251bac0d45433f1a8dc8ceb4.zip
dev-python/cffi: backport HPPA fix
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/cffi/cffi-1.15.1-r1.ebuild65
-rw-r--r--dev-python/cffi/files/cffi-1.15.1-hppa.patch59
2 files changed, 124 insertions, 0 deletions
diff --git a/dev-python/cffi/cffi-1.15.1-r1.ebuild b/dev-python/cffi/cffi-1.15.1-r1.ebuild
new file mode 100644
index 000000000000..fc58f4f7e3fb
--- /dev/null
+++ b/dev-python/cffi/cffi-1.15.1-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=setuptools
+# DO NOT ADD pypy to PYTHON_COMPAT
+# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 toolchain-funcs pypi
+
+DESCRIPTION="Foreign Function Interface for Python calling C code"
+HOMEPAGE="
+ https://cffi.readthedocs.io/
+ https://pypi.org/project/cffi/
+"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="
+ dev-libs/libffi:=
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/pycparser[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+distutils_enable_sphinx doc/source
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/cffi-1.14.0-darwin-no-brew.patch
+ "${FILESDIR}"/${P}-hppa.patch
+)
+
+src_prepare() {
+ if [[ ${CHOST} == *darwin* ]] ; then
+ # Don't obsessively try to find libffi
+ sed -i -e "s/.*\-iwithsysroot\/usr\/include\/ffi.*/\tpass/" setup.py || die
+ fi
+ distutils-r1_src_prepare
+}
+
+src_configure() {
+ tc-export PKG_CONFIG
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # these tests call pip
+ testing/cffi0/test_zintegration.py
+ )
+
+ "${EPYTHON}" -c "import _cffi_backend as backend" || die
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest c testing
+}
diff --git a/dev-python/cffi/files/cffi-1.15.1-hppa.patch b/dev-python/cffi/files/cffi-1.15.1-hppa.patch
new file mode 100644
index 000000000000..e185e7b93929
--- /dev/null
+++ b/dev-python/cffi/files/cffi-1.15.1-hppa.patch
@@ -0,0 +1,59 @@
+https://foss.heptapod.net/pypy/cffi/-/commit/ab11bfa551697cd2b61fdaa571c7975c06e6912c
+
+From ab11bfa551697cd2b61fdaa571c7975c06e6912c Mon Sep 17 00:00:00 2001
+From: John David Anglin <dave.anglin@bell.net>
+Date: Sun, 18 Dec 2022 14:52:04 -0500
+Subject: [PATCH] Fix the test failures on hppa
+
+A couple of years ago the libffi port for hppa-linux was changed from using a
+trampoline executed on the stack to the function descriptor technique used by
+ia64. This doesn't require an executable stack and is simpler. However,
+function pointers need to have the PLABEL bit set in the pointer. As a result,
+a simple cast can't be used to convert closure pointers to function pointers.
+
+python-cffi uses its own closure allocation so the problem can't be fixed in
+libffi.
+
+I added a macro CFFI_FN to do the conversion. It shouldn't affect other
+architectures. There is a similar define in libffi.
+
+Fixes: https://bugs.debian.org/1024271
+
+--HG--
+branch : hppa
+--- a/c/_cffi_backend.c
++++ b/c/_cffi_backend.c
+@@ -60,6 +60,13 @@
+ # endif
+ #endif
+
++/* Convert from closure pointer to function pointer. */
++#if defined(__hppa__) && !defined(__LP64__)
++#define CFFI_FN(f) ((void (*)(void))((unsigned int)(f) | 2))
++#else
++#define CFFI_FN(f) ((void (*)(void))f)
++#endif
++
+
+ /* Define the following macro ONLY if you trust libffi's version of
+ * ffi_closure_alloc() more than the code in malloc_closure.h.
+@@ -3191,7 +3198,7 @@ cdata_call(CDataObject *cd, PyObject *args, PyObject *kwds)
+
+ Py_BEGIN_ALLOW_THREADS
+ restore_errno();
+- ffi_call(&cif_descr->cif, (void (*)(void))(cd->c_data),
++ ffi_call(&cif_descr->cif, (void (*)(void)) CFFI_FN(cd->c_data),
+ resultdata, buffer_array);
+ save_errno();
+ Py_END_ALLOW_THREADS
+@@ -6394,7 +6401,7 @@ static PyObject *b_callback(PyObject *self, PyObject *args)
+ goto error;
+ Py_INCREF(ct);
+ cd->head.c_type = ct;
+- cd->head.c_data = (char *)closure_exec;
++ cd->head.c_data = (char *)CFFI_FN(closure_exec);
+ cd->head.c_weakreflist = NULL;
+ closure->user_data = NULL;
+ cd->closure = closure;
+--
+GitLab