summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-06-04 01:38:20 +1000
committerMichael Palimaka <kensington@gentoo.org>2017-06-04 01:38:35 +1000
commitbdb1a320ada8a638591259e36535b46835491991 (patch)
tree35aaeeb5bf7631d5c3ef8ab5682ac7b465008091
parentapp-emulation/libvirt: drop old versions (diff)
downloadgentoo-bdb1a320.tar.gz
gentoo-bdb1a320.tar.bz2
gentoo-bdb1a320.zip
app-text/poppler: fix build with jpeg or jpeg2k USE flags disabled
Thanks to those that suggested solutions on the bugs. Gentoo-bug: 619568 Gentoo-bug: 619720 Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--app-text/poppler/poppler-0.55.0-r1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-text/poppler/poppler-0.55.0-r1.ebuild b/app-text/poppler/poppler-0.55.0-r1.ebuild
index df90008fc250..d429f13df27e 100644
--- a/app-text/poppler/poppler-0.55.0-r1.ebuild
+++ b/app-text/poppler/poppler-0.55.0-r1.ebuild
@@ -111,10 +111,15 @@ src_configure() {
$(cmake-utils_use_find_package qt5 Qt5Core)
-DWITH_TIFF="$(usex tiff)"
)
+ if use jpeg; then
+ mycmakeargs+=(-DENABLE_DCTDECODER=libjpeg)
+ else
+ mycmakeargs+=(-DENABLE_DCTDECODER=none)
+ fi
if use jpeg2k; then
mycmakeargs+=(-DENABLE_LIBOPENJPEG=openjpeg2)
else
- mycmakeargs+=(-DENABLE_LIBOPENJPEG=)
+ mycmakeargs+=(-DENABLE_LIBOPENJPEG=none)
fi
if use lcms; then
mycmakeargs+=(-DENABLE_CMS=lcms2)