summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-10 05:19:06 +0000
committerSam James <sam@gentoo.org>2023-02-10 05:47:11 +0000
commitbdb55c2684cec373dc2e1c35849765954283936a (patch)
treece45bc6f1d9d95d58a1f23270c4d417c35020126
parentx11-libs/wxGTK: keyword 3.2.1 for ~loong (diff)
downloadgentoo-bdb55c26.tar.gz
gentoo-bdb55c26.tar.bz2
gentoo-bdb55c26.zip
net-misc/spice-gtk: add 0.42
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/spice-gtk/Manifest1
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.42.ebuild146
2 files changed, 147 insertions, 0 deletions
diff --git a/net-misc/spice-gtk/Manifest b/net-misc/spice-gtk/Manifest
index 446207c4b52b..31c2d1c9fe95 100644
--- a/net-misc/spice-gtk/Manifest
+++ b/net-misc/spice-gtk/Manifest
@@ -1,3 +1,4 @@
DIST spice-gtk-0.40-meson-0.63.patch.xz 5932 BLAKE2B 5188e46236024575543125226404a24490faf37e9b764e8b8e2935620c6a908f6ca93f35c2a414306bb3c6646c0e47b2fd12ced83a7829ad8c118a1188b44ed8 SHA512 7b4ea4cf48b1e95bbc81c7eaa54b135333a8dba8167959e8baa7b50398d6542f2ac3d98fdb493995abb47b2a6bfb2ac75c393dda795cf69b7335ca6e3b1ddb70
DIST spice-gtk-0.40.tar.xz 848688 BLAKE2B 1046361ca40037bca826759bd7dc86f522640d39c08b1579f8e25bc2a2510665034445f7421d4de0485df9ef868e19779000c643035842f18e16555e3a1936b3 SHA512 b6db8b56c5c36158d97b3f7690d18883c4d6076e4ed1de1763fc704f9a2397b60d6170b70882d7d0a977b32be334756b7a27d66849f53e4d3b82abb8a54a0892
DIST spice-gtk-0.41.tar.xz 827320 BLAKE2B bed8e62647ca9fde8a3b534a3d9720dee829f222442edb589e6ff569ce9a49f16e3c99bad4798a22e8a551d0d89875043c2335e2b08a80901483ace6a1948d6d SHA512 bfd97c98c8bdbc29da0f26c38dfcf75d9f17e5358d4c7fa9c36e4974d0df3ce92409ca568dfc790d43f581d00b94090d9e60154e83220a719d678b596c87fcef
+DIST spice-gtk-0.42.tar.xz 812776 BLAKE2B 406a2218d4ec0765173c911d6305cb0e043cd575c53ba51cbd53d922835b9d395873143f2388a5a02ee60ce617e32a1cb6a95008b67deec787fcf67da0d49736 SHA512 fd567e35f6d4ebfe6ef004f358dca4c41254336f55f7dd26cf67b62b2acb4866907186bd0526b7cb52b0c24020cdc8809251127498a8d357555bb0c5d3b8f137
diff --git a/net-misc/spice-gtk/spice-gtk-0.42.ebuild b/net-misc/spice-gtk/spice-gtk-0.42.ebuild
new file mode 100644
index 000000000000..1c112cadb3cb
--- /dev/null
+++ b/net-misc/spice-gtk/spice-gtk-0.42.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VALA_USE_DEPEND="vapigen"
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit desktop meson optfeature python-any-r1 readme.gentoo-r1 vala xdg
+
+DESCRIPTION="Set of GObject and Gtk objects for connecting to Spice servers and a client GUI"
+HOMEPAGE="https://www.spice-space.org https://cgit.freedesktop.org/spice/spice-gtk/"
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/spice/spice-gtk.git"
+ inherit git-r3
+
+ SPICE_PROTOCOL_VER=9999
+else
+ SRC_URI="https://www.spice-space.org/download/gtk/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+ SPICE_PROTOCOL_VER=0.14.3
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="+gtk3 +introspection lz4 mjpeg policykit sasl smartcard usbredir vala wayland webdav"
+
+# TODO:
+# * check if sys-freebsd/freebsd-lib (from virtual/acl) provides acl/libacl.h
+# * use external pnp.ids as soon as that means not pulling in gnome-desktop
+RDEPEND="
+ >=dev-libs/glib-2.46:2
+ dev-libs/json-glib:0=
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ media-libs/gstreamer:1.0[introspection?]
+ media-libs/opus
+ media-libs/libjpeg-turbo:=
+ sys-libs/zlib
+ >=x11-libs/cairo-1.2
+ >=x11-libs/pixman-0.17.7
+ x11-libs/libX11
+ gtk3? ( x11-libs/gtk+:3[introspection?] )
+ introspection? ( dev-libs/gobject-introspection )
+ dev-libs/openssl:=
+ lz4? ( app-arch/lz4 )
+ sasl? ( dev-libs/cyrus-sasl )
+ smartcard? ( app-emulation/qemu[smartcard] )
+ usbredir? (
+ sys-apps/hwdata
+ >=sys-apps/usbredir-0.4.2
+ virtual/acl
+ virtual/libusb:1
+ policykit? (
+ >=sys-auth/polkit-0.110-r1
+ )
+ )
+ webdav? (
+ net-libs/phodav:3.0
+ net-libs/libsoup:3.0
+ )
+"
+# TODO: spice-gtk has an automagic dependency on media-libs/libva without a
+# configure knob. The package is relatively lightweight so we just depend
+# on it unconditionally for now. It would be cleaner to transform this into
+# a USE="vaapi" conditional and patch the buildsystem...
+RDEPEND="${RDEPEND}
+ amd64? ( media-libs/libva:= )
+ arm64? ( media-libs/libva:= )
+ x86? ( media-libs/libva:= )
+"
+DEPEND="${RDEPEND}
+ >=app-emulation/spice-protocol-${SPICE_PROTOCOL_VER}"
+BDEPEND="
+ dev-perl/Text-CSV
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+ $(python_gen_any_dep '
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ ')
+"
+
+python_check_deps() {
+ python_has_version "dev-python/six[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/pyparsing[${PYTHON_USEDEP}]"
+}
+
+src_prepare() {
+ default
+
+ use vala && vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature gtk3 gtk)
+ $(meson_feature introspection)
+ $(meson_use mjpeg builtin-mjpeg)
+ $(meson_feature policykit polkit)
+ $(meson_feature lz4)
+ $(meson_feature sasl)
+ $(meson_feature smartcard)
+ $(meson_feature usbredir)
+ $(meson_feature vala vapi)
+ $(meson_feature webdav)
+ $(meson_feature wayland wayland-protocols)
+ )
+
+ if use elibc_musl; then
+ emesonargs+=(
+ -Dcoroutine=gthread
+ )
+ fi
+
+ if use usbredir; then
+ emesonargs+=(
+ -Dusb-acl-helper-dir=/usr/libexec
+ -Dusb-ids-path="${EPREFIX}"/usr/share/hwdata/usb.ids
+ )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use usbredir && use policykit; then
+ # bug #775554 (and bug #851657)
+ fowners root:root /usr/libexec/spice-client-glib-usb-acl-helper
+ fperms 4755 /usr/libexec/spice-client-glib-usb-acl-helper
+ fi
+
+ make_desktop_entry spicy Spicy "utilities-terminal" "Network;RemoteAccess;"
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "Sound support (via pulseaudio)" media-plugins/gst-plugins-pulse
+}