summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-02-05 20:16:14 -0500
committerCraig Andrews <candrews@gentoo.org>2019-02-05 20:16:52 -0500
commitbdb9dbb6ab9fef96dc79a6ff6868da683909f7a6 (patch)
tree88db66311507adc09ce6d0a6d6b2b3cbacd4f81c
parentapp-doc/xmltoman: arm64 stable (bug #676390) (diff)
downloadgentoo-bdb9dbb6.tar.gz
gentoo-bdb9dbb6.tar.bz2
gentoo-bdb9dbb6.zip
app-admin/needrestart: 3.4 version bump, EAPI=7
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--app-admin/needrestart/Manifest1
-rw-r--r--app-admin/needrestart/needrestart-3.4.ebuild41
-rw-r--r--app-admin/needrestart/needrestart-9999.ebuild4
3 files changed, 44 insertions, 2 deletions
diff --git a/app-admin/needrestart/Manifest b/app-admin/needrestart/Manifest
index 7e8f6d796cc3..9757a47803c7 100644
--- a/app-admin/needrestart/Manifest
+++ b/app-admin/needrestart/Manifest
@@ -3,3 +3,4 @@ DIST needrestart-3.0.tar.gz 58437 BLAKE2B 6f3b79f793dab85af2a68f3796926b958c077b
DIST needrestart-3.1.tar.gz 58882 BLAKE2B c29d7a56905b047f73743075f520116004a8eed8d88ca402e958fc6a4a430213c9ba4dec469dd1221cbad5b8c6123a9e1acb451f63c6dfdfcd11dc27bce147af SHA512 a55f4e83be676d26d815f28df2a7d56c17bd74d6c1a801f5d1ee05344853d7272dda018b3c19b7753dd6f256e793261d5581df49449c4c9577309add15d4bb70
DIST needrestart-3.2.tar.gz 59702 BLAKE2B 9eb8073a4dc6f7a402ee9ce055960663a08d3d4b11805ef4189c8416d59bda53e02f4b07f43f49b73a99eb9b82d8e94ca5757cd6c7463dcfa34949ca7e6521da SHA512 56e881d73b1bf1cbee8a94ae871c2fe350d6b31e4701fdc256bbedb0d9934111f5f201d3d7b7f25ff54f78fd450c95f4c2bad6f06de5e9ce379a393fd73280d5
DIST needrestart-3.3.tar.gz 59814 BLAKE2B bfba00dee7c0f225efcaaa80b301eb38d0ea82645f253c8bef9294102f9f4183433ed1b6efe71a9dc34c65f76364ff3fc2344e840b34f97361f3ddcd0dc9ab4b SHA512 ea2f3cbe228a6b879905bd3b3de8b5e0bb2362e8d3cd566817d2e7d519d54207ff5923eb8e49cbd8ffe8ed50729f4da04bf4d55268e806f49157860584058d50
+DIST needrestart-3.4.tar.gz 63219 BLAKE2B 892bb610001575b7e653e06380ba39bb91608db6b5cc491d1e89543a72a17f69547f2610ebe7f3e51835dc1af5a32604fe54f79b6565c9f97df194a87f5f7bdf SHA512 3d63a9c32112b1d4f5d0c6d66430323761c9e7c17f01f52d0572b64ebf113fc9b52838dada363667632ae51894312d891ae8016e8eb5cbd4e0d06fa37c603f25
diff --git a/app-admin/needrestart/needrestart-3.4.ebuild b/app-admin/needrestart/needrestart-3.4.ebuild
new file mode 100644
index 000000000000..82173bf1f12c
--- /dev/null
+++ b/app-admin/needrestart/needrestart-3.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/liske/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/liske/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Restart daemons after library updates"
+HOMEPAGE="https://fiasko-nw.net/~thomas/tag/needrestart.html https://github.com/liske/needrestart"
+
+SLOT="0"
+LICENSE="GPL-2+"
+
+RDEPEND="
+ >=sys-apps/sed-4.2.2
+ dev-lang/perl:=
+ dev-perl/libintl-perl
+ dev-perl/Module-Find
+ dev-perl/Module-ScanDeps
+ dev-perl/Proc-ProcessTable
+ dev-perl/Sort-Naturally
+ dev-perl/TermReadKey
+ sys-apps/init-system-helpers
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_install() {
+ default
+ doman man/*.1
+ dodoc -r ex
+}
diff --git a/app-admin/needrestart/needrestart-9999.ebuild b/app-admin/needrestart/needrestart-9999.ebuild
index 3019c0bacfe7..82173bf1f12c 100644
--- a/app-admin/needrestart/needrestart-9999.ebuild
+++ b/app-admin/needrestart/needrestart-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/liske/${PN}.git"