summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2022-01-24 21:57:54 +0100
committerSam James <sam@gentoo.org>2022-01-25 00:49:01 +0000
commitbdbf5f63824b45d21ae303620b5ae035ba199349 (patch)
tree184f1512579c8901039239a0ffa1bc380ff034b7
parentx11-term/gnome-terminal: fix build with meson-0.61 (diff)
downloadgentoo-bdbf5f63.tar.gz
gentoo-bdbf5f63.tar.bz2
gentoo-bdbf5f63.zip
media-sound/gnome-music: fix build with meson-0.61
Closes: https://bugs.gentoo.org/831936 Signed-off-by: Christophe Lermytte <gentoo@lermytte.be> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-sound/gnome-music/files/40.1.1-fix-build-with-meson-0.61.1.patch24
-rw-r--r--media-sound/gnome-music/gnome-music-40.1.1.ebuild4
2 files changed, 28 insertions, 0 deletions
diff --git a/media-sound/gnome-music/files/40.1.1-fix-build-with-meson-0.61.1.patch b/media-sound/gnome-music/files/40.1.1-fix-build-with-meson-0.61.1.patch
new file mode 100644
index 000000000000..4ae460ac99d7
--- /dev/null
+++ b/media-sound/gnome-music/files/40.1.1-fix-build-with-meson-0.61.1.patch
@@ -0,0 +1,24 @@
+https://gitlab.gnome.org/GNOME/gnome-music/-/commit/d9f35b542adbf6b0e1114c7c077df04212a98fc7
+https://bugs.gentoo.org/831936
+
+From: Jean Felder <jfelder@src.gnome.org>
+Date: Thu, 18 Nov 2021 12:09:26 +0100
+Subject: [PATCH] meson: Remove incorrect i18n.merge_file argument
+
+The positional argument was being silently ignored until meson 0.60.0
+where it returns a deprecation message:
+"DEPRECATION: i18n.merge_file does not take any positional
+arguments. This will become a hard error in the next Meson release."
+
+See: https://github.com/mesonbuild/meson/issues/9441
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -47,7 +47,6 @@ appdata_conf.set('appid', APPLICATION_ID)
+ appdata_conf.set('package_url', PACKAGE_URL)
+ appdata_conf.set('package_url_bug', PACKAGE_URL_BUG)
+ i18n.merge_file(
+- 'appdata',
+ input: configure_file(
+ output: PROJECT_RDNN_NAME + '.appdata.xml.in',
+ input: PROJECT_RDNN_NAME + '.appdata.xml.in.in',
+GitLab
diff --git a/media-sound/gnome-music/gnome-music-40.1.1.ebuild b/media-sound/gnome-music/gnome-music-40.1.1.ebuild
index 261d35742d1c..ff9dc73cd09e 100644
--- a/media-sound/gnome-music/gnome-music-40.1.1.ebuild
+++ b/media-sound/gnome-music/gnome-music-40.1.1.ebuild
@@ -53,6 +53,10 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}/${PV}"-fix-build-with-meson-0.61.1.patch
+)
+
RESTRICT="test" # only does desktop and appdata validation, and latter needs network to validate screenshot from https
pkg_setup() {