summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-19 07:23:24 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-19 08:02:33 +0200
commitbdc099ce76157499560252135a6a787e51886b36 (patch)
treec6a7e0e353a6db0b2524d9965803ca807fdd6381
parentdev-python/python-engineio: Bump to 4.9.1 (diff)
downloadgentoo-bdc099ce76157499560252135a6a787e51886b36.tar.gz
gentoo-bdc099ce76157499560252135a6a787e51886b36.tar.bz2
gentoo-bdc099ce76157499560252135a6a787e51886b36.zip
dev-python/pygit2: Bump to 1.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pygit2/Manifest1
-rw-r--r--dev-python/pygit2/pygit2-1.15.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pygit2/Manifest b/dev-python/pygit2/Manifest
index 4bc70f331ef5..16eb0caf46fa 100644
--- a/dev-python/pygit2/Manifest
+++ b/dev-python/pygit2/Manifest
@@ -1 +1,2 @@
DIST pygit2-1.14.1.tar.gz 765621 BLAKE2B 7761851052c5dc03f82db987166012eb2a3445d62b209bc1734e240a619d7c5e4449c1772b250dd3ba8e1605b7c94edb4d8b7ad50c92bd85833e4688ed1e92ef SHA512 0718d7f480d40a5c435c725fbfec728ebdbb70d700607662308458dd125796fce9ddcf40afa6841ddc9cb7b19a5966fb3b5c8e4a52281a7eb354381ce62b5534
+DIST pygit2-1.15.0.tar.gz 766816 BLAKE2B bc0f97cbcdb1c445bb00706ade517f4c36cf9d869f87ca919df8116fb3a4e9f29a1c43a637ae53b7e6ccfad028e0df48fad85ee1a0f334438c3fa2916247fbda SHA512 33a5805046f5f18de2ec212145f4adf26b28afb11b669e3cb4d1dc29362ea6627fde605b654d11a80d91589e3000784dfe1c79522bd8c6f1b27974b13a15ef07
diff --git a/dev-python/pygit2/pygit2-1.15.0.ebuild b/dev-python/pygit2/pygit2-1.15.0.ebuild
new file mode 100644
index 000000000000..ee3f91cf63dc
--- /dev/null
+++ b/dev-python/pygit2/pygit2-1.15.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="
+ https://github.com/libgit2/pygit2/
+ https://pypi.org/project/pygit2/
+"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND="
+ =dev-libs/libgit2-1.8*:=
+"
+BDEPEND="
+ >=dev-python/cffi-1.16.0:=[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ ${BDEPEND}
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unconditionally prevent it from using network
+ sed -i -e '/has_network/s:True:False:' test/utils.py || die
+}
+
+src_test() {
+ rm -r pygit2 || die
+ distutils-r1_src_test
+}