summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-04-05 20:51:12 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-14 18:55:47 +0300
commitbdd13ca364cef3617820a23e7e4a8da163817dfb (patch)
tree4c98eccd347a4a0eaca08d7c39716e2ae04e4ec4
parentmedia-libs/libeot: EAPI8 bump, minor ebuild improvements (diff)
downloadgentoo-bdd13ca364cef3617820a23e7e4a8da163817dfb.tar.gz
gentoo-bdd13ca364cef3617820a23e7e4a8da163817dfb.tar.bz2
gentoo-bdd13ca364cef3617820a23e7e4a8da163817dfb.zip
media-libs/libeot: EAPI8 bump, minor ebuild improvements
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/36123 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--media-libs/libeot/libeot-0.01-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/libeot/libeot-0.01-r1.ebuild b/media-libs/libeot/libeot-0.01-r1.ebuild
new file mode 100644
index 000000000000..62bab11bf0a5
--- /dev/null
+++ b/media-libs/libeot/libeot-0.01-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Library for parsing Embedded OpenType files (Microsoft embedded font 'standard')"
+HOMEPAGE="https://github.com/umanwizard/libeot"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/umanwizard/libeot.git"
+else
+ SRC_URI="https://github.com/umanwizard/libeot/archive/v${PV}.tar.gz -> ${P}.tgz"
+ KEYWORDS="~amd64 ~riscv ~x86"
+fi
+
+LICENSE="MPL-2.0"
+SLOT="0"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}