summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-10-15 11:15:45 -0400
committerCraig Andrews <candrews@gentoo.org>2021-10-15 11:17:24 -0400
commitbde4c9a48f2da15c9880bf02bf2568f578fedbd9 (patch)
treec02ed2e6c224b2852e2e75d3efa1ee8664748719
parentx11-drivers/nvidia-drivers: mention egl-wayland in gbm elog (diff)
downloadgentoo-bde4c9a48f2da15c9880bf02bf2568f578fedbd9.tar.gz
gentoo-bde4c9a48f2da15c9880bf02bf2568f578fedbd9.tar.bz2
gentoo-bde4c9a48f2da15c9880bf02bf2568f578fedbd9.zip
net-mail/onionrouter: 0.6.2 version bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--net-mail/onionrouter/Manifest1
-rw-r--r--net-mail/onionrouter/onionrouter-0.6.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-mail/onionrouter/Manifest b/net-mail/onionrouter/Manifest
index 5e359ce3fadd..ac1a8da0f39d 100644
--- a/net-mail/onionrouter/Manifest
+++ b/net-mail/onionrouter/Manifest
@@ -1 +1,2 @@
DIST onionrouter-0.6.1.tar.gz 26584 BLAKE2B e1d722ba4e7ec617e39fda54299cd71d9d47bbd34fd44a19ffef8f2349f9b238251b47d01c369223393a9d7f2e0a05c5d8b7dc9f991c7d386ba800086b8cc226 SHA512 5d08e7a7310e69e29eaba2098a62cef4b5044c207f4a78b4cfebfd2a9d18bd812b485793ff7395186d4949ad9604b4e82dc0e9b1200abf03108466bf531a6d15
+DIST onionrouter-0.6.2.tar.gz 27920 BLAKE2B e9158fe7e066968d9569fb84085a85300774f6b2a2f070216755a3444c6a0352da847a7a383bed4cd792083c1fc8d71039c2c7b3e4c0c21aeca6bcb0c440de44 SHA512 4d5db2f856d6a52dfd43b7d3fea4317a1238ba6410c1da953e1cb59519ef8c18e3b73f676beff9612a853030762570f386dca24a7d7be4add23493e0b344535e
diff --git a/net-mail/onionrouter/onionrouter-0.6.2.ebuild b/net-mail/onionrouter/onionrouter-0.6.2.ebuild
new file mode 100644
index 000000000000..396599972a75
--- /dev/null
+++ b/net-mail/onionrouter/onionrouter-0.6.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 systemd
+
+DESCRIPTION=".onion discovery via SRV DNS lookups for use with postfix"
+HOMEPAGE="https://pypi.org/project/onionrouter/ https://github.com/ehloonion/onionrouter/"
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ehloonion/onionrouter.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://pypi.io/packages/source/${PN::1}/${PN}/${P}.tar.gz"
+fi
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="$(python_gen_cond_dep '
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+')"
+BDEPEND="$(python_gen_cond_dep '
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+')"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ insinto /etc/onionrouter
+ doins "${S}/onionrouter/configs/onionrouter.ini"
+}