summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-11-01 10:57:19 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-11-01 11:06:27 +0000
commitbdf3b3987e34aa44084a4c35cf48d8e02c190919 (patch)
treeef384e98803d5a10b514d7092e181ecd6229d221
parentdev-haskell/terminfo: update to EAPI=7 (diff)
downloadgentoo-bdf3b3987e34aa44084a4c35cf48d8e02c190919.tar.gz
gentoo-bdf3b3987e34aa44084a4c35cf48d8e02c190919.tar.bz2
gentoo-bdf3b3987e34aa44084a4c35cf48d8e02c190919.zip
dev-haskell/test-framework-th: update to EAPI=7
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-haskell/test-framework-th/metadata.xml49
-rw-r--r--dev-haskell/test-framework-th/test-framework-th-0.2.4.ebuild20
2 files changed, 11 insertions, 58 deletions
diff --git a/dev-haskell/test-framework-th/metadata.xml b/dev-haskell/test-framework-th/metadata.xml
index a8fce2d224aa..b7878815d80d 100644
--- a/dev-haskell/test-framework-th/metadata.xml
+++ b/dev-haskell/test-framework-th/metadata.xml
@@ -5,53 +5,4 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- @test-framework-th@ contains two interesting functions: @defaultMainGenerator@ and @testGroupGenerator@.
-
- @defaultMainGenerator@ will extract all functions beginning with case_ or prop_ in the module and put them in a testGroup.
-
- &gt; -- file SomeModule.hs
- &gt; ( -# LANGUAGE TemplateHaskell #- )
- &gt; module SomeModule where
- &gt; import Test.Framework.TH
- &gt; import Test.Framework
- &gt; import Test.HUnit
- &gt; import Test.Framework.Providers.HUnit
- &gt; import Test.Framework.Providers.QuickCheck2
- &gt;
- &gt; -- observe this line!
- &gt; main = $(defaultMainGenerator)
- &gt; case_1 = do 1 @=? 1
- &gt; case_2 = do 2 @=? 2
- &gt; prop_reverse xs = reverse (reverse xs) == xs
- &gt; where types = xs::[Int]
-
- is the same as
-
- &gt; -- file SomeModule.hs
- &gt; ( -# LANGUAGE TemplateHaskell #- )
- &gt; module SomeModule where
- &gt; import Test.Framework.TH
- &gt; import Test.Framework
- &gt; import Test.HUnit
- &gt; import Test.Framework.Providers.HUnit
- &gt; import Test.Framework.Providers.QuickCheck2
- &gt;
- &gt; -- observe this line!
- &gt; main =
- &gt; defaultMain [
- &gt; testGroup "SomeModule" [ testCase "1" case_1, testCase "2" case_2, testProperty "reverse" prop_reverse]
- &gt; ]
- &gt;
- &gt; case_1 = do 1 @=? 1
- &gt; case_2 = do 2 @=? 2
- &gt; prop_reverse xs = reverse (reverse xs) == xs
- &gt; where types = xs::[Int]
-
- @testGroupGenerator@ is like @defaultMainGenerator@ but without @defaultMain@. It is useful if you need a function for the testgroup
- (e.g. if you want to be able to call the testgroup from another module).
- </longdescription>
- <upstream>
- <remote-id type="github">finnsson/test-generator</remote-id>
- </upstream>
</pkgmetadata>
diff --git a/dev-haskell/test-framework-th/test-framework-th-0.2.4.ebuild b/dev-haskell/test-framework-th/test-framework-th-0.2.4.ebuild
index 812e3653792f..cc8dadb87ad8 100644
--- a/dev-haskell/test-framework-th/test-framework-th-0.2.4.ebuild
+++ b/dev-haskell/test-framework-th/test-framework-th-0.2.4.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-# ebuild generated by hackport 0.3.1.9999
+# ebuild generated by hackport 0.6.6.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
-DESCRIPTION="Automagically generate the HUnit and Quickcheck code using Template Haskell"
+DESCRIPTION="Automagically generate the HUnit and Quickcheck using Template Haskell"
HOMEPAGE="https://github.com/finnsson/test-generator"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
@@ -18,9 +18,11 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="dev-haskell/haskell-src-exts:=[profile?]
- >=dev-haskell/language-haskell-extract-0.2:=[profile?]
- dev-haskell/regex-posix:=[profile?]
- dev-haskell/test-framework:=[profile?]
- >=dev-lang/ghc-6.10.4:="
+ >=dev-haskell/language-haskell-extract-0.2:=[profile?]
+ dev-haskell/regex-posix:=[profile?]
+ dev-haskell/test-framework:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6"
+ >=dev-haskell/cabal-1.6
+"