summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-05-04 21:10:57 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-05-04 21:15:05 -0400
commitbdf63dcd3d3fcb03a6d18e56c5eea93e2526b479 (patch)
treebf07ed69ec7cde7399a615bdd0fa86d65107a21d
parentsys-libs/glibc: keyword 2.39-r5 (diff)
downloadgentoo-bdf63dcd3d3fcb03a6d18e56c5eea93e2526b479.tar.gz
gentoo-bdf63dcd3d3fcb03a6d18e56c5eea93e2526b479.tar.bz2
gentoo-bdf63dcd3d3fcb03a6d18e56c5eea93e2526b479.zip
dev-php/PHPMailer: add 6.9.1
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--dev-php/PHPMailer/Manifest1
-rw-r--r--dev-php/PHPMailer/PHPMailer-6.9.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-php/PHPMailer/Manifest b/dev-php/PHPMailer/Manifest
index 0ca8829c661a..a9b232779ae2 100644
--- a/dev-php/PHPMailer/Manifest
+++ b/dev-php/PHPMailer/Manifest
@@ -1,2 +1,3 @@
DIST PHPMailer-6.5.0.tar.gz 99073 BLAKE2B dcb917233da29ab45305f7cf0405f9bb384bd4f98f062a74d94a168868d0cd92017e555bf8e7139130dd669e0a04917e3789c548b5165112d591aa403bfd56b8 SHA512 0632ec8b80c30393b00aebbadde7dd032eb2553232a100a74d69b6ed6465adf1eb3a4acca0aaf040665a978e7507aee9350b092336056ccb5306fbaea4640376
DIST PHPMailer-6.6.4.tar.gz 102883 BLAKE2B d05eca221b3058e6632ab47c3d93d5f5cc76333351c75af537642a7850c5fb77c825e53a77321e4a63d7b06e41afb468e4dd5fe2f9b5f045ae8ed6f8543ef2ac SHA512 94ef038b59f8cf840205993d994070228a4237a19c153a0a9486e68a0289468cd882b2450482bdafb15f163c526c723dff3903919de872c6888b49273b718e87
+DIST PHPMailer-6.9.1.tar.gz 109263 BLAKE2B 97820b1fb941e120839d89d928661b218555ebb58f2ccd25ed4236a656f4f48f518e7522ad5d2eb60a9d038e5e0ebdc9198597d6f1c82eb91de8953c71adeced SHA512 a02d95405ffbfdc26d214d091508c8cd61e07b7285f264cc1c7bdf6bb1427b6cdde759b627710fb20cb988ded9299bfec85e61e5749932c245e79262d6f21c06
diff --git a/dev-php/PHPMailer/PHPMailer-6.9.1.ebuild b/dev-php/PHPMailer/PHPMailer-6.9.1.ebuild
new file mode 100644
index 000000000000..ebb698c6a0d5
--- /dev/null
+++ b/dev-php/PHPMailer/PHPMailer-6.9.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Full-featured email creation and transfer class for PHP"
+HOMEPAGE="https://github.com/PHPMailer/PHPMailer"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# To help out the Composer children, the tests and examples are missing
+# from the release tarballs.
+IUSE="idn ssl"
+
+# The ctype and filter extensions get used unconditionally, with no
+# fallback and no "extension missing" exception. All of the other
+# extensions are technically optional, depending on how you use
+# PHPMailer and whether or not you're willing to settle for fallback
+# implementations.
+#
+# The insane dependency string is to prevent the ctype and filter
+# extensions from being provided by one version (i.e. slot) of PHP,
+# while intl and unicode are provided by another.
+RDEPEND="
+ ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,ssl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter,ssl] )
+ )
+ !ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter] )
+ )"
+
+src_install() {
+ # The PHPMailer class loads its language files
+ # using a relative path, so we need to keep the "src" here.
+ insinto "/usr/share/php/${PN}"
+ doins -r language src
+
+ dodoc README.md SECURITY.md
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog "Upstream no longer provides an autoloader, so you will need"
+ elog "to include each source file (for example: PHPMailer.php,"
+ elog "Exception.php,...) that you need."
+}