summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-08-03 09:57:31 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-08-03 10:12:58 +0200
commitbe013dc096ae369a9a0eb8b180dea22cbd8ca0df (patch)
tree30fa99a35433de1f9536b7e3fee3442be1ea9439
parentapp-text/zathura: bump girara dependency (bug 590182, thanks Toralf Förster). (diff)
downloadgentoo-be013dc0.tar.gz
gentoo-be013dc0.tar.bz2
gentoo-be013dc0.zip
media-libs/alsa-lib: Bump to version 1.1.2
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--media-libs/alsa-lib/Manifest1
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.1.2.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/media-libs/alsa-lib/Manifest b/media-libs/alsa-lib/Manifest
index 576469ce7fa3..7d92e8b4b15d 100644
--- a/media-libs/alsa-lib/Manifest
+++ b/media-libs/alsa-lib/Manifest
@@ -1,3 +1,4 @@
DIST alsa-lib-1.0.29.tar.bz2 905417 SHA256 73043c35eb9636be0f4af6a240235c213f12a25feb1f04aeeac8cb7e30fcbdd0 SHA512 c9c2dcd3105abadcfdff104770a1f7683d83f6b9df64eebe9f9efc1ecab3ca4cef43718b5b15526bdabf2862ce55ec665732bb0390fc8e6492e2c1cebec9294c WHIRLPOOL 330877960733e847c12f133f93acc58a2053303b4437c5aaf21e2c4df0c47389df28ed093ab6606ee3cb854389b359d981dc547fba08bab03cff1c99f93e72d8
DIST alsa-lib-1.1.0.tar.bz2 929874 SHA256 dfde65d11e82b68f82e562ab6228c1fb7c78854345d3c57e2c68a9dd3dae1f15 SHA512 2939d0b621c1c619b0a492b05f2e84f354d588c9cc982d93dbcf01c582319258dd5f803ff5c10be52343cd8827d690f671ab5b20ad586a0ee371f0949c9e98f4 WHIRLPOOL b82bdf72ed5cd23517270a1e81407670d2af2794fa14decf9513643f270281affe978eef9bc61cd76eea529751461ab016fc0e187b36e2527bec02674e5ee8a8
DIST alsa-lib-1.1.1.tar.bz2 932105 SHA256 8ac76c3144ed2ed49da7622ab65ac5415205913ccbedde877972383cbc234269 SHA512 dacd0a74adc682ac0034cbeba2de3d1a141e0ac2e564c9e04dae202ffaf87ef3a1e01307afc2fd2d9cfe679e5b101c379f9b6ea5f7ccceeed14a427bd5232bc7 WHIRLPOOL c383ee51592e87c08a1bb25e358482afe6116b4feaf45121296fb887e77c930fb3b8e864f3265bf7bd4c57227fdcbc71994031bb9356621d69de7a252bed65a4
+DIST alsa-lib-1.1.2.tar.bz2 947423 SHA256 d38dacd9892b06b8bff04923c380b38fb2e379ee5538935ff37e45b395d861d6 SHA512 a6c6675b1fd86955ef5072b9e6090795fc6b0b16f32481bece049e5f100e689be48b6416ff7cf36abfc67e0b94f420e08c15ff13a9701987d6bb69a8fa567e8a WHIRLPOOL 7aa68f305cb5ad58e9bdaeb3eee5fa7a37e9f606640789a9c778ff1bfd9b458d80e6ccfa9f73f9ad5b3a229ea988fa9b6d64b929c87f64ea9376a778f30eed0d
diff --git a/media-libs/alsa-lib/alsa-lib-1.1.2.ebuild b/media-libs/alsa-lib/alsa-lib-1.1.2.ebuild
new file mode 100644
index 000000000000..ce747686f1d6
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.1.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# no support for python3_2 or above yet wrt #471326
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils multilib multilib-minimal python-single-r1
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="alisp debug doc elibc_uclibc python"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-soundlibs-20130224-r1
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ find . -name Makefile.am -exec sed -i -e '/CFLAGS/s:-g -O2::' {} + || die
+ # https://bugs.gentoo.org/509886
+ use elibc_uclibc && { sed -i -e 's:oldapi queue_timer:queue_timer:' test/Makefile.am || die; }
+ # https://bugs.gentoo.org/545950
+ sed -i -e '5s:^$:\nAM_CPPFLAGS = -I$(top_srcdir)/include:' test/lsb/Makefile.am || die
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myconf
+ # enable Python only on final ABI
+ if multilib_is_native_abi; then
+ myconf="$(use_enable python)"
+ else
+ myconf="--disable-python"
+ fi
+ use elibc_uclibc && myconf+=" --without-versioned"
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-maintainer-mode \
+ --enable-shared \
+ --disable-resmgr \
+ --enable-rawmidi \
+ --enable-seq \
+ --enable-aload \
+ $(use_with debug) \
+ $(use_enable alisp) \
+ ${myconf}
+}
+
+multilib_src_compile() {
+ emake
+
+ if multilib_is_native_abi && use doc; then
+ emake doc
+ fgrep -Zrl "${S}" doc/doxygen/html | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ if multilib_is_native_abi && use doc; then
+ docinto html
+ dodoc -r doc/doxygen/html/.
+ fi
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --all
+ find "${ED}"/usr/$(get_libdir)/alsa-lib -name '*.a' -exec rm -f {} +
+ docinto ""
+ dodoc ChangeLog doc/asoundrc.txt NOTES TODO
+}