summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-01-11 21:36:18 +0000
committerJustin Lecher <jlec@gentoo.org>2017-01-12 19:18:41 +0000
commitbe06d6e1587f7948233cab040b1fb7a65bebb4e6 (patch)
tree6b1d274a1c87034d572efae6e5933eb525c8bca9
parentsys-apps/hwloc: Fix bug #581004 properly. (diff)
downloadgentoo-be06d6e1587f7948233cab040b1fb7a65bebb4e6.tar.gz
gentoo-be06d6e1587f7948233cab040b1fb7a65bebb4e6.tar.bz2
gentoo-be06d6e1587f7948233cab040b1fb7a65bebb4e6.zip
dev-python/pytest-django: Relax dependency version
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/pytest-django/pytest-django-2.9.1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-python/pytest-django/pytest-django-2.9.1.ebuild b/dev-python/pytest-django/pytest-django-2.9.1.ebuild
index 4c225165f6d6..51e676ea4872 100644
--- a/dev-python/pytest-django/pytest-django-2.9.1.ebuild
+++ b/dev-python/pytest-django/pytest-django-2.9.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -25,6 +25,13 @@ DEPEND="${RDEPEND}
# https://github.com/pytest-dev/pytest-django/issues/290
RESTRICT=test
+src_prepare() {
+ sed \
+ -e '/setuptools_scm/s:==1.8.0::g' \
+ -i setup.py || die
+ distutils-r1_src_prepare
+}
+
python_test() {
PYTEST_PLUGINS=${PN/-/_} \
py.test --ds=pytest_django_test.settings_sqlite_file --strict -r fEsxXw || die