summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2024-01-08 19:23:51 +0200
committerMart Raudsepp <leio@gentoo.org>2024-01-08 19:23:51 +0200
commitbe08f45d769856b392219c9ed143bbb421d65974 (patch)
tree138eb3a9a040b08503e81844a5e783c04cf20c75
parentapp-shells/bash: backport memory leak fix for 5.2 (diff)
downloadgentoo-be08f45d769856b392219c9ed143bbb421d65974.tar.gz
gentoo-be08f45d769856b392219c9ed143bbb421d65974.tar.bz2
gentoo-be08f45d769856b392219c9ed143bbb421d65974.zip
x11-libs/libnotify: drop 0.8.2
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--x11-libs/libnotify/Manifest1
-rw-r--r--x11-libs/libnotify/libnotify-0.8.2.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/x11-libs/libnotify/Manifest b/x11-libs/libnotify/Manifest
index e43dd1a98565..7fc95d3f794f 100644
--- a/x11-libs/libnotify/Manifest
+++ b/x11-libs/libnotify/Manifest
@@ -1,2 +1 @@
-DIST libnotify-0.8.2.tar.xz 105912 BLAKE2B d014d01e624a072a1a4e60d8606833e790fc9b47a93229486a7c7860d3d90eaae6bcf3f4f78599db8b2c0ed3d35569a1b20d8a8deb08c8fa5be98330b1205f60 SHA512 c9eb0630520382228237ae914654e27ba973efe29a27d040c2462016bd3e0704889aabc5d04d51906951cd404d7edd64262860b7636afd03dd76dedcf1f77cae
DIST libnotify-0.8.3.tar.xz 106008 BLAKE2B 05852c866dc91d42cf01804333605ecb546f7d779b143fabc341752263c8cacea9acda40bb60af90dbc84ab8327ba99966e09924ccc337f7a97909b95d39a874 SHA512 e55073fdf418a4c04375825221edc92ab6a01201b83db2a1f1530f8f91f7da9da32327452b0785251790553517dcc717cfe623142450691b7dd247ec9164cffb
diff --git a/x11-libs/libnotify/libnotify-0.8.2.ebuild b/x11-libs/libnotify/libnotify-0.8.2.ebuild
deleted file mode 100644
index 7ad4e2741ab4..000000000000
--- a/x11-libs/libnotify/libnotify-0.8.2.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit gnome.org meson-multilib xdg-utils
-
-DESCRIPTION="A library for sending desktop notifications"
-HOMEPAGE="https://gitlab.gnome.org/GNOME/libnotify"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="gtk-doc +introspection test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="gtk-doc? ( introspection )"
-
-RDEPEND="
- >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}]
- x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
- introspection? ( >=dev-libs/gobject-introspection-1.54:= )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- >=dev-libs/gobject-introspection-common-1.32
- dev-util/glib-utils
- virtual/pkgconfig
- app-text/docbook-xsl-ns-stylesheets
- dev-libs/libxslt
- gtk-doc? (
- dev-util/gi-docgen
- app-text/docbook-xml-dtd:4.1.2
- )
- test? ( x11-libs/gtk+:3[${MULTILIB_USEDEP}] )
-"
-IDEPEND="app-eselect/eselect-notify-send"
-PDEPEND="virtual/notification-daemon"
-
-src_prepare() {
- default
- xdg_environment_reset
-}
-
-multilib_src_configure() {
- local emesonargs=(
- $(meson_use test tests)
- $(meson_native_use_feature introspection)
- $(meson_native_use_bool gtk-doc gtk_doc)
- -Ddocbook_docs=disabled
- )
- meson_src_configure
-}
-
-multilib_src_install_all() {
- mv "${ED}"/usr/bin/{,libnotify-}notify-send || die #379941
-
- einstalldocs
-
- if use gtk-doc; then
- mkdir -p "${ED}"/usr/share/gtk-doc/ || die
- mv "${ED}"/usr/share/{doc,gtk-doc}/libnotify-0 || die
- fi
-}
-
-pkg_postinst() {
- eselect notify-send update ifunset
-}
-
-pkg_postrm() {
- eselect notify-send update ifunset
-}