summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-03-03 02:12:50 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-03-03 03:07:09 +0100
commitbe2ff53a2aec1548130a734bddc3c71e0e4856c4 (patch)
treebb189b7dc42073693f05cf46ea3ea9a1c7ad9330
parentdev-python/aiohttp-cors: Bump to v0.6.0 (diff)
downloadgentoo-be2ff53a.tar.gz
gentoo-be2ff53a.tar.bz2
gentoo-be2ff53a.zip
dev-python/libcloud: Bump to v1.5.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-python/libcloud/Manifest1
-rw-r--r--dev-python/libcloud/libcloud-1.5.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/libcloud/Manifest b/dev-python/libcloud/Manifest
index 3ec96368b8ad..7ec75e74f377 100644
--- a/dev-python/libcloud/Manifest
+++ b/dev-python/libcloud/Manifest
@@ -1,2 +1,3 @@
DIST apache-libcloud-0.15.1.tar.bz2 570953 BLAKE2B 1baca706ac57d76baf4f83824ea0fccaccec51f38114a0103777e2965e67ad9cd96ad46459841ea702d72f8f0c3ce166037714d04f91c1f2369ddf6f455ffa63 SHA512 0cbc02c955cb91e135d73a5198ad216d0f91fa942b88dd1ffc1c46a487190f45500f003d2825cdb4f6c96c4ca7e5cf2681709769b0c2d8801b08e5a41b3d69b0
DIST apache-libcloud-1.2.1.tar.bz2 992983 BLAKE2B e3caccd2814f3b25fa96fbc21972fb3694a6f5e55663564f712b98b64a60e577baf1da0295b914fef2440a461f6fa16f313e83bde252360ac6786995527afc04 SHA512 12e239f286d8eb523597488998582be02d6e8cd4e21a8fa7c639c829ba622833e4292ac4cd7cbc8b94670e19ec1711cb0032bc72433f421bf2ba2b8c70dcd954
+DIST apache-libcloud-1.5.0.tar.bz2 1258553 BLAKE2B 9cad0f61ab8505deea99c15022da92caf24295480d16bedf9c735c1117a055c94162cdcb331734c572f375de3ba10b499d5ed46a5a11f1e634d272e69748ef79 SHA512 91c10d164f56c9f75c6e5633802c3cf31046ab7a3ae554b73310b1da2d882ac1f8e90aaf3462db57ac0949dfd66cb840ec8fc6e6b79c46128668f13183d47b30
diff --git a/dev-python/libcloud/libcloud-1.5.0.ebuild b/dev-python/libcloud/libcloud-1.5.0.ebuild
new file mode 100644
index 000000000000..414bc3b2bb65
--- /dev/null
+++ b/dev-python/libcloud/libcloud-1.5.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# py3 dropped due to failing tests once lockfile installed
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Unified Interface to the Cloud - python support libs"
+HOMEPAGE="https://libcloud.apache.org/"
+SRC_URI="mirror://apache/${PN}/apache-${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/lockfile[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]' python{2_7,3_4} pypy)
+ )"
+
+# Known test failures
+RESTRICT="test"
+
+S="${WORKDIR}/apache-${P}"
+
+python_prepare_all() {
+ if use examples; then
+ mkdir examples
+ mv example_*.py examples || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ cp libcloud/test/secrets.py-dist libcloud/test/secrets.py || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}