summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-29 14:30:03 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-29 14:30:03 +0200
commitbe32513821ebdc64d042d843c4d1849e19c3ff63 (patch)
tree616294b01c198c8e35980de1ef8edbd0df50c09c
parentacct-group/fingerprint: New package (diff)
downloadgentoo-be32513821ebdc64d042d843c4d1849e19c3ff63.tar.gz
gentoo-be32513821ebdc64d042d843c4d1849e19c3ff63.tar.bz2
gentoo-be32513821ebdc64d042d843c4d1849e19c3ff63.zip
sys-auth/thinkfinger: Port to EAPI 7 and GLEP 81
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sys-auth/thinkfinger/files/0.3-carriagereturn.patch4
-rw-r--r--sys-auth/thinkfinger/files/0.3-direct_set_config_usb_hello.patch6
-rw-r--r--sys-auth/thinkfinger/files/0.3-send-sync-event.patch4
-rw-r--r--sys-auth/thinkfinger/files/0.3-tftoolgroup.patch4
-rw-r--r--sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild48
5 files changed, 33 insertions, 33 deletions
diff --git a/sys-auth/thinkfinger/files/0.3-carriagereturn.patch b/sys-auth/thinkfinger/files/0.3-carriagereturn.patch
index 731f1531947b..528731e27d9e 100644
--- a/sys-auth/thinkfinger/files/0.3-carriagereturn.patch
+++ b/sys-auth/thinkfinger/files/0.3-carriagereturn.patch
@@ -1,5 +1,5 @@
---- pam/pam_thinkfinger-uinput.c 2007-02-27 17:52:50.000000000 +0100
-+++ pam/pam_thinkfinger-uinput.c 2009-02-17 13:56:02.013033249 +0100
+--- a/pam/pam_thinkfinger-uinput.c
++++ b/pam/pam_thinkfinger-uinput.c
@@ -95,6 +95,7 @@
/* our single key keyboard */
i = ioctl (*fd, UI_SET_EVBIT, EV_KEY) < 0;
diff --git a/sys-auth/thinkfinger/files/0.3-direct_set_config_usb_hello.patch b/sys-auth/thinkfinger/files/0.3-direct_set_config_usb_hello.patch
index 06723ad1306c..2de27ab459ad 100644
--- a/sys-auth/thinkfinger/files/0.3-direct_set_config_usb_hello.patch
+++ b/sys-auth/thinkfinger/files/0.3-direct_set_config_usb_hello.patch
@@ -1,7 +1,5 @@
-Index: libthinkfinger/libthinkfinger.c
-===================================================================
---- libthinkfinger/libthinkfinger.c (revision 118)
-+++ libthinkfinger/libthinkfinger.c (working copy)
+--- a/libthinkfinger/libthinkfinger.c
++++ b/libthinkfinger/libthinkfinger.c
@@ -265,18 +265,7 @@
int retval = -1;
char dummy[] = "\x10";
diff --git a/sys-auth/thinkfinger/files/0.3-send-sync-event.patch b/sys-auth/thinkfinger/files/0.3-send-sync-event.patch
index 39e0edb27ba1..0fbba6e9c2ae 100644
--- a/sys-auth/thinkfinger/files/0.3-send-sync-event.patch
+++ b/sys-auth/thinkfinger/files/0.3-send-sync-event.patch
@@ -1,5 +1,5 @@
---- pam/pam_thinkfinger-uinput.c 2009-12-27 18:42:26.000000000 +0100
-+++ pam/pam_thinkfinger-uinput.c 2009-12-27 18:41:55.000000000 +0100
+--- a/pam/pam_thinkfinger-uinput.c
++++ b/pam/pam_thinkfinger-uinput.c
@@ -34,27 +34,40 @@
int uinput_cr (int *fd)
{
diff --git a/sys-auth/thinkfinger/files/0.3-tftoolgroup.patch b/sys-auth/thinkfinger/files/0.3-tftoolgroup.patch
index 169b7cefe286..251c6357b177 100644
--- a/sys-auth/thinkfinger/files/0.3-tftoolgroup.patch
+++ b/sys-auth/thinkfinger/files/0.3-tftoolgroup.patch
@@ -1,5 +1,5 @@
---- tf-tool/tf-tool.c 2007-03-30 11:00:45.000000000 +0200
-+++ tf-tool/tf-tool.c 2009-02-18 14:57:24.316197097 +0100
+--- a/tf-tool/tf-tool.c
++++ b/tf-tool/tf-tool.c
@@ -26,6 +26,9 @@
#include <errno.h>
#include <libgen.h>
diff --git a/sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild b/sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild
index 730d8745e2c1..5148727daa45 100644
--- a/sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild
+++ b/sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
-inherit autotools-utils user linux-info pam
+inherit linux-info pam
DESCRIPTION="Support for the UPEK/SGS Thomson fingerprint reader, common in Thinkpads"
HOMEPAGE="http://thinkfinger.sourceforge.net/"
@@ -12,13 +12,15 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug pam static-libs"
+IUSE="debug pam"
-RDEPEND="virtual/libusb:0
+DEPEND="
+ virtual/libusb:0
pam? ( sys-libs/pam )"
-DEPEND="${RDEPEND}
- sys-devel/libtool
- virtual/pkgconfig"
+RDEPEND="
+ ${DEPEND}
+ acct-group/fingerprint"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${PV}-direct_set_config_usb_hello.patch
@@ -29,7 +31,7 @@ PATCHES=(
)
pkg_setup() {
- if use pam ; then
+ if use pam; then
CONFIG_CHECK="~INPUT_UINPUT"
ERROR_CFG="Your kernel needs uinput for the pam module to work"
check_extra_config
@@ -37,43 +39,43 @@ pkg_setup() {
}
src_configure() {
- local myeconfargs=(
+ econf \
+ --disable-static \
$(use_enable pam) \
$(use_enable debug usb-debug) \
- "--with-securedir=$(getpam_mod_dir)"
- )
- autotools-utils_src_configure
+ --with-securedir="$(getpam_mod_dir)"
+
+ rm README.in || die
}
src_install() {
- DOCS=( AUTHORS ChangeLog NEWS README )
- autotools-utils_src_install
+ default
keepdir /etc/pam_thinkfinger
insinto /lib/udev/rules.d
doins "${FILESDIR}"/60-thinkfinger.rules
-}
-pkg_preinst() {
- enewgroup fingerprint
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
}
pkg_postinst() {
fowners root:fingerprint /etc/pam_thinkfinger
fperms 710 /etc/pam_thinkfinger
+
elog "Use tf-tool --acquire to take a finger print"
elog "tf-tool will write the finger print file to /tmp/test.bir"
- elog ""
- if use pam ; then
+ elog
+
+ if use pam; then
elog "To add a fingerprint to PAM, use tf-tool --add-user USERNAME"
- elog ""
+ elog
elog "Add the following to /etc/pam.d/system-auth after pam_env.so"
elog "auth sufficient pam_thinkfinger.so"
- elog ""
+ elog
elog "Your system-auth should look similar to:"
elog "auth required pam_env.so"
elog "auth sufficient pam_thinkfinger.so"
elog "auth sufficient pam_unix.so try_first_pass likeauth nullok"
- elog ""
fi
}