summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-10 16:24:40 +0100
committerSam James <sam@gentoo.org>2021-05-10 16:25:43 +0100
commitbe44b523eb78e10f9a594f4f900af44eaeb36b61 (patch)
treeea72173ae35ef18d79e33d5016e48e4b7e3fceef
parentdev-ml/opam-installer: remove building ext library (already in tree) (diff)
downloadgentoo-be44b523eb78e10f9a594f4f900af44eaeb36b61.tar.gz
gentoo-be44b523eb78e10f9a594f4f900af44eaeb36b61.tar.bz2
gentoo-be44b523eb78e10f9a594f4f900af44eaeb36b61.zip
dev-util/re2c: regenerate autotools for nonbash patch
While the used patch does modify configure directly, this is fragile and sometimes causes maintainer mode to be triggered regardless. Let's regenerate autotools to be safe given a user managed to hit this. Closes: https://bugs.gentoo.org/779187 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/re2c/re2c-2.1.1-r1.ebuild12
1 files changed, 12 insertions, 0 deletions
diff --git a/dev-util/re2c/re2c-2.1.1-r1.ebuild b/dev-util/re2c/re2c-2.1.1-r1.ebuild
index 29518e3a9d51..854354f08251 100644
--- a/dev-util/re2c/re2c-2.1.1-r1.ebuild
+++ b/dev-util/re2c/re2c-2.1.1-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit autotools
+
DESCRIPTION="tool for generating C-based recognizers from regular expressions"
HOMEPAGE="http://re2c.org/"
SRC_URI="https://github.com/skvadrik/re2c/releases/download/${PV}/${P}.tar.xz"
@@ -14,6 +16,16 @@ IUSE="debug"
PATCHES=("${FILESDIR}"/${P}-sh.patch)
+src_prepare() {
+ default
+
+ # Only needed for the sh patch
+ # Despite the patch modifying the configure directly,
+ # this is sometimes fragile and triggers maintainer mode anyway.
+ # bug #779187
+ eautoreconf
+}
+
src_configure() {
econf \
--enable-golang \