summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-01 17:47:56 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-01 17:51:03 +0200
commitbe4a06cfd5bcb363ea673a139a044ce7d3a2dae2 (patch)
treed2fc53852e6b352493f112cb7e7051749c0c0158
parentdev-lang/eisl: bump to 3.90 (diff)
downloadgentoo-be4a06cfd5bcb363ea673a139a044ce7d3a2dae2.tar.gz
gentoo-be4a06cfd5bcb363ea673a139a044ce7d3a2dae2.tar.bz2
gentoo-be4a06cfd5bcb363ea673a139a044ce7d3a2dae2.zip
dev-python/sentry-sdk: Update deselects/skips for 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-2.0.1.ebuild79
1 files changed, 17 insertions, 62 deletions
diff --git a/dev-python/sentry-sdk/sentry-sdk-2.0.1.ebuild b/dev-python/sentry-sdk/sentry-sdk-2.0.1.ebuild
index 714519a746bd..2098315872e0 100644
--- a/dev-python/sentry-sdk/sentry-sdk-2.0.1.ebuild
+++ b/dev-python/sentry-sdk/sentry-sdk-2.0.1.ebuild
@@ -61,19 +61,13 @@ python_test() {
# tests require Internet access
tests/integrations/httpx/test_httpx.py
tests/integrations/requests/test_requests.py
- tests/integrations/stdlib/test_httplib.py
- tests/integrations/flask/test_flask.py
tests/integrations/django/test_basic.py
tests/integrations/socket/test_socket.py
# wtf is it supposed to do?!
tests/integrations/gcp/test_gcp.py
- # broken by rq-1.10.1 (optional dep)
- tests/integrations/rq/test_rq.py
- # fastapi is not packaged
- tests/integrations/asgi/test_fastapi.py
# TODO
tests/integrations/bottle
- # TODO: causes breakage in other tests
+ # TODO: most of them hang
tests/integrations/starlette
# TODO
tests/integrations/tornado
@@ -89,70 +83,31 @@ python_test() {
local EPYTEST_DESELECT=(
# hangs
- 'tests/test_transport.py::test_transport_works'
- # TODO
- 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
- tests/test_client.py::test_databag_depth_stripping
- tests/test_client.py::test_databag_string_stripping
- tests/test_client.py::test_databag_breadth_stripping
- tests/integrations/asgi/test_asgi.py::test_auto_session_tracking_with_aggregates
- tests/integrations/asgi/test_asgi.py::test_websocket
- tests/integrations/aiohttp/test_aiohttp.py::test_transaction_style
- tests/integrations/aiohttp/test_aiohttp.py::test_traces_sampler_gets_request_object_in_sampling_context
- tests/integrations/django/test_data_scrubbing.py::test_scrub_django_custom_session_cookies_filtered
- # incompatible version?
- tests/integrations/falcon/test_falcon.py
- tests/integrations/sqlalchemy/test_sqlalchemy.py::test_large_event_not_truncated
- tests/integrations/django/test_data_scrubbing.py::test_scrub_django_session_cookies_{filtered,removed}
- # test_circular_references: apparently fragile
- 'tests/integrations/threading/test_threading.py::test_circular_references'
- # test for new feature, fails with IndexError
- tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
- # TODO
- tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
- tests/integrations/wsgi/test_wsgi.py::test_profile_sent_when_profiling_enabled
- tests/test_profiler.py::test_sample_buffer
- tests/test_profiler.py::test_thread_scheduler_takes_first_samples
- tests/test_profiler.py::test_thread_scheduler_takes_more_samples
- tests/test_profiler.py::test_thread_scheduler_single_background_thread
- # broken with py3.11, *shrug*
- tests/test_profiler.py::test_extract_stack_with_max_depth
- # TODO
- tests/integrations/sqlalchemy/test_sqlalchemy.py::test_long_sql_query_preserved
- tests/integrations/sqlalchemy/test_sqlalchemy.py::test_engine_name_not_string
- tests/test_scrubber.py::test_breadcrumb_extra_scrubbing
- tests/test_scrubber.py::test_span_data_scrubbing
- # this is not even funny
- tests/test_utils.py::test_installed_modules
- # flaky hypothesis stuff
- tests/test_serializer.py::test_bytes_serialization_repr_many
- # TODO
- tests/integrations/aiohttp/test_aiohttp.py::test_basic
- tests/tracing/test_decorator_py3.py::test_trace_decorator_{,a}sync_py3
- # crashes Python
- tests/integrations/grpc/test_grpc_aio.py
- # hangs
tests/integrations/threading/test_threading.py::test_propagates_threadpool_hub
+ # broken teardown?
+ tests/test_client.py::test_uwsgi_warnings
+ # too many dependencies installed, sigh
+ tests/test_new_scopes_compat_event.py
+ # Internet
+ tests/integrations/stdlib/test_httplib.py::test_outgoing_trace_headers
+ tests/integrations/stdlib/test_httplib.py::test_outgoing_trace_headers_head_sdk
# TODO
- tests/test_utils.py::test_default_release
+ tests/integrations/aiohttp/test_aiohttp.py::test_basic
+ tests/integrations/django/test_data_scrubbing.py::test_scrub_django_custom_session_cookies_filtered
tests/integrations/sqlalchemy/test_sqlalchemy.py::test_orm_queries
- tests/integrations/sqlalchemy/test_sqlalchemy.py::test_transactions
tests/integrations/sqlalchemy/test_sqlalchemy.py::test_query_source
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_transactions
tests/integrations/stdlib/test_subprocess.py::test_subprocess_basic
tests/integrations/threading/test_threading.py
tests/integrations/wsgi/test_wsgi.py
- 'tests/utils/test_contextvars.py::test_leaks[threads]'
- # skipped without gevent but breaks stuff via broken teardown?
- tests/test_metrics.py::test_no_metrics_with_gevent
- # TODO
- tests/utils/test_contextvars.py::test_leaks
- # broken teardown?
- tests/test_client.py::test_uwsgi_warnings
- # too many dependencies installed, sigh
- tests/test_new_scopes_compat_event.py
- # TODO
+ tests/test_basics.py::test_auto_enabling_integrations_catches_import_error
+ tests/test_client.py::test_databag_breadth_stripping
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_utils.py::test_default_release
tests/tracing/test_sampling.py::test_records_lost_event_only_if_traces_sample_rate_enabled
tests/tracing/test_sampling.py::test_records_lost_event_only_if_traces_sampler_enabled
+ tests/utils/test_contextvars.py::test_leaks
)
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1