summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-04-02 10:48:20 +1200
committerKent Fredric <kentnl@gentoo.org>2017-04-02 10:49:09 +1200
commitbe61ad73a22b4a94921289d9bb206a86748028ed (patch)
tree9132519d08760188316a588fe95934a765e62d9f
parentmedia-libs/glew: Update metadata (diff)
downloadgentoo-be61ad73.tar.gz
gentoo-be61ad73.tar.bz2
gentoo-be61ad73.zip
dev-perl/Net-SSLeay: Bump to version 1.810.0
Upstream: - Fix RSA_get_key_parameters - Fix memory leak in X509_get_subjectAltNames - Fix Makefile.PL without '.' in @INC - Fix get_my_thread_id to work when ERRSV not defined Bug: https://bugs.gentoo.org/613750 Package-Manager: Portage-2.3.4, Repoman-2.3.2
-rw-r--r--dev-perl/Net-SSLeay/Manifest1
-rw-r--r--dev-perl/Net-SSLeay/Net-SSLeay-1.810.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-perl/Net-SSLeay/Manifest b/dev-perl/Net-SSLeay/Manifest
index e3e2d4491f16..51d68bb1f8e7 100644
--- a/dev-perl/Net-SSLeay/Manifest
+++ b/dev-perl/Net-SSLeay/Manifest
@@ -1 +1,2 @@
DIST Net-SSLeay-1.80.tar.gz 395820 SHA256 a541a66d59fc5f9bb7af09d3a0b68305e4c43ba9488b12915728fd282ea01b93 SHA512 03b5f2ba86d20f31ef50029af94b1bcf513c7b99d9666a04e83aba4f7c8cce3e30daf6df85932619949f059177660f49a928488e61b967a12dd4aec41eafad95 WHIRLPOOL 8f11141c3caaa1e9d32368183ab9742e8c1bba5efd6702efa9e4142b6f54871f2380cdb6fe3d1aef2b63db388bdf69f3167d592eca935d93af484dd00511b03c
+DIST Net-SSLeay-1.81.tar.gz 396631 SHA256 00cbb6174e628b42178e1445c9fd5a3c5ae2cfd6a5a43e03610ba14786f21b7d SHA512 8d4b72ede74ea22cf2ed681a8441f40965331cd5d4442c19677cf5bc7c1e61ed1e50d0f3a4f1b272428485bcc132ec99b0c75344ca43e8a34a9dd15539719f55 WHIRLPOOL 125710fcabce6f9ba2515bb04a90513d0f2ab2f57546187044bc7f4f45b0ba354f747674fcebfad41dced608603e8c811bce58a66e104efd90205a4b2102d417
diff --git a/dev-perl/Net-SSLeay/Net-SSLeay-1.810.0.ebuild b/dev-perl/Net-SSLeay/Net-SSLeay-1.810.0.ebuild
new file mode 100644
index 000000000000..0078c2f73a6c
--- /dev/null
+++ b/dev-perl/Net-SSLeay/Net-SSLeay-1.810.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MIKEM
+DIST_VERSION=1.81
+DIST_EXAMPLES=("examples/*")
+inherit multilib perl-module
+
+DESCRIPTION="Perl extension for using OpenSSL"
+
+LICENSE="openssl"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="libressl test minimal examples"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ virtual/perl-MIME-Base64
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ !minimal? (
+ dev-perl/Test-Exception
+ dev-perl/Test-Warn
+ dev-perl/Test-NoWarnings
+ )
+ virtual/perl-Test-Simple
+ )
+"
+export OPTIMIZE="$CFLAGS"
+export OPENSSL_PREFIX=${EPREFIX}/usr
+
+src_prepare() {
+ sed -i \
+ -e "/\$opts->{optimize} = '-O2 -g';/d" \
+ -e "s,\"\$prefix/lib\",\"\$prefix/$(get_libdir)\"," \
+ inc/Module/Install/PRIVATE/Net/SSLeay.pm || die
+
+ local my_test_control
+ my_test_control=${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}
+
+ if use test; then
+ perl_rm_files 't/local/01_pod.t' 't/local/02_pod_coverage.t' 't/local/kwalitee.t'
+ fi
+ if use test && has network ${my_test_control} ; then
+ eapply "${FILESDIR}/1.72-config-nettest-yes.patch"
+ else
+ eapply "${FILESDIR}/1.72-config-nettest-no.patch"
+ fi
+
+ perl-module_src_prepare
+}