summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-05-01 10:01:33 +0200
committerHans de Graaff <graaff@gentoo.org>2022-05-01 10:01:33 +0200
commitbe71dee9b1b5f8fdb1b2ec8229e525d20449cbf7 (patch)
tree73532e728992e4dac02990d80ee97829aea0400b
parentdev-ruby/marcel: drop 1.0.0, 1.0.1 (diff)
downloadgentoo-be71dee9.tar.gz
gentoo-be71dee9.tar.bz2
gentoo-be71dee9.zip
dev-ruby/mecab-ruby: update EAPI 6 -> 8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/mecab-ruby/mecab-ruby-0.996-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/mecab-ruby/mecab-ruby-0.996-r2.ebuild b/dev-ruby/mecab-ruby/mecab-ruby-0.996-r2.ebuild
new file mode 100644
index 000000000000..706c47049361
--- /dev/null
+++ b/dev-ruby/mecab-ruby/mecab-ruby-0.996-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+inherit ruby-ng
+
+DESCRIPTION="Ruby binding for MeCab"
+HOMEPAGE="https://taku910.github.io/mecab/"
+SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/${PN%-*}/${P}.tar.gz"
+
+LICENSE="|| ( BSD LGPL-2.1 GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="~app-text/mecab-${PV}"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS README test.rb )
+HTML_DOCS=( bindings.html )
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1
+}
+
+each_ruby_install() {
+ emake DESTDIR="${D}" install
+}
+
+all_ruby_install() {
+ einstalldocs
+}