summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-11-05 20:02:53 -0500
committerMatt Turner <mattst88@gentoo.org>2020-11-05 20:06:41 -0500
commitbe7fdea501e4643fcc5ad4f83164cfd4f27ebdb5 (patch)
tree59a6969114ee9939f00bf64e3e0c908b755234d1
parentdev-qt/qtwebengine: Fix build with ICU-68 (diff)
downloadgentoo-be7fdea501e4643fcc5ad4f83164cfd4f27ebdb5.tar.gz
gentoo-be7fdea501e4643fcc5ad4f83164cfd4f27ebdb5.tar.bz2
gentoo-be7fdea501e4643fcc5ad4f83164cfd4f27ebdb5.zip
app-misc/livecd-tools: EAPI=7 and other updates
- Point HOMEPAGE at gitweb - Check for CONFIG_SND_PROC_FS for the unmute service - Drop gawk/sed dependencies since they're part of the base system - Depend on media-sound/alsa-utils (bug #561498) Closes: https://bugs.gentoo.org/561498 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-misc/livecd-tools/livecd-tools-9999.ebuild25
1 files changed, 14 insertions, 11 deletions
diff --git a/app-misc/livecd-tools/livecd-tools-9999.ebuild b/app-misc/livecd-tools/livecd-tools-9999.ebuild
index 9f0e8b536c7b..0636c87f2449 100644
--- a/app-misc/livecd-tools/livecd-tools-9999.ebuild
+++ b/app-misc/livecd-tools/livecd-tools-9999.ebuild
@@ -1,7 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit linux-info
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="git://anongit.gentoo.org/proj/livecd-tools.git"
@@ -12,25 +14,26 @@ else
fi
DESCRIPTION="Gentoo LiveCD tools for autoconfiguration of hardware"
-HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+HOMEPAGE="https://gitweb.gentoo.org/proj/livecd-tools.git/"
SLOT="0"
LICENSE="GPL-2"
-IUSE=""
-RDEPEND="dev-util/dialog
+RDEPEND="
+ dev-util/dialog
+ media-sound/alsa-utils
net-dialup/mingetty
- >=sys-apps/baselayout-2
- >=sys-apps/openrc-0.8.2-r1
+ sys-apps/openrc
sys-apps/pciutils
- sys-apps/gawk
- sys-apps/sed
"
pkg_setup() {
- ewarn "This package is designed for use on the LiveCD only and will do"
- ewarn "unspeakably horrible and unexpected things on a normal system."
- ewarn "YOU HAVE BEEN WARNED!!!"
+ ewarn "This package is designed for use on the LiveCD only and will do"
+ ewarn "unspeakably horrible and unexpected things on a normal system."
+ ewarn "YOU HAVE BEEN WARNED!!!"
+
+ CONFIG_CHECK="~SND_PROC_FS"
+ linux-info_pkg_setup
}
src_install() {