summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-01-02 23:26:03 +0100
committerDavid Seifert <soap@gentoo.org>2023-01-02 23:26:03 +0100
commitbe8b15c8c702ead3d3841afdff07c7774b9471f7 (patch)
treebf70e37e7505e2f481ebb17a8e9f7e98af96ec6f
parentapp-containers/containerd: add 1.6.14 (diff)
downloadgentoo-be8b15c8c702ead3d3841afdff07c7774b9471f7.tar.gz
gentoo-be8b15c8c702ead3d3841afdff07c7774b9471f7.tar.bz2
gentoo-be8b15c8c702ead3d3841afdff07c7774b9471f7.zip
sys-cluster/galera: partially restore old versions
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sys-cluster/galera/Manifest2
-rw-r--r--sys-cluster/galera/files/galera-25.3.32-respect-cflags.patch38
-rw-r--r--sys-cluster/galera/galera-25.3.35.ebuild80
-rw-r--r--sys-cluster/galera/galera-25.3.37.ebuild80
4 files changed, 200 insertions, 0 deletions
diff --git a/sys-cluster/galera/Manifest b/sys-cluster/galera/Manifest
index 25285a706ebd..be25eb1b6ae1 100644
--- a/sys-cluster/galera/Manifest
+++ b/sys-cluster/galera/Manifest
@@ -1,2 +1,4 @@
+DIST galera-25.3.35.tar.gz 1278869 BLAKE2B c5c0cc1d4ad29caf94550a6b96ab9762a97273713b906c4f3e3d9851b90b1028246285e74becc912336edbb6e1a427d9bdd9c31177f3dd899153dbed54cdde92 SHA512 aaa7038cf9e8be57ae1760d259af31bafa8d3c994c46cbb6224231fe3bb63d7bc830a97a2d4833cd24b85a47da2e4c7bfc2a99d73155d6bd6330e4a9dda3083d
+DIST galera-25.3.37.tar.gz 1282455 BLAKE2B 1bdaad50cc08839bfaf988f2b4c5da606f08cb3d4ca43ddb27755a312f490e2e45231446c4d72c6da49aaa7ff309da661a92877a80a983c0e1f0d103f5201ee6 SHA512 348fbc100caa267ea93d2e66ed7bfe437c14ec823d31ae1f293b46791e0063f7afb41fd307ff49fa72e6c5880887da755e3782c50bdbc28622ab00020f1feaec
DIST galera-26.4.10.tar.gz 1424663 BLAKE2B 6be96cfaffd0af14a511f1f1aeaf2b7c18a3aa05216389e51a90834d9307bcd832005ee5da38acf530d40b2b6c11e62353be5aa4c0f678804808d1f74bbeea38 SHA512 97fd629d9f963459a9bce377ebcd35a5b4f533451f38011a03e440f0ac3ceddcaf45f4001afa8cd523626c03e64f27363e4b2e819d2b637551e579a3add44226
DIST galera-26.4.13.tar.gz 1529682 BLAKE2B d7030fd5e3a48ede16f608cca9986de117a54f99cf3d972a5b14623acd84f05f31f5cdbbc3032bf5caa8e0486f418ac07c8f87287bb14a8164507c558876ae61 SHA512 e548048eac5fceb0bea1ae736abc6c488d175bc71a3cfb963675232688392ecb5dcc64ddd8e78ceda40e26b94b806d3c34bd9fc9765ebc047b5a5ce28ff7efea
diff --git a/sys-cluster/galera/files/galera-25.3.32-respect-cflags.patch b/sys-cluster/galera/files/galera-25.3.32-respect-cflags.patch
new file mode 100644
index 000000000000..94c1f829450a
--- /dev/null
+++ b/sys-cluster/galera/files/galera-25.3.32-respect-cflags.patch
@@ -0,0 +1,38 @@
+--- a/SConstruct
++++ b/SConstruct
+@@ -88,7 +88,7 @@ Commandline Options:
+ build_target = 'all'
+
+ # Optimization level
+-opt_flags = ' -g -O3 -DNDEBUG'
++opt_flags = ' -DNDEBUG'
+
+ # Architecture (defaults to build host type)
+ compile_arch = ''
+@@ -121,26 +121,6 @@ elif debug_lvl == 3:
+ if dbug:
+ opt_flags = opt_flags + ' -DGU_DBUG_ON'
+
+-if sysname == 'sunos':
+- compile_arch = ' -mtune=native'
+-elif x86:
+- if bits == 32:
+- if machine == 'x86_64':
+- compile_arch = ' -mx32'
+- else:
+- compile_arch = ' -m32 -march=i686'
+- if sysname == 'linux':
+- link_arch = ' -Wl,-melf_i386'
+- else:
+- compile_arch = ' -m64'
+- if sysname == 'linux':
+- link_arch = ' -Wl,-melf_x86_64'
+- link_arch = compile_arch + link_arch
+-elif machine == 's390x':
+- compile_arch = ' -mzarch'
+- if bits == 32:
+- compile_arch += ' -m32'
+-
+ boost = int(ARGUMENTS.get('boost', 1))
+ boost_pool = int(ARGUMENTS.get('boost_pool', 0))
+ system_asio= int(ARGUMENTS.get('system_asio', 1))
diff --git a/sys-cluster/galera/galera-25.3.35.ebuild b/sys-cluster/galera/galera-25.3.35.ebuild
new file mode 100644
index 000000000000..038ddd3e62c9
--- /dev/null
+++ b/sys-cluster/galera/galera-25.3.35.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit python-any-r1 scons-utils toolchain-funcs flag-o-matic
+
+MY_PN="${PN}-3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Synchronous multi-master replication engine that provides the wsrep API"
+HOMEPAGE="https://galeracluster.com"
+SRC_URI="https://releases.galeracluster.com/${MY_PN}/source/${MY_P}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2 BSD"
+
+SLOT="0"
+
+KEYWORDS="amd64 ~arm arm64 ~ia64 ~ppc ppc64 x86"
+IUSE="cpu_flags_x86_sse4_2 garbd test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-libs/openssl:0=
+ dev-libs/boost:=
+"
+
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-libs/check
+ >=dev-cpp/asio-1.10.1[ssl(+)]
+ <dev-cpp/asio-1.12.0
+"
+
+#Run time only
+RDEPEND="${COMMON_DEPEND}"
+
+# Respect {C,LD}FLAGS.
+PATCHES=( "${FILESDIR}/${PN}"-25.3.32-respect-cflags.patch )
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ # Remove bundled dev-cpp/asio
+ rm -r "${S}/asio" || die "Failed to remove bundled asio"
+ #Remove optional garbd daemon
+ if ! use garbd ; then
+ rm -r "${S}/garb" || die "Failed to remove garbd daemon"
+ fi
+}
+
+src_configure() {
+ tc-export AR CC CXX OBJDUMP
+ # strict_build_flags=0 disables -Werror, -pedantic, -Weffc++,
+ # and -Wold-style-cast
+ MYSCONS=(
+ crc32c_no_hardware=$(usex cpu_flags_x86_sse4_2 0 1)
+ tests=$(usex test 1 0)
+ strict_build_flags=0
+ system_asio=1
+ )
+}
+
+src_compile() {
+ escons --warn=no-missing-sconscript "${MYSCONS[@]}"
+}
+
+src_install() {
+ dodoc scripts/packages/README scripts/packages/README-MySQL
+ if use garbd ; then
+ dobin garb/garbd
+ newconfd "${FILESDIR}/garb.cnf" garbd
+ newinitd "${FILESDIR}/garb.init" garbd
+ doman man/garbd.8
+ fi
+ exeinto /usr/$(get_libdir)/"${PN}"
+ doexe libgalera_smm.so
+}
diff --git a/sys-cluster/galera/galera-25.3.37.ebuild b/sys-cluster/galera/galera-25.3.37.ebuild
new file mode 100644
index 000000000000..33c3545ee6ba
--- /dev/null
+++ b/sys-cluster/galera/galera-25.3.37.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit python-any-r1 scons-utils toolchain-funcs flag-o-matic
+
+MY_PN="${PN}-3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Synchronous multi-master replication engine that provides the wsrep API"
+HOMEPAGE="https://galeracluster.com"
+SRC_URI="https://releases.galeracluster.com/${MY_PN}/source/${MY_P}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2 BSD"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="cpu_flags_x86_sse4_2 garbd test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-libs/openssl:0=
+ >=dev-libs/boost-1.41:0=
+"
+
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-libs/check
+ >=dev-cpp/asio-1.10.1[ssl(+)]
+ <dev-cpp/asio-1.12.0
+"
+
+#Run time only
+RDEPEND="${COMMON_DEPEND}"
+
+# Respect {C,LD}FLAGS.
+PATCHES=( "${FILESDIR}/${PN}"-25.3.32-respect-cflags.patch )
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ # Remove bundled dev-cpp/asio
+ rm -r "${S}/asio" || die "Failed to remove bundled asio"
+ #Remove optional garbd daemon
+ if ! use garbd ; then
+ rm -r "${S}/garb" || die "Failed to remove garbd daemon"
+ fi
+}
+
+src_configure() {
+ tc-export AR CC CXX OBJDUMP
+ # strict_build_flags=0 disables -Werror, -pedantic, -Weffc++,
+ # and -Wold-style-cast
+ MYSCONS=(
+ crc32c_no_hardware=$(usex cpu_flags_x86_sse4_2 0 1)
+ tests=$(usex test 1 0)
+ strict_build_flags=0
+ system_asio=1
+ )
+}
+
+src_compile() {
+ escons --warn=no-missing-sconscript "${MYSCONS[@]}"
+}
+
+src_install() {
+ dodoc scripts/packages/README scripts/packages/README-MySQL
+ if use garbd ; then
+ dobin garb/garbd
+ newconfd "${FILESDIR}/garb.cnf" garbd
+ newinitd "${FILESDIR}/garb.init" garbd
+ doman man/garbd.8
+ fi
+ exeinto /usr/$(get_libdir)/"${PN}"
+ doexe libgalera_smm.so
+}