summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-27 21:46:35 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-27 21:48:31 +0200
commitbe93959ddf85c28f49bfd0fefb154375f57fa008 (patch)
tree2704d2f04dc495ebf5b0da36d20e2863b840be5f
parentdev-python/arrow: add 1.2.2 (diff)
downloadgentoo-be93959ddf85c28f49bfd0fefb154375f57fa008.tar.gz
gentoo-be93959ddf85c28f49bfd0fefb154375f57fa008.tar.bz2
gentoo-be93959ddf85c28f49bfd0fefb154375f57fa008.zip
dev-python/prompt_toolkit: add 3.0.26
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/prompt_toolkit/Manifest1
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-3.0.26.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/Manifest b/dev-python/prompt_toolkit/Manifest
index df0932dea3d8..5bbfb1fc9b5a 100644
--- a/dev-python/prompt_toolkit/Manifest
+++ b/dev-python/prompt_toolkit/Manifest
@@ -1 +1,2 @@
DIST prompt_toolkit-3.0.24.tar.gz 3042044 BLAKE2B e9b4186a38756cf6c0d92575e42dfe4507e63f721038374252e7a7d5af76f7df04dc01251079d99a74167aef7e394b50c43b5190df8b9cd68cf74eae31dfbe51 SHA512 e423735441407ffe51d46225efa4b747899d47fa5d5a2163e5c0c906d2f1937e80a67bcd06ff6aa97d8a336e507fd0322957e79b9382d1a678994060fcccfb84
+DIST prompt_toolkit-3.0.26.tar.gz 402667 BLAKE2B 60160c3e0059b570321d182699b2e6cc10e7d771e9c328314e5561329aec5ddb4951d5cd50d49414314d50a9542e223b44e9c589d272ccf32bfb4f54ed1a9980 SHA512 7151d6678409bf3b04bee76cbcf4e0ffb5ca1963c359d30c8edf9e81bde424ea69b7009cd44e6d72088936290e2fd9dd8cac59efc8b5e59bfb87dacf53967b05
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-3.0.26.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-3.0.26.ebuild
new file mode 100644
index 000000000000..2ba2e9e388b5
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-3.0.26.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="dev-python/wcwidth[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest