summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-14 08:26:42 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-14 11:21:20 +0100
commitbeba175805bc5b1e67a6bb24e11d2cc8407bf37c (patch)
treeb8c0dfac992d686ac3326bb1515b3463147f7bae
parentdev-python/botocore: Bump to 1.23.24 (diff)
downloadgentoo-beba175805bc5b1e67a6bb24e11d2cc8407bf37c.tar.gz
gentoo-beba175805bc5b1e67a6bb24e11d2cc8407bf37c.tar.bz2
gentoo-beba175805bc5b1e67a6bb24e11d2cc8407bf37c.zip
dev-python/boto3: Bump to 1.20.24
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.20.24.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index b0f44f27b167..2453d46ff781 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -8,4 +8,5 @@ DIST boto3-1.20.20.tar.gz 454638 BLAKE2B 031f919d5c75423b14fe04712bbe93c8c0b43ec
DIST boto3-1.20.21.tar.gz 455027 BLAKE2B 034fd322a3c304f1d8074f89ec12678e964983abc47b5484a19e8c9c9e793ab66a2240f26167e581028b32341f3c938d1d4cd2ad3b1e00033308d44c50e4ab94 SHA512 b9823f6fe651d9d74034a1e2178b372d01d56fcb1c45d9436d2d8d8347ff7cdf5c156e43f3212ff273d89bfd71f838e4c24c0e1c01bd2fc8d5cdc1027db5dd47
DIST boto3-1.20.22.tar.gz 455654 BLAKE2B 36cee197e59df0503a14046b3d64d9a9c4d5595d47fd779b285a31670fa84fb8e1b63cd189f9ef6621e363d15f74663cb9873caaf170edaa856abda9785973ba SHA512 0821949043483350448c47c3784a4446966a665a0bbab7fe07adb42fb64653a00706a2da0b1039939e3576490f9f90bbb32c83b5bf8bc87be42f20daeea3fcb0
DIST boto3-1.20.23.tar.gz 456315 BLAKE2B 9f74a1822c631fdcc666db1d2cda5ab464b150ca01cfad807542a5db548910fda971cfb5b5d92bfa2be90680759cb4b9b368b44485228df99364c17b01150f6a SHA512 1cbbdac34f8174b153546f4b6a43f1317fbcb4556e058759c59f4aea23e8517f23d63dc581be776469f49c7e82378ac0a2657b211df70b29bbb94839e263005e
+DIST boto3-1.20.24.tar.gz 456338 BLAKE2B 4192f20a7a5c247a72b381506697034d744fd62c60d06402759942c3dc1ef0c136ea7b85ab80920831f876e098af549bcdff688ff287a0350ed00ed88aaf0adf SHA512 96a2d6dabaca0aa0d85efcbc2f98f8e41b568e2190352c00101c3df85623867036f64ad9935681ad2a104abd9f6aa9e79de8f7136a846e256185d065afed23a1
DIST boto3-1.20.5.tar.gz 439166 BLAKE2B c140e15e497e6cdf6b4b77bb99e0a0f5ac01d5b5793f8bfb210b52bbc09e39e6fe06a957951375e0795210dc1c3b2a0afd2f498bc88e449d9e6846f2b357f016 SHA512 2823466e4851684253d4ce42a8c34e5cbdad6d04c823040fe2cebdf0cffb14d5d3f40e28d57ebec14533fab04ba74f27c25f078ddb8791b8f52d0424e11b39fc
diff --git a/dev-python/boto3/boto3-1.20.24.ebuild b/dev-python/boto3/boto3-1.20.24.ebuild
new file mode 100644
index 000000000000..9e72dd682a4c
--- /dev/null
+++ b/dev-python/boto3/boto3-1.20.24.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}