summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-03 23:31:09 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-04 00:35:17 +0100
commitbec67b2834fc0d7f714b5b5e2af50527c7dd5cab (patch)
treefd00d662e3c0ebce7995d74009a3e6d0dba788b2
parentdev-python/flask-whooshalchemy: Clean old up (diff)
downloadgentoo-bec67b28.tar.gz
gentoo-bec67b28.tar.bz2
gentoo-bec67b28.zip
dev-python/flask-wtf: Clean old up
-rw-r--r--dev-python/flask-wtf/Manifest2
-rw-r--r--dev-python/flask-wtf/flask-wtf-0.10.3.ebuild51
-rw-r--r--dev-python/flask-wtf/flask-wtf-0.13.1.ebuild54
3 files changed, 0 insertions, 107 deletions
diff --git a/dev-python/flask-wtf/Manifest b/dev-python/flask-wtf/Manifest
index 46485dc84b41..c703d863e8cb 100644
--- a/dev-python/flask-wtf/Manifest
+++ b/dev-python/flask-wtf/Manifest
@@ -1,3 +1 @@
-DIST Flask-WTF-0.10.3.tar.gz 247240 BLAKE2B d0bc70cef87cfb6aab0947319ed1b1b66ced7b6a2d7d165ab4e58abf8c0d9c5177bec95aa95f66fd34c02c2bc82bc9f224967c4b8a9b7f685aaccc90d74c489a SHA512 c8cbc817afca7efbc2c0302c4fa3625874159c10e4664b502693acfa3ffcca34aee0a6f17528b45340f1e7f103f87ac72178f2ca4d589307bde12fe47ac5cf50
-DIST Flask-WTF-0.13.1.tar.gz 253341 BLAKE2B 47c369f173d64bbeaa3286e28faebf9055c3ebc28e5ad3d4e6f54ae9b17f79205eca5fa1f135dd38f2536ea8b7f1c83967ce5919e03538b4d7861cdfa59191c0 SHA512 ea85898688c16ee0b5dc54055ac0f19564c83b60a433c8fb4dfa27651f9f16b62e6c30ede0f8246a18c19c7b36dd17272210fd1a38f463efe71e12c058bd0f27
DIST Flask-WTF-0.14.2.tar.gz 254903 BLAKE2B dd6b650d97622dbb56cc0bdd3c036f14e562181720ede0c48652b8fcbc88d2d684f013f0468e723b8b0746f2c6f44ca18ffe0ea353594680b47bc1212664ce52 SHA512 9d4b4b24eb24827aeb524699e6720eab384c42901a102daddd9fdc6b8dbc8eebec8c9d31a1e9052c9af4d61bd08eef8ef9dc4cdc8d9b950ff5bdd0201db1dfde
diff --git a/dev-python/flask-wtf/flask-wtf-0.10.3.ebuild b/dev-python/flask-wtf/flask-wtf-0.10.3.ebuild
deleted file mode 100644
index 0012300ab428..000000000000
--- a/dev-python/flask-wtf/flask-wtf-0.10.3.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 pypy )
-
-# silly captcha test trying to access things over the network
-RESTRICT="test"
-
-inherit distutils-r1
-
-MY_PN="Flask-WTF"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Simple integration of Flask and WTForms, including CSRF, file upload and Recaptcha integration"
-HOMEPAGE="http://pythonhosted.org/Flask-WTF/ https://pypi.python.org/pypi/Flask-WTF"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- >=dev-python/wtforms-1.0.5[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/flask-testing[${PYTHON_USEDEP}]
- dev-python/flask-uploads[${PYTHON_USEDEP}]
- dev-python/speaklater[${PYTHON_USEDEP}]
- dev-python/flask-babel[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/werkzeug[${PYTHON_USEDEP}]' python2_7 )
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/flask-wtf/flask-wtf-0.13.1.ebuild b/dev-python/flask-wtf/flask-wtf-0.13.1.ebuild
deleted file mode 100644
index 2b954d8da5c4..000000000000
--- a/dev-python/flask-wtf/flask-wtf-0.13.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
-
-inherit distutils-r1
-
-MY_PN="Flask-WTF"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Simple integration of Flask and WTForms"
-HOMEPAGE="http://pythonhosted.org/Flask-WTF/ https://pypi.python.org/pypi/Flask-WTF"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- >=dev-python/wtforms-1.0.5[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/flask-testing[${PYTHON_USEDEP}]
- dev-python/flask-uploads[${PYTHON_USEDEP}]
- dev-python/speaklater[${PYTHON_USEDEP}]
- dev-python/flask-babel[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/werkzeug[${PYTHON_USEDEP}]' python2_7 )
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # tries to access things over the network
- rm tests/test_recaptcha.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}