summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-04-27 23:59:52 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-04-28 00:01:46 -0400
commitbef10654f61f1196d2cbe28987c040b5c88360a9 (patch)
tree1591f7343bbdd71f3767909d915d7c5315291881
parentdev-python/whelk: Version bump (diff)
downloadgentoo-bef10654.tar.gz
gentoo-bef10654.tar.bz2
gentoo-bef10654.zip
app-misc/gramps: new version 4.2.5.
This is a straightforward version bump, except that I've eliminated one patch. By passing the --resourcepath argument to distutils, we avoid the need to patch it ourselves. Gentoo-Bug: 616796 Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--app-misc/gramps/Manifest1
-rw-r--r--app-misc/gramps/gramps-4.2.5.ebuild (renamed from app-misc/gramps/gramps-4.2.4-r2.ebuild)17
2 files changed, 11 insertions, 7 deletions
diff --git a/app-misc/gramps/Manifest b/app-misc/gramps/Manifest
index 680dee7f7f23..cc81765024db 100644
--- a/app-misc/gramps/Manifest
+++ b/app-misc/gramps/Manifest
@@ -1,2 +1,3 @@
DIST gramps-3.4.5.tar.gz 10444188 SHA256 940b665a2e0dadf7ee310bdd1a1033c20816c856df8a7d6c4e0850a60471dbc7 SHA512 c9b517f58712d9f585dbddcb394d3605a5f823950a8c3c5a4ffd20d1a8523d6b75f9b6193271adabe76edc073dd6b4c20811de62582a2930b84d88922b4e52b3 WHIRLPOOL 4e30108881900883a4cb3c3ee4c9ef78e04d0850c3dbdaf97569f44cdfb2e56463f3f156f041b4dec6650c722f12cc0909689edc9591c97c5b02b1705860c228
DIST gramps-4.2.4.tar.gz 18683901 SHA256 25190692f2f0d06e05f0761fef45173dd8d6693762572a62845b544a2c622efa SHA512 640b7b8affc29eee000232a3828f71c6e6e4ee568a4fce2ae8f9eaeabc87682e2dd9e2f1db1e8093e368d86583e80ce3c5261cf223f9cc6e210e7d6272781499 WHIRLPOOL ae118840749364b2904e5ed35f318019c54551305cf98d6e118bf9c539d1507dbce74b46fe66430e53c1115d09d3c73296a91f354ad0bb734e6d182a3ae148d0
+DIST gramps-4.2.5.tar.gz 18694912 SHA256 1de3007215b7d0b779ec8f086e14e7a75f2aa811ee37c6d0cff06bfc9458743d SHA512 20a8ebff7ea2e3a80248830e55d58ebe0b5a350e1ac31efb3f2b900af38c134037bae91a58fb441be54f9fac8226555a3f5771cc358d3a4a92e89af911433b9c WHIRLPOOL d9f49b188e20697477860ecb5916c452b95ea08c038b828b0f01edc1097d3d45b549e3e1a5bc5a4aad1d8aab390b8dfefc4ec46ac58420161de8e4d644c8f95e
diff --git a/app-misc/gramps/gramps-4.2.4-r2.ebuild b/app-misc/gramps/gramps-4.2.5.ebuild
index 9f754091ca12..6abcc0c4b44e 100644
--- a/app-misc/gramps/gramps-4.2.4-r2.ebuild
+++ b/app-misc/gramps/gramps-4.2.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -9,12 +9,13 @@ inherit distutils-r1
DESCRIPTION="Genealogical Research and Analysis Management Programming System"
HOMEPAGE="https://gramps-project.org/"
-SRC_URI="https://github.com/gramps-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/gramps-project/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+reports +exif geo spell"
+IUSE="+reports exif geo spell"
RDEPEND="
dev-python/bsddb3[${PYTHON_USEDEP}]
@@ -31,12 +32,14 @@ RDEPEND="
spell? ( app-text/gtkspell:3[introspection] )
"
-PATCHES=(
- "${FILESDIR}/${P}-resourcepath.patch"
-)
+python_configure_all() {
+ mydistutilsargs=( --resourcepath=/usr/share )
+}
python_prepare_all() {
+ # Install documentation to the proper location. This can't be done
+ # easily with a patch because we substitute in the $PF variable,
+ # and that changes with every revision.
sed -i "s:share/doc/gramps:share/doc/${PF}:g" setup.py || die
-
distutils-r1_python_prepare_all
}