summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-09-28 11:18:29 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-09-28 11:23:18 -0500
commitbf05e186d8fd17b206f582b5b18a9fcddb8cfc57 (patch)
tree0b35e06003766ad99988dd16816fab51e9abda90
parentdev-python/oslo-config: 4.11.1 bup (diff)
downloadgentoo-bf05e186.tar.gz
gentoo-bf05e186.tar.bz2
gentoo-bf05e186.zip
dev-python/oslo-serialization: 2.16.1 bup
Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--dev-python/oslo-serialization/Manifest1
-rw-r--r--dev-python/oslo-serialization/oslo-serialization-2.16.1.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/oslo-serialization/Manifest b/dev-python/oslo-serialization/Manifest
index 1ac7922726c4..ff45fe34450b 100644
--- a/dev-python/oslo-serialization/Manifest
+++ b/dev-python/oslo-serialization/Manifest
@@ -1,2 +1,3 @@
DIST oslo-serialization-2.16.0.tar.gz 28204 SHA256 0ef8dfa735a42dcfd7d804c5b14576df92407f842d5e12c1fad7eb0889c444fc SHA512 d6612d99e05e3c634d8b2a2e37183884f7aeec3608080bc2bbfcd8e436a64a678e1bb294024ddec0d276fc216fa92a9117a63eb085bc110500e07f1db172e5b0 WHIRLPOOL 5d43524577569a2ee194bc92f387fad10bf15e6922fa315f9559d6a7a6ecba95dfd977f30e7a9086e6120e38fc56f83d37e64f25bc113b6f212f03753f355cbd
+DIST oslo-serialization-2.16.1.tar.gz 28733 SHA256 306d9982eae272fff05db7637971fd07d2b9b818306c9e3af87aea7f452b4844 SHA512 36e162c8f93d064d103052eb8295de7753ac9739f6c9c9f8d048090f5f2663f643f69507d9c47b9fd6142f5ba14d1eeb49120119cce5c6e60cbe09248e8f5a1d WHIRLPOOL 7cc84da7a5437b91c9f5cd5c3c3f7cb6c6e260cdc7dcceb78f98da7ec2f3af10c444fb76b9e4ff0ed07ddcb98e567c8c86f49fc2b6e3f3274f48d0f46236b2e6
DIST oslo-serialization-2.20.0.tar.gz 28693 SHA256 fca6fbb350d560aab8a4fdc9a1128dac3b1d38b2fc9bf5ad22136ae090854802 SHA512 f15c55a28d1e99b4e01a579f6a3b20d260f8e911ea801b20b27acf3ce284a2bb0ef8a3fa6d6db2d5a094aea9efaa87308b1166ac23dab169209e06bb23d0880c WHIRLPOOL bd2d4fae43f685e2f307c944cce7b9cad21b571ef7bfe7419fba03bc912a2aaa9a1777292a53bcc518663d5b4ac05b3a1e144350d7acefa1657c0a15bad99af5
diff --git a/dev-python/oslo-serialization/oslo-serialization-2.16.1.ebuild b/dev-python/oslo-serialization/oslo-serialization-2.16.1.ebuild
new file mode 100644
index 000000000000..e98506682f1d
--- /dev/null
+++ b/dev-python/oslo-serialization/oslo-serialization-2.16.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo Serialization library"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ virtual/python-ipaddress[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.13[${PYTHON_USEDEP}]
+ !~dev-python/netaddr-0.7.16[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.4[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.18.0[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ use doc && esetup.py build_sphinx
+ distutils-r1_python_prepare_all
+}
+
+# Note: Tests fail due to requiring installation.
+#
+# Installation appears to fail due ot the use of namespace packages but root
+# cause was never truly established.
+RESTRICT="test"
+
+python_test() {
+ distutils_install_for_testing
+
+ PYTHONPATH="${TEST_DIR}/lib:${PYTHONPATH}"
+
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}