summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-21 08:07:56 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-21 09:32:11 +0300
commitbf0e40786f570c47d0f0b00185d9afdade9bf63e (patch)
tree7318880a78861cceac73c518f853997d4731f57a
parentdev-python/python-netlink: update maintainers (diff)
downloadgentoo-bf0e40786f570c47d0f0b00185d9afdade9bf63e.tar.gz
gentoo-bf0e40786f570c47d0f0b00185d9afdade9bf63e.tar.bz2
gentoo-bf0e40786f570c47d0f0b00185d9afdade9bf63e.zip
dev-python/python-netlink: enable py3.{9,10}
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/python-netlink/python-netlink-0.1.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/dev-python/python-netlink/python-netlink-0.1.ebuild b/dev-python/python-netlink/python-netlink-0.1.ebuild
index 84b05e228be7..8a7540760238 100644
--- a/dev-python/python-netlink/python-netlink-0.1.ebuild
+++ b/dev-python/python-netlink/python-netlink-0.1.ebuild
@@ -1,23 +1,23 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-PYTHON_COMPAT=( python3_7 python3_8 )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
-MY_PN="NetLink"
-MY_P="${MY_PN}-${PV}"
+MY_P="NetLink-${PV}"
+
DESCRIPTION="Pure-Python client for the Linux NetLink interface"
HOMEPAGE="https://pypi.org/project/NetLink/ https://xmine128.tk/Software/Python/netlink/docs/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+SRC_URI="mirror://pypi/${MY_P:0:1}/NetLink/${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
LICENSE="LGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="!dev-libs/libnl[python]"
-S=${WORKDIR}/${MY_P}
+
+RDEPEND="!dev-libs/libnl[python(-)]"
python_prepare_all() {
distutils-r1_python_prepare_all