summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-01-29 07:23:53 +0100
committerHans de Graaff <graaff@gentoo.org>2016-01-29 07:28:28 +0100
commitbf163e2b98b83f435f1d52ad3b4da28d2a08c14b (patch)
treedf81cdf8f9d2b259cfdcd259c341f74f03b3ae34
parentx11-drivers/nvidia-drivers: Raise x11-base/xorg-server compatibility (bug #57... (diff)
downloadgentoo-bf163e2b.tar.gz
gentoo-bf163e2b.tar.bz2
gentoo-bf163e2b.zip
dev-ruby/rspec-core: add 3.4.2
Package-Manager: portage-2.2.26
-rw-r--r--dev-ruby/rspec-core/Manifest1
-rw-r--r--dev-ruby/rspec-core/rspec-core-3.4.2.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/dev-ruby/rspec-core/Manifest b/dev-ruby/rspec-core/Manifest
index 9b2d70641179..97de9d3c60bb 100644
--- a/dev-ruby/rspec-core/Manifest
+++ b/dev-ruby/rspec-core/Manifest
@@ -5,3 +5,4 @@ DIST rspec-core-3.3.1-git.tgz 332355 SHA256 9dc839186e72fe5d4b4f15500bc2a976d08d
DIST rspec-core-3.3.2-git.tgz 332730 SHA256 aef9a2867a435aa7be57826c850e88e593232077dc42f12bfed89a92c7704d26 SHA512 6cadfa43d63df8d24105d88d6e8b22a495a30f04b289c71c8887ea3fead9ec8f071a6c734a140b1e4910f25094fd36c7c37b54a0724e734233ca584202f0cf32 WHIRLPOOL 1e385223ea8c9b32bfc6ecc93146ccad793441bae3426f6cb4acc07d7a1f2bc6e20be11597fcd27f3c6bb207482213e2eaf214835041df631d06b9bc524e5b70
DIST rspec-core-3.4.0-git.tgz 354166 SHA256 852bf29d13c30e921126b57233b80a56495465fe80f3a5fb036721f20a74a668 SHA512 9961b99a2209268528a3cee741f682f37300d0bd88c8364ee400073a3274e7465d767f01207db12789debb73a4bcb5dc6eb06039b0364cdf9fd72803fa917bc5 WHIRLPOOL 9d6176434c72a2eacb8d4ca5ae794f0bd0351507bf51a1b102f4eb12dce02a84cbf2f813c801ac5fc591c533ef4ffe995b9e8df374de4ecffe3cb8367e1c1b59
DIST rspec-core-3.4.1-git.tgz 354375 SHA256 ed75c25573e155b5fd9f57102785294b2f9b4d3796b96279ba977acbb5bf9eb2 SHA512 e472969b7d1571be39438190029690acdcd760b61f7067e8bf66b29324f2eeb7f870f382dacc79738f0aeea1c66bc971b7a8b93ae6a2c3bc61ac539ce4b452a3 WHIRLPOOL 53243e1374d9cc50f950d17e7de30d9dc3f0c3ac0dea16f41c3b36f3160e95d1ab6ed720e83dc508b4925c3340ed4876918fbcfafe937f9b7753cc8888a266a2
+DIST rspec-core-3.4.2-git.tgz 354859 SHA256 bcb93520f5cb2bc0f2f66c09579970c524e7404575cefc5aefcd3da594d775b6 SHA512 33fc3336a01b86f9c22e5e9fe9f78f2b4f66a309fd0bff90d565484912d2ae6525dc80b0e6e2c6d2b5d698c2848e0b025cc4f065b533b9936ba6e7dfb03bae88 WHIRLPOOL 451f5b70bdd9db53fc7fabc84dacff6cd3cbda3422ca475a1090e5bcd2ec42249e91953c0d648c5a4d2ab12af85e778b392a1e75717526d89577ecffe88f0cfa
diff --git a/dev-ruby/rspec-core/rspec-core-3.4.2.ebuild b/dev-ruby/rspec-core/rspec-core-3.4.2.ebuild
new file mode 100644
index 000000000000..6816c7fc9526
--- /dev/null
+++ b/dev-ruby/rspec-core/rspec-core-3.4.2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC="none"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+# Also install this custom path since internal paths depend on it.
+RUBY_FAKEGEM_EXTRAINSTALL="exe"
+
+RUBY_FAKEGEM_GEMSPEC="rspec-core.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-core"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc64"
+IUSE="highlight"
+
+SUBVERSION="$(get_version_component_range 1-2)"
+
+ruby_add_rdepend "
+ =dev-ruby/rspec-support-${SUBVERSION}*
+ !!<dev-ruby/rspec-core-2.14.8-r4
+ highlight? ( >=dev-ruby/coderay-1.0.9 )
+"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/nokogiri-1.5.2
+ >=dev-ruby/coderay-1.0.9
+ dev-ruby/syntax
+ >=dev-ruby/thread_order-1.1.0
+ >=dev-ruby/zentest-4.6.2
+ >=dev-ruby/rspec-expectations-3.3.0:3
+ >=dev-ruby/rspec-mocks-2.99.0:3
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Avoid dependency on cucumber since we can't run the features anyway.
+ sed -i -e '/[Cc]ucumber/ s:^:#:' Rakefile || die
+
+ # Duplicate exe also in bin. We can't change it since internal stuff
+ # also depends on this and fixing that is going to be fragile. This
+ # way we can at least install proper bin scripts.
+ cp -R exe bin || die
+
+ # Avoid unneeded dependency on git.
+ sed -i -e 's/git ls-files --/find/' rspec-core.gemspec || die
+
+ # Avoid aruba dependency so that we don't end up in dependency hell.
+ sed -i -e '/ArubaLoader/,/^end/ s:^:#:' -e '/Aruba/ s:^:#:' spec/spec_helper.rb || die
+ rm spec/integration/{failed_line_detection,filtering,order,persistence_failures}_spec.rb spec/support/aruba_support.rb || die
+
+ # Avoid a spec failing due to path issues
+ sed -i -e '/does not load files in the default path when run by ruby/,/end/ s:^:#:' \
+ spec/rspec/core/configuration_spec.rb || die
+
+ # Avoid specs for older coderay version which is no longer packaged
+ sed -i -e '/highlights the syntax of the provided lines/ s/do/,skip: true do/' \
+ -e '/dynamically adjusts to changing color config/ s/do/,skip: true do/' \
+ spec/rspec/core/source/syntax_highlighter_spec.rb
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby -e:'${RUBY}' -e:' spec/rspec/core_spec.rb || die
+
+ # case ${RUBY} in
+ # *ruby22)
+ # # The rubygems version bundled with ruby 2.2 causes warnings.
+ # sed -i -e '/a library that issues no warnings when loaded/,/^ end/ s:^:#:' spec/rspec/core_spec.rb || die
+ # ;;
+ # esac
+}
+
+all_ruby_compile() {
+ if use doc ; then
+ yardoc || die
+ fi
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -Ilib bin/rspec spec || die "Tests failed."
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rspec /usr/bin/rspec-3 'gem "rspec", "~>3.0"'
+}