summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Beddek <telans@posteo.de>2021-10-31 15:39:39 +1300
committerSam James <sam@gentoo.org>2021-11-14 05:24:34 +0000
commitbf19acd92c91042669578bf32770a912b301a830 (patch)
tree5774fb876f62db085c8829d6f044cf8f7405072b
parentdev-libs/liborcus: add 0.17.0 (diff)
downloadgentoo-bf19acd92c91042669578bf32770a912b301a830.tar.gz
gentoo-bf19acd92c91042669578bf32770a912b301a830.tar.bz2
gentoo-bf19acd92c91042669578bf32770a912b301a830.zip
dev-libs/libixion: add 0.17.0
Signed-off-by: James Beddek <telans@posteo.de> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/libixion/Manifest1
-rw-r--r--dev-libs/libixion/libixion-0.17.0.ebuild60
-rw-r--r--dev-libs/libixion/libixion-9999.ebuild7
3 files changed, 65 insertions, 3 deletions
diff --git a/dev-libs/libixion/Manifest b/dev-libs/libixion/Manifest
index 55952aeb461e..aff640dd2314 100644
--- a/dev-libs/libixion/Manifest
+++ b/dev-libs/libixion/Manifest
@@ -1 +1,2 @@
DIST libixion-0.16.1.tar.xz 482500 BLAKE2B 26075c819a952f48c4e136fa28b4ef5075b455dea52d51940e4fc55344e19e404d70b44222631d0b0f85280d09bb8a05955bfcbe0a228b97d72d8f00f1639248 SHA512 979c631e9536f6d2c3ae32f7892756ac8889d27c551d80eb9d519bf912bd323da4b6ecd363fe2719e74e04bc3661e5d56e03a582f68f5293ffcac59b74f4c7de
+DIST libixion-0.17.0.tar.xz 499836 BLAKE2B c8c31b07ad14dd49be259686af3e39e6f5d4aeeb8680030ea7bd2697c8baa72123f2659b3087f224f956612dc444c97e6a6d331fd3deff780981bab4d5b6ad25 SHA512 0acdb2eae5250236a94b1a3344ca990058ea8db7b1e741545bcb7160f9e28d21a3c2ec336621fd590df10188a4d5feadfbb3a63f57e9bfd2cc1bffc04009ffad
diff --git a/dev-libs/libixion/libixion-0.17.0.ebuild b/dev-libs/libixion/libixion-0.17.0.ebuild
new file mode 100644
index 000000000000..806058a7ae4f
--- /dev/null
+++ b/dev-libs/libixion/libixion-0.17.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit python-single-r1
+
+DESCRIPTION="General purpose formula parser & interpreter"
+HOMEPAGE="https://gitlab.com/ixion/ixion"
+
+if [[ ${PV} == *9999 ]]; then
+ MDDS_SLOT="1/9999"
+ EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
+ inherit git-r3 autotools
+else
+ MDDS_SLOT="1/2.0"
+ SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
+ # Unkeyworded while libreoffice has no release making use of this slot
+ # KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/0.17" # based on SONAME of libixion.so
+IUSE="debug python +threads"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-util/mdds:${MDDS_SLOT}
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ $(use_enable debug)
+ $(use_enable debug debug-utils)
+ $(use_enable debug log-debug)
+ $(use_enable python)
+ $(use_enable threads)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}
diff --git a/dev-libs/libixion/libixion-9999.ebuild b/dev-libs/libixion/libixion-9999.ebuild
index d9195a2f1d42..c9e0cbbd5438 100644
--- a/dev-libs/libixion/libixion-9999.ebuild
+++ b/dev-libs/libixion/libixion-9999.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
+
inherit python-single-r1
DESCRIPTION="General purpose formula parser & interpreter"
@@ -14,13 +15,13 @@ if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
inherit git-r3 autotools
else
- MDDS_SLOT="1/1.5"
+ MDDS_SLOT="1/2.0"
SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
fi
LICENSE="MIT"
-SLOT="0/0.16" # based on SONAME of libixion.so
+SLOT="0/0.17" # based on SONAME of libixion.so
IUSE="debug python +threads"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"