summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-01-28 20:10:24 +0100
committerJohannes Huber <johu@gentoo.org>2017-01-28 20:12:01 +0100
commitbf28b83fe393662d5322f0e8f07ee9bd82457e9b (patch)
treeda0053bcd38550d6bac4e1cca38c1bbd0acfd378
parentx11-wm/awesome: Remove 3.4.15 (diff)
downloadgentoo-bf28b83fe393662d5322f0e8f07ee9bd82457e9b.tar.gz
gentoo-bf28b83fe393662d5322f0e8f07ee9bd82457e9b.tar.bz2
gentoo-bf28b83fe393662d5322f0e8f07ee9bd82457e9b.zip
x11-wm/awesome: Remove 3.5.6 (r1)
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--x11-wm/awesome/awesome-3.5.6-r1.ebuild133
-rw-r--r--x11-wm/awesome/files/awesome-glib-fix.patch13
2 files changed, 0 insertions, 146 deletions
diff --git a/x11-wm/awesome/awesome-3.5.6-r1.ebuild b/x11-wm/awesome/awesome-3.5.6-r1.ebuild
deleted file mode 100644
index 93ceb6d9313f..000000000000
--- a/x11-wm/awesome/awesome-3.5.6-r1.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-inherit cmake-utils eutils
-
-DESCRIPTION="A dynamic floating and tiling window manager"
-HOMEPAGE="http://awesome.naquadah.org/"
-SRC_URI="http://awesome.naquadah.org/download/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE="dbus doc elibc_FreeBSD gnome"
-
-COMMON_DEPEND="
- >=dev-lang/lua-5.1:0
- dev-libs/glib:2
- >=dev-libs/libxdg-basedir-1
- >=dev-lua/lgi-0.7
- x11-libs/cairo[xcb]
- x11-libs/gdk-pixbuf:2
- >=x11-libs/libxcb-1.6
- >=x11-libs/pango-1.19.3[introspection]
- >=x11-libs/startup-notification-0.10_p20110426
- >=x11-libs/xcb-util-0.3.8
- x11-libs/xcb-util-cursor
- x11-libs/libXcursor
- >=x11-libs/libX11-1.3.99.901
- dbus? ( >=sys-apps/dbus-1 )
- elibc_FreeBSD? ( dev-libs/libexecinfo )"
-
-# graphicsmagick's 'convert -channel' has no Alpha support, bug #352282
-DEPEND="${COMMON_DEPEND}
- >=app-text/asciidoc-8.4.5
- app-text/xmlto
- dev-util/gperf
- virtual/pkgconfig
- media-gfx/imagemagick[png]
- >=x11-proto/xcb-proto-1.5
- >=x11-proto/xproto-7.0.15
- doc? (
- app-doc/doxygen
- media-gfx/graphviz
- )"
-
-RDEPEND="${COMMON_DEPEND}"
-
-DOCS="AUTHORS BUGS PATCHES README STYLE"
-
-src_prepare() {
- # bug #408025
- epatch "${FILESDIR}/${PN}-3.5_rc1-convert-path.patch"
- epatch "${FILESDIR}/${PN}-xsession.patch"
-
- # bug #507604
- epatch "${FILESDIR}/${PN}-3.5.5-util.lua-xdg-icons-fix.patch"
- # bug #509658
- epatch "${FILESDIR}/${PN}-3.5.5-cflag-cleanup.patch"
-}
-
-src_configure() {
- mycmakeargs=(
- -DPREFIX="${EPREFIX}"/usr
- -DSYSCONFDIR="${EPREFIX}"/etc
- $(cmake-utils_use_with dbus DBUS)
- $(cmake-utils_use doc GENERATE_DOC)
- )
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- local myargs="all"
-
- if use doc ; then
- myargs="${myargs} doc"
- fi
- cmake-utils_src_make ${myargs}
-}
-
-src_install() {
- cmake-utils_src_install
-
- if use doc ; then
- (
- cd "${CMAKE_BUILD_DIR}"/doc
- mv html doxygen
- dohtml -r doxygen || die
- )
- fi
- rm -rf "${ED}"/usr/share/doc/${PN} || die "Cleanup of dupe docs failed"
-
- exeinto /etc/X11/Sessions
- newexe "${FILESDIR}"/${PN}-session ${PN} || die
-
- # GNOME-based awesome
- if use gnome ; then
- # GNOME session
- insinto /usr/share/gnome-session/sessions
- newins "${FILESDIR}/${PN}-gnome-3.session" "${PN}-gnome.session" || die
- # Application launcher
- domenu "${FILESDIR}/${PN}-gnome.desktop" || die
- # X Session
- insinto /usr/share/xsessions/
- doins "${FILESDIR}/${PN}-gnome-xsession.desktop" || die
- fi
-}
-
-pkg_postinst() {
- # bug #447308
- if use gnome; then
- elog
- elog "You have enabled the gnome USE flag."
- elog "Please note that quitting awesome won't kill your gnome session."
- elog "To really quit the session, you should bind your quit key"
- elog "to the following command:"
- elog " gnome-session-quit --logout"
- elog "For more info visit"
- elog " https://bugs.gentoo.org/show_bug.cgi?id=447308"
- fi
-
- # bug #440724
- elog
- elog "If you are having issues with Java application windows being"
- elog "completely blank, try installing"
- elog " x11-misc/wmname"
- elog "and setting the WM name to LG3D."
- elog "For more info visit"
- elog " https://bugs.gentoo.org/show_bug.cgi?id=440724"
- elog
-}
diff --git a/x11-wm/awesome/files/awesome-glib-fix.patch b/x11-wm/awesome/files/awesome-glib-fix.patch
deleted file mode 100644
index e3e6fcf94896..000000000000
--- a/x11-wm/awesome/files/awesome-glib-fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
->=glib-2.31 build fix
-
---- a/spawn.c
-+++ b/spawn.c
-@@ -24,7 +24,7 @@
- #include <sys/types.h>
- #include <sys/wait.h>
-
--#include <glib/gspawn.h>
-+#include <glib.h>
-
- #include "spawn.h"
- #include "screen.h"