summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-29 07:02:51 +0000
committerSam James <sam@gentoo.org>2024-02-29 07:03:29 +0000
commitbf3840abb9f8b7a7efc03bcd4c2ad8fcb5fab297 (patch)
tree994727664db896272b5c94e2f6b9fa198f8e5859
parentdev-python/pycurl: add missing dev-python/pytest-timeout test dep (diff)
downloadgentoo-bf3840ab.tar.gz
gentoo-bf3840ab.tar.bz2
gentoo-bf3840ab.zip
dev-python/pycurl: backport test improvements to stable
Backport the test improvements from b450193edb70aa6c5f80fd1c2797e4f3570c187c so we don't have tests hanging forever in the stable ebuild. Closes: https://bugs.gentoo.org/919052 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/pycurl/pycurl-7.45.2-r1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-python/pycurl/pycurl-7.45.2-r1.ebuild b/dev-python/pycurl/pycurl-7.45.2-r1.ebuild
index 940b0bb94856..e0b8e79c33dd 100644
--- a/dev-python/pycurl/pycurl-7.45.2-r1.ebuild
+++ b/dev-python/pycurl/pycurl-7.45.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -43,6 +43,7 @@ BDEPEND="
test? (
>=dev-python/bottle-0.12.7[${PYTHON_USEDEP}]
dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),http2]
)
"
@@ -81,9 +82,15 @@ python_test() {
tests/memory_mgmt_test.py::MemoryMgmtTest::test_readdata_refcounting
tests/memory_mgmt_test.py::MemoryMgmtTest::test_writedata_refcounting
tests/memory_mgmt_test.py::MemoryMgmtTest::test_writeheader_refcounting
+ # broken with curl 8.4.0+
+ tests/multi_callback_test.py::MultiCallbackTest::test_multi_socket_action
+ tests/multi_socket_select_test.py::MultiSocketSelectTest::test_multi_socket_select
+ # TODO
+ tests/option_constants_test.py::OptionConstantsTest::test_proxy_tlsauth
+ tests/option_constants_test.py::OptionConstantsTest::test_socks5_gssapi_nec_setopt
)
- epytest -p flaky tests
+ epytest -p flaky -p timeout --timeout=30 tests
}
python_install_all() {