summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-29 02:19:47 +0100
committerSam James <sam@gentoo.org>2023-03-29 13:56:20 +0100
commitbf44c56b1af48d9b9142a7e6973883e4e43a274f (patch)
tree4cfeadcb477ba5f161c6d4f8354a4f0077b32e5e
parentdev-ruby/date: drop 3.2.2, 3.3.0, 3.3.1 (diff)
downloadgentoo-bf44c56b1af48d9b9142a7e6973883e4e43a274f.tar.gz
gentoo-bf44c56b1af48d9b9142a7e6973883e4e43a274f.tar.bz2
gentoo-bf44c56b1af48d9b9142a7e6973883e4e43a274f.zip
dev-ruby/pg: drop 1.3.5
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-ruby/pg/Manifest1
-rw-r--r--dev-ruby/pg/pg-1.3.5.ebuild61
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-ruby/pg/Manifest b/dev-ruby/pg/Manifest
index 1dd177b37229..08c2c2792b82 100644
--- a/dev-ruby/pg/Manifest
+++ b/dev-ruby/pg/Manifest
@@ -1,3 +1,2 @@
-DIST pg-1.3.5.tar.gz 256197 BLAKE2B 8a8cd0135eb7dcf8389d2b0afa174059d12f542b1e2897fba0e292fd16f31508293ca90f64f731db9bc14e55e9ba2c740ccf744a5fe30c449d64344264e409e1 SHA512 44e8ad97a6f4136d49641c5a59a70a489d766d1c1e511f5a6f003c2ae2900466b02a2504dc0fb26c872ce3fcb56ac83ac5299a829cca99d9c02c4b7ce0f0ac75
DIST pg-1.4.1.tar.gz 258388 BLAKE2B d2f2c81b51fb159a95990382cce316938b97d8ecb1c9590c4a70be741f4806bc47dc99423c1d54e939bc156e287cc7cba28d854dc68900501c10fbaf15cb3076 SHA512 e8e0ad7b6df4a98d8ac6dfa8006044f7fbfc45713e1aa866e80a83061be5a6a1a57456cc2ffc14d976c2d108ce526c6fa9d4ce59222a9d9bb3ef676e9dec8da9
DIST pg-1.4.6.tar.gz 282608 BLAKE2B 73616b6ba0373ae81394188fd96d7ca37144b76e5e89d0267e076ea39b9e33d19851d3881e70d9d5934ea26671c07635a22e7e530dd0094a243de8e9d9793fb5 SHA512 5cde5441f9864f89e7f44fd72d8becc60c223ba90793812c4756764f9807610d393ecca5ba05187e8aefb0d3530d67a7525b4e2c638160161410b369937e912a
diff --git a/dev-ruby/pg/pg-1.3.5.ebuild b/dev-ruby/pg/pg-1.3.5.ebuild
deleted file mode 100644
index 3b9ccc759fa7..000000000000
--- a/dev-ruby/pg/pg-1.3.5.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_GEMSPEC="pg.gemspec"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRADOC="Contributors.rdoc README.rdoc History.rdoc"
-
-RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby extension library providing an API to PostgreSQL"
-HOMEPAGE="https://github.com/ged/ruby-pg"
-SRC_URI="https://github.com/ged/ruby-pg/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-RUBY_S="ruby-${P}"
-
-LICENSE="|| ( BSD-2 Ruby-BSD )"
-SLOT="1"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND+=" dev-db/postgresql:*"
-DEPEND+=" dev-db/postgresql
- test? ( >=dev-db/postgresql-9.4[server(+),threads] )"
-
-all_ruby_prepare() {
- # hack the Rakefile to make it sure that it doesn't load
- # rake-compiler (so that we don't have to depend on it and it
- # actually works when building with USE=doc).
- sed -i \
- -e '/Rakefile.cross/s:^:#:' \
- -e '/ExtensionTask/,/^end$/ s:^:#:' \
- Rakefile || die
-
- sed -e 's/git ls-files -z/find * -print0/' \
- -e "s:_relative ': './:" \
- -e 's/__dir__/"."/' \
- -i ${RUBY_FAKEGEM_GEMSPEC} || die
-
- # Avoid tests that assume IPv4
- sed -i -e '/expect.*hostaddr/ s:^:#:' spec/pg/connection_spec.rb || die
-
- # Avoid test that only works with bundled pg
- sed -i -e '/tells about the libpq library path/askip "gentoo"' spec/pg_spec.rb || die
-}
-
-each_ruby_test() {
- if [[ "${EUID}" -ne "0" ]]; then
- # Make the rspec call explicit, this way we don't have to depend
- # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
- # the whole extension from scratch.
- RSPEC_VERSION=3 ruby-ng_rspec
- else
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
-}