summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-03-22 23:42:54 +0000
committerMarek Szuba <marecki@gentoo.org>2023-03-22 23:43:36 +0000
commitbf637c6f3255cf9c06cf4761ea8c670fa4e3bc99 (patch)
tree77f22d074d6338ac8ec3962b8b8419067f88fe43
parentmedia-gfx/gmic: add 3.2.2, drop 3.2.1 (diff)
downloadgentoo-bf637c6f3255cf9c06cf4761ea8c670fa4e3bc99.tar.gz
gentoo-bf637c6f3255cf9c06cf4761ea8c670fa4e3bc99.tar.bz2
gentoo-bf637c6f3255cf9c06cf4761ea8c670fa4e3bc99.zip
net-misc/oidc-agent: add 4.5.1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--net-misc/oidc-agent/Manifest1
-rw-r--r--net-misc/oidc-agent/oidc-agent-4.5.1.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/net-misc/oidc-agent/Manifest b/net-misc/oidc-agent/Manifest
index dd20a86c9c6c..cbb3cef98433 100644
--- a/net-misc/oidc-agent/Manifest
+++ b/net-misc/oidc-agent/Manifest
@@ -1,2 +1,3 @@
DIST oidc-agent-4.3.1.tar.gz 2124200 BLAKE2B 4108f50688fd0d2043105972a7a7fbab58a74b6a36e0d0a739be5b42a29c3b6bedb29b2273038d49b77fc3245a51f8cf998a12fee5e39096dd5e35ec72660b05 SHA512 3b598f760b1932a07bb243ce7c978a99c209ffbe5594cbb9e084c430c11c089ff0f7be113f73b165bd5f6b382d0ab30dd230c4c9fab6e210a327af20715e6d60
DIST oidc-agent-4.5.0.tar.gz 1823181 BLAKE2B d2023494689ec65837efcd67e325c690ec1b3a03f78dccce853d1c30e312a89d5d43476132830d10aa63ead7b5cfc91b99fcf78fdfa2d46c60e5a62030c77884 SHA512 23520dc5556ed54ad2dcf3a14a5183f04b1f8030aafd342cfb5f4e21683058da475335c7b29ae0727bd20405e42fad825614d1b7c86fca5a81e4bf3cae5f64c1
+DIST oidc-agent-4.5.1.tar.gz 1823853 BLAKE2B d73ce4405ead08ddc0433a5c3b660b08037eecbde5f1e0358cad8731d0787e63ffae4b1317ecfe824a951e07a82d600fa4180557d93d0ce5a382e8c8f39289d6 SHA512 9afffbfcb00c610b04f97c59d610799a4ce45b1c40a61e388c6ab8b550381725602e43d219ce475a9d0425c1bc07b49ca982379286e9f48ebae1e19ca4587779
diff --git a/net-misc/oidc-agent/oidc-agent-4.5.1.ebuild b/net-misc/oidc-agent/oidc-agent-4.5.1.ebuild
new file mode 100644
index 000000000000..459b2148429c
--- /dev/null
+++ b/net-misc/oidc-agent/oidc-agent-4.5.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Agent and tools for managing OpenID Connect tokens on the command line"
+HOMEPAGE="https://github.com/indigo-dc/oidc-agent"
+SRC_URI="https://github.com/indigo-dc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="test"
+
+DEPEND="app-crypt/libsecret
+ dev-libs/cJSON:=
+ dev-libs/libsodium:=
+ media-gfx/qrencode
+ net-libs/libmicrohttpd:=
+ net-libs/webkit-gtk:4.1=
+ net-misc/curl
+ elibc_musl? ( sys-libs/argp-standalone )"
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( dev-libs/check )"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.4.0_deps-automagic.patch
+ "${FILESDIR}"/${PN}-4.4.0_install-perms.patch
+ "${FILESDIR}"/${PN}-4.5.0_webkit41.patch
+)
+
+src_prepare() {
+ xdg_environment_reset
+ default
+ sed -i -e 's|^\(\s\+\)@|\1|' Makefile || die "Failed to increase verbosity in Makefile"
+}
+
+src_compile() {
+ local -x USE_CJSON_SO=1
+ use elibc_musl && local -x USE_ARGP_SO=1
+ emake -j1 create_obj_dir_structure create_picobj_dir_structure # Bug #880157
+ emake
+}
+
+src_install() {
+ emake \
+ PREFIX="${ED}" \
+ BIN_AFTER_INST_PATH="/usr" \
+ INCLUDE_PATH="${ED}"/usr/include \
+ LIB_PATH="${ED}"/usr/$(get_libdir) \
+ install
+
+ # This file is not compatible with Gentoo and in any case, we generally
+ # let the users load such agents themselves.
+ rm -f "${ED}"/etc/X11/Xsession.d/91${PN}
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog
+ elog "You should use oidc-gen to initially generate your account configuration"
+ elog "before it can be loaded into oidc-agent using oidc-add. For details, please"
+ elog "consult the man page of oidc-gen, or full documentation at"
+ elog " https://indigo-dc.gitbooks.io/oidc-agent/"
+ elog
+ else
+ local new_major_ver old_ver
+ new_major_ver=$(ver_cut 1)
+ for old_ver in ${REPLACING_VERSIONS}; do
+ if [[ $(ver_cut 1 ${old_ver}) != ${new_major_ver} ]]; then
+ ewarn
+ ewarn "You are upgrading from a different major version. Please restart any running instances of ${PN}"
+ ewarn "to make sure they are compatible with the updated clients."
+ ewarn
+ break
+ fi
+ done
+ fi
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}