summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-07-17 20:14:50 +0200
committerDavid Seifert <soap@gentoo.org>2021-07-17 20:14:50 +0200
commitbfa996e0f1f8e5e6e25dc79344af0687168045e3 (patch)
tree6f6abe454060a511f2819c54e489cda0cb0f74e7
parentapp-emulation/fs-uae-launcher: PYTHON_MULTI_USEDEP -> PYTHON_USEDEP (diff)
downloadgentoo-bfa996e0f1f8e5e6e25dc79344af0687168045e3.tar.gz
gentoo-bfa996e0f1f8e5e6e25dc79344af0687168045e3.tar.bz2
gentoo-bfa996e0f1f8e5e6e25dc79344af0687168045e3.zip
app-emulation/virt-manager: PYTHON_MULTI_USEDEP -> PYTHON_USEDEP
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--app-emulation/virt-manager/virt-manager-2.2.1-r3.ebuild10
-rw-r--r--app-emulation/virt-manager/virt-manager-3.1.0.ebuild12
-rw-r--r--app-emulation/virt-manager/virt-manager-3.2.0.ebuild12
-rw-r--r--app-emulation/virt-manager/virt-manager-9999.ebuild14
4 files changed, 24 insertions, 24 deletions
diff --git a/app-emulation/virt-manager/virt-manager-2.2.1-r3.ebuild b/app-emulation/virt-manager/virt-manager-2.2.1-r3.ebuild
index e0ce6f6fc762..a5da10c5d597 100644
--- a/app-emulation/virt-manager/virt-manager-2.2.1-r3.ebuild
+++ b/app-emulation/virt-manager/virt-manager-2.2.1-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_8 )
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_SETUPTOOLS=no
@@ -30,10 +30,10 @@ RDEPEND="!app-emulation/virtinst
app-cdr/cdrtools
>=app-emulation/libvirt-glib-1.0.0[introspection]
$(python_gen_cond_dep '
- dev-libs/libxml2[python,${PYTHON_MULTI_USEDEP}]
- dev-python/libvirt-python[${PYTHON_MULTI_USEDEP}]
- dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
- dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
+ dev-python/libvirt-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
')
>=sys-libs/libosinfo-0.2.10[introspection]
gtk? (
diff --git a/app-emulation/virt-manager/virt-manager-3.1.0.ebuild b/app-emulation/virt-manager/virt-manager-3.1.0.ebuild
index 7b57165eb531..cec598a0ff27 100644
--- a/app-emulation/virt-manager/virt-manager-3.1.0.ebuild
+++ b/app-emulation/virt-manager/virt-manager-3.1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9} )
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_SETUPTOOLS=no
@@ -30,11 +30,11 @@ RDEPEND="!app-emulation/virtinst
app-cdr/cdrtools
>=app-emulation/libvirt-glib-1.0.0[introspection]
$(python_gen_cond_dep '
- dev-libs/libxml2[python,${PYTHON_MULTI_USEDEP}]
- dev-python/argcomplete[${PYTHON_MULTI_USEDEP}]
- dev-python/libvirt-python[${PYTHON_MULTI_USEDEP}]
- dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
- dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ dev-python/libvirt-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
')
>=sys-libs/libosinfo-0.2.10[introspection]
gtk? (
diff --git a/app-emulation/virt-manager/virt-manager-3.2.0.ebuild b/app-emulation/virt-manager/virt-manager-3.2.0.ebuild
index ddd942dd7b23..8529c5b317cb 100644
--- a/app-emulation/virt-manager/virt-manager-3.2.0.ebuild
+++ b/app-emulation/virt-manager/virt-manager-3.2.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9} )
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_SETUPTOOLS=no
@@ -29,11 +29,11 @@ RDEPEND="${PYTHON_DEPS}
app-cdr/cdrtools
>=app-emulation/libvirt-glib-1.0.0[introspection]
$(python_gen_cond_dep '
- dev-libs/libxml2[python,${PYTHON_MULTI_USEDEP}]
- dev-python/argcomplete[${PYTHON_MULTI_USEDEP}]
- >=dev-python/libvirt-python-6.10.0[${PYTHON_MULTI_USEDEP}]
- dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
- dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ >=dev-python/libvirt-python-6.10.0[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
')
>=sys-libs/libosinfo-0.2.10[introspection]
gtk? (
diff --git a/app-emulation/virt-manager/virt-manager-9999.ebuild b/app-emulation/virt-manager/virt-manager-9999.ebuild
index 3e4593a1f8a9..18fe7b6fb023 100644
--- a/app-emulation/virt-manager/virt-manager-9999.ebuild
+++ b/app-emulation/virt-manager/virt-manager-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9} )
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_SETUPTOOLS=no
@@ -30,12 +30,12 @@ RDEPEND="${PYTHON_DEPS}
app-cdr/cdrtools
>=app-emulation/libvirt-glib-1.0.0[introspection]
$(python_gen_cond_dep '
- dev-libs/libxml2[python,${PYTHON_MULTI_USEDEP}]
- dev-python/argcomplete[${PYTHON_MULTI_USEDEP}]
- >=dev-python/libvirt-python-6.10.0[${PYTHON_MULTI_USEDEP}]
- dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
- dev-python/requests[${PYTHON_MULTI_USEDEP}]
- dev-python/tqdm[${PYTHON_MULTI_USEDEP}]
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ >=dev-python/libvirt-python-6.10.0[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
')
>=sys-libs/libosinfo-0.2.10[introspection]
gtk? (