summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-02-05 15:28:01 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-02-05 15:28:01 -0800
commitbfc4909893cae1c52c4860c6b7a0acd41eccbc95 (patch)
treeaea03aeee4064693b959104ea8bfff5b3805f0b0
parentdev-games/freecell-solver: python3_8 (diff)
downloadgentoo-bfc4909893cae1c52c4860c6b7a0acd41eccbc95.tar.gz
gentoo-bfc4909893cae1c52c4860c6b7a0acd41eccbc95.tar.bz2
gentoo-bfc4909893cae1c52c4860c6b7a0acd41eccbc95.zip
dev-python/pyudev-0.22.0: Version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/pyudev/Manifest1
-rw-r--r--dev-python/pyudev/metadata.xml1
-rw-r--r--dev-python/pyudev/pyudev-0.22.0.ebuild51
3 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/pyudev/Manifest b/dev-python/pyudev/Manifest
index 5b73a2d2813e..e888f4c61e96 100644
--- a/dev-python/pyudev/Manifest
+++ b/dev-python/pyudev/Manifest
@@ -1 +1,2 @@
DIST pyudev-0.21.0.tar.gz 89469 BLAKE2B 3bf9ac46442c5948d131932c7b62a59ef979755f2d55bcd0165fc1b69b865268051fdeab7605c8a1cb0694ce0f4b88f31a1e6a1893900a7300ddf6439734712e SHA512 ba5b6156768b65b9655d809b14378b01173643781b9c4017271e880cdfed442c44ac49eb26c970e4275b820e01678e3001870591fccf88dc713ec941e2b85d11
+DIST pyudev-0.22.0.tar.gz 85077 BLAKE2B 66c78aa4d3bea5ceae3660a93e5bd1733629bb5228d67d8e647abb8c237a2786c1061b07e034be5467f5bcab58d95ba30f91d74bdc54cd8253dff69be3ad4a80 SHA512 a09ed479a54a1772a6af68cb975fef792068c2de3655e20223905bc3f574fd32bd3dbe6b97062eee3ab5f08a8b041ad3ea86dfb68c839ea44e29d65ec1686670
diff --git a/dev-python/pyudev/metadata.xml b/dev-python/pyudev/metadata.xml
index 9c052c908df4..dbaac4f67640 100644
--- a/dev-python/pyudev/metadata.xml
+++ b/dev-python/pyudev/metadata.xml
@@ -10,7 +10,6 @@
and service found in modern linux systems.
</longdescription>
<use>
- <flag name="pygobject">Install PyGobject bindings</flag>
<flag name="qt5">Install PyQt5 bindings</flag>
</use>
<upstream>
diff --git a/dev-python/pyudev/pyudev-0.22.0.ebuild b/dev-python/pyudev/pyudev-0.22.0.ebuild
new file mode 100644
index 000000000000..2fba5997b60f
--- /dev/null
+++ b/dev-python/pyudev/pyudev-0.22.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python binding to libudev"
+HOMEPAGE="https://pyudev.readthedocs.io/en/latest/ https://github.com/pyudev/pyudev"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+IUSE="qt5"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ virtual/udev
+ qt5? ( dev-python/PyQt5[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( CHANGES.rst README.rst )
+
+#PATCHES=(
+# "${FILESDIR}/${PN}-0.19.0-skip-non-deterministic-test.patch"
+#)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if use test; then
+ ewarn "If your PORTAGE_TMPDIR is longer in length then '/var/tmp/',"
+ ewarn "change it to /var/tmp to ensure tests will pass."
+ fi
+
+ # tests are known to pass then fail on alternate runs
+ # tests: fix run_path
+ sed -i -e "s|== \('/run/udev'\)|in (\1,'/dev/.udev')|g" \
+ tests/test_core.py || die
+
+ distutils-r1_python_prepare_all
+}