summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-04 20:03:28 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-04 20:54:55 +0300
commitbfd7337045b0e5dafe9135fc17f639d9887a5790 (patch)
tree052cf5edc70c99575c3f88b7ab3d3d1a001e4dcd
parentdev-python/phonenumbers: add 8.12.53 (diff)
downloadgentoo-bfd7337045b0e5dafe9135fc17f639d9887a5790.tar.gz
gentoo-bfd7337045b0e5dafe9135fc17f639d9887a5790.tar.bz2
gentoo-bfd7337045b0e5dafe9135fc17f639d9887a5790.zip
dev-python/oslo-concurrency: add 5.0.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/oslo-concurrency/Manifest1
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-5.0.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/oslo-concurrency/Manifest b/dev-python/oslo-concurrency/Manifest
index d4b2f95340f1..e2ef7144db99 100644
--- a/dev-python/oslo-concurrency/Manifest
+++ b/dev-python/oslo-concurrency/Manifest
@@ -1 +1,2 @@
DIST oslo.concurrency-4.5.1.tar.gz 59126 BLAKE2B 61f509b4ce76cd036b695bb5ad744374e029239a63a629a4b96d44c8ba29150095fe9d57000367c4d07dc7c358ef61cfa4868a2347f206327093ad32ffb85955 SHA512 88319915c90befb01a275666b4a760357c1e72f04d5faf27ab9c67629ecbf2dd3a73d077f3c57435231b55aa777a9642f26e91cc4cb27ad56eb801b2b98eca48
+DIST oslo.concurrency-5.0.0.tar.gz 59343 BLAKE2B 412fba38e0281b2c6d7b27182d159c99730a22ec3400586481f234998cd2f446de5cdd84aaa3abb1cdd93eb9eff1294c87ce51e165dc49caa078e69932ecd19b SHA512 570acbaf599a8a177ba6bc7c009edb43db5e077c06bee5c5895d81944daf78c8dde197bd9af730b17b5075fdaf527252aa44ea0edb79d73e16714582645afb7e
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-5.0.0.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-5.0.0.ebuild
new file mode 100644
index 000000000000..e51f8493591c
--- /dev/null
+++ b/dev-python/oslo-concurrency/oslo-concurrency-5.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Oslo Concurrency library"
+HOMEPAGE="https://pypi.org/project/oslo.concurrency/
+ https://github.com/openstack/oslo.concurrency"
+SRC_URI="mirror://pypi/o/${PN/-/.}/${PN/-/.}-${PV}.tar.gz"
+S="${WORKDIR}/${PN/-/.}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/eventlet-0.19.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+ )
+"
+
+distutils_enable_tests unittest
+
+python_compile() {
+ distutils-r1_python_compile
+ if ! has "${EPYTHON}" python3.{8..9}; then
+ find "${BUILD_DIR}"/install -name '*eventlet*.py' -delete || die
+ fi
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ eunittest
+}