summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2023-11-05 23:07:26 +0100
committerSebastian Pipping <sping@gentoo.org>2023-11-05 23:07:36 +0100
commitc004e47374d840b93b534cf6fd304292586ad0c9 (patch)
tree5771713cd47b30a9e6f251551cf457cd0c3836f8
parentx11-misc/safeeyes: Drop old (diff)
downloadgentoo-c004e47374d840b93b534cf6fd304292586ad0c9.tar.gz
gentoo-c004e47374d840b93b534cf6fd304292586ad0c9.tar.bz2
gentoo-c004e47374d840b93b534cf6fd304292586ad0c9.zip
x11-misc/safeeyes: Python 3.12 + EmptyGlobalAssignment
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
-rw-r--r--x11-misc/safeeyes/safeeyes-2.1.6-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-misc/safeeyes/safeeyes-2.1.6-r1.ebuild b/x11-misc/safeeyes/safeeyes-2.1.6-r1.ebuild
new file mode 100644
index 000000000000..02c1bee35ae8
--- /dev/null
+++ b/x11-misc/safeeyes/safeeyes-2.1.6-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_REQ_USE="tk" # for site-packages/Xlib/ext/randr.py
+DISTUTILS_USE_PEP517=setuptools
+
+inherit xdg distutils-r1 pypi
+
+DESCRIPTION="Linux alternative to EyeLeo"
+HOMEPAGE="https://github.com/slgobinath/SafeEyes"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/libayatana-appindicator
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/croniter[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-sound/alsa-utils
+ x11-apps/xprop
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-misc/xprintidle
+ "
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}