summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-16 09:23:24 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-16 09:23:34 -0400
commitc0068bb3863bdee6d3d01f78b7d7ea6a8f23261c (patch)
tree35d006c38b789c42272c715b265ccf937d3c38b3
parentgnome-extra/evolution-data-server: Add patch for cmake-3.20 compat (diff)
downloadgentoo-c0068bb3863bdee6d3d01f78b7d7ea6a8f23261c.tar.gz
gentoo-c0068bb3863bdee6d3d01f78b7d7ea6a8f23261c.tar.bz2
gentoo-c0068bb3863bdee6d3d01f78b7d7ea6a8f23261c.zip
mail-client/evolution: Add patch for cmake-3.20 compat
Closes: https://bugs.gentoo.org/781971 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--mail-client/evolution/evolution-3.38.4.ebuild2
-rw-r--r--mail-client/evolution/files/3.38-PrintableOptions.cmake-Correct-variable-name-compari.patch75
2 files changed, 77 insertions, 0 deletions
diff --git a/mail-client/evolution/evolution-3.38.4.ebuild b/mail-client/evolution/evolution-3.38.4.ebuild
index 3a5b63903436..3dbfedc6526c 100644
--- a/mail-client/evolution/evolution-3.38.4.ebuild
+++ b/mail-client/evolution/evolution-3.38.4.ebuild
@@ -95,6 +95,8 @@ file from /usr/share/applications if you use a different browser)."
src_prepare() {
cmake_src_prepare
gnome2_src_prepare
+
+ eapply "${FILESDIR}"/3.38-PrintableOptions.cmake-Correct-variable-name-compari.patch
}
src_configure() {
diff --git a/mail-client/evolution/files/3.38-PrintableOptions.cmake-Correct-variable-name-compari.patch b/mail-client/evolution/files/3.38-PrintableOptions.cmake-Correct-variable-name-compari.patch
new file mode 100644
index 000000000000..f7e8855bbe08
--- /dev/null
+++ b/mail-client/evolution/files/3.38-PrintableOptions.cmake-Correct-variable-name-compari.patch
@@ -0,0 +1,75 @@
+From 7cfe4190e3e72b40472d57871459f1b136393003 Mon Sep 17 00:00:00 2001
+From: Milan Crha <mcrha@redhat.com>
+Date: Wed, 14 Apr 2021 16:58:08 +0200
+Subject: [PATCH] PrintableOptions.cmake: Correct variable name comparison
+
+CMake 3.20.1 errors out with:
+
+CMake Error at cmake/modules/PrintableOptions.cmake:38 (message):
+ variable name cannot be empty
+ Call Stack (most recent call first):
+ CMakeLists.txt:152 (add_printable_variable)
+
+Change how the parameter value is compared, to fix it.
+---
+ cmake/modules/PrintableOptions.cmake | 20 ++++++++++----------
+ 1 file changed, 10 insertions(+), 10 deletions(-)
+
+diff --git a/cmake/modules/PrintableOptions.cmake b/cmake/modules/PrintableOptions.cmake
+index ba1c9d0b7f..339f1da4b4 100644
+--- a/cmake/modules/PrintableOptions.cmake
++++ b/cmake/modules/PrintableOptions.cmake
+@@ -19,40 +19,40 @@
+ # prints all the build options previously added with the above functions
+
+ macro(add_printable_variable_bare _name)
+- if(_name STREQUAL "")
++ if("${_name}" STREQUAL "")
+ message(FATAL_ERROR "variable name cannot be empty")
+- endif(_name STREQUAL "")
++ endif("${_name}" STREQUAL "")
+ list(APPEND _printable_options ${_name})
+ endmacro()
+
+ macro(add_printable_option _name _description _default_value)
+- if(_name STREQUAL "")
++ if("${_name}" STREQUAL "")
+ message(FATAL_ERROR "option name cannot be empty")
+- endif(_name STREQUAL "")
++ endif("${_name}" STREQUAL "")
+ option(${_name} ${_description} ${_default_value})
+ add_printable_variable_bare(${_name})
+ endmacro()
+
+ macro(add_printable_variable _name _description _default_value)
+- if(_name STREQUAL "")
++ if("${_name}" STREQUAL "")
+ message(FATAL_ERROR "variable name cannot be empty")
+- endif(_name STREQUAL "")
++ endif("${_name}" STREQUAL "")
+ set(${_name} ${_default_value} CACHE STRING ${_description})
+ add_printable_variable_bare(${_name})
+ endmacro()
+
+ macro(add_printable_variable_path _name _description _default_value)
+- if(_name STREQUAL "")
++ if("${_name}" STREQUAL "")
+ message(FATAL_ERROR "path variable name cannot be empty")
+- endif(_name STREQUAL "")
++ endif("${_name}" STREQUAL "")
+ set(${_name} ${_default_value} CACHE PATH ${_description})
+ add_printable_variable_bare(${_name})
+ endmacro()
+
+ macro(add_printable_variable_filepath _name _description _default_value)
+- if(_name STREQUAL "")
++ if("${_name}" STREQUAL "")
+ message(FATAL_ERROR "filepath variable name cannot be empty")
+- endif(_name STREQUAL "")
++ endif("${_name}" STREQUAL "")
+ set(${_name} ${_default_value} CACHE FILEPATH ${_description})
+ add_printable_variable_bare(${_name})
+ endmacro()
+--
+2.26.3
+