summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-06-10 14:59:28 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-06-10 17:30:40 +0200
commitc0179faf5c2e761875eaa5f0e963c5503c062b8c (patch)
tree05ab12ff96157723720d2fe270fd7e78344ee97f
parentnet-p2p/ktorrent: 21.04.2 version bump (diff)
downloadgentoo-c0179faf5c2e761875eaa5f0e963c5503c062b8c.tar.gz
gentoo-c0179faf5c2e761875eaa5f0e963c5503c062b8c.tar.bz2
gentoo-c0179faf5c2e761875eaa5f0e963c5503c062b8c.zip
dev-libs/kopeninghours: 21.04.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/kopeninghours/Manifest1
-rw-r--r--dev-libs/kopeninghours/kopeninghours-21.04.2.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/kopeninghours/Manifest b/dev-libs/kopeninghours/Manifest
index 35cbd0438ce3..b877b495d3ed 100644
--- a/dev-libs/kopeninghours/Manifest
+++ b/dev-libs/kopeninghours/Manifest
@@ -1 +1,2 @@
DIST kopeninghours-21.04.1.tar.xz 62176 BLAKE2B c0b8bbc747fdc947eb05980796a0b8c2f6006cff4278ec5fe941eaed66becb8904e05b599a7562680bdfee79ecdc6755bbe4afdd8dec928b7ef404becbd9c3d1 SHA512 dd65c0ef888e5e8b88109eb9e873203f190ca657812d4be72ac59d2ac7910fad9342a47b185af1c6949cd9045f15e1deaae0ac95eebee64d10e702621a8d2fe0
+DIST kopeninghours-21.04.2.tar.xz 62824 BLAKE2B 1bd346fc46894199fd0f80a5cb35768de4131d1c0daf4594f4500745f8b0e79209fe41308b8e005fa1b0c6424d1776aeece3dd39b065e6ce0159f9a094679df3 SHA512 566550704a1ffe92249a026ffca10ec52514e2460da459df6dbf457065cfab5c9462ff1b9a90aa9c35637121fdff00ac89986764b5c77b519f5ac5c2174faf85
diff --git a/dev-libs/kopeninghours/kopeninghours-21.04.2.ebuild b/dev-libs/kopeninghours/kopeninghours-21.04.2.ebuild
new file mode 100644
index 000000000000..405678cd3d3d
--- /dev/null
+++ b/dev-libs/kopeninghours/kopeninghours-21.04.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="true"
+KDE_GEAR="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.80.0
+QTMIN=5.15.2
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit ecm kde.org python-single-r1
+
+DESCRIPTION="Library for parsing and evaluating OSM opening hours expressions"
+HOMEPAGE="https://api.kde.org/kopeninghours/html/index.html
+https://invent.kde.org/libraries/kopeninghours"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=kde-frameworks/kholidays-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ sys-libs/zlib
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.70:=[python,${PYTHON_MULTI_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-21.03.90-boostpython.patch )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOSTPYTHON_VERSION_MAJOR_MINOR=${EPYTHON}
+ $(cmake_use_find_package python Boost)
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ python_optimize
+}