summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-10 07:33:16 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-10 07:53:51 +0200
commitc0385de165ccbecafe4c0fac6945127923f05d09 (patch)
tree6eb61e0ca9edbad128f8747e9e6b0caa9261b53c
parentdev-python/ujson: Bump to 4.0.1 (diff)
downloadgentoo-c0385de165ccbecafe4c0fac6945127923f05d09.tar.gz
gentoo-c0385de165ccbecafe4c0fac6945127923f05d09.tar.bz2
gentoo-c0385de165ccbecafe4c0fac6945127923f05d09.zip
dev-python/vcrpy: Bump to 4.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/vcrpy/Manifest1
-rw-r--r--dev-python/vcrpy/vcrpy-4.1.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index 7b8263e40cd2..689c02bcb00c 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1 +1,2 @@
DIST vcrpy-4.1.0.tar.gz 330122 BLAKE2B a7a2516d4dfcc01da801fb8685ea3b56f50ce474d35477ae36785ea1bfbae113bd3c18fb3faadb13fc81c37fa1d282a84bc60fdd27f4fc4a1f3e952312d7bc5f SHA512 7ad5517cd52f6f31448db9b608d8a7b274741727487ede21b7f80e4060e3ddbb34c731166f67ae7136c86a8d3e7fd23128e035a148f18f771066bfa71319624f
+DIST vcrpy-4.1.1.tar.gz 329508 BLAKE2B b6981150a8fd742301e0d7897d84855c741c97307bbb5c5751680f3d33d69d6333a18d714fcc14cb018f5dd6c02e840e1313136660c4459e2755d448fc0b07e9 SHA512 afa1904bff37bfd2d278ed49fa3982a357eb6bb113818b532044da0f11a9dd877cc152d7f0d81d88bdc0f870521b1241f6aecf959f668211904e3c6c7cea4ad8
diff --git a/dev-python/vcrpy/vcrpy-4.1.1.ebuild b/dev-python/vcrpy/vcrpy-4.1.1.ebuild
new file mode 100644
index 000000000000..e28175b7cb17
--- /dev/null
+++ b/dev-python/vcrpy/vcrpy-4.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
+HOMEPAGE="https://github.com/kevin1024/vcrpy"
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # tests requiring Internet
+ rm tests/integration/test_aiohttp.py || die
+ rm tests/integration/test_boto.py || die
+ sed -e 's:test_flickr_should_respond_with_200:_&:' \
+ -e 's:test_amazon_doctype:_&:' \
+ -i tests/integration/test_wild.py || die
+ sed -e 's:testing_connect:_&:' \
+ -i tests/unit/test_stubs.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}