summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2018-07-25 19:33:17 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2018-07-25 19:33:17 +0000
commitc0425ce60cb8aab6f190b64d86de61c43d6e390e (patch)
treeafe4e2bbbb04e74cd15d2477881c7ef9e95dc7ae
parentmedia-gfx/imagemagick: v6.9.10-8 & v7.0.8-8 (diff)
downloadgentoo-c0425ce60cb8aab6f190b64d86de61c43d6e390e.tar.gz
gentoo-c0425ce60cb8aab6f190b64d86de61c43d6e390e.tar.bz2
gentoo-c0425ce60cb8aab6f190b64d86de61c43d6e390e.zip
www-apps/drupal: Bump to 8.5.5 release.
Package-Manager: Portage-2.3.42, Repoman-2.3.9
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-8.5.5.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index 26657d92e42c..7e7889398818 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,2 +1,3 @@
DIST drupal-7.59.tar.gz 3282260 BLAKE2B bf7d74926fe4e94149ef7ff622cf7889f45f3e35b9bfd19fed12aa688c8131f2f8daa2a261796896d5386966603e837b6dec3b6c02221f9b0c527c4a6f5ff9da SHA512 68f02b39d1a4658adc0f0046c22cc1059b68f952f9cd753f5a3e379cf93705be308b4727519e90d77a42437442daebaa78d76745954be4d40e1a5105c319069c
DIST drupal-8.5.4.tar.gz 15779939 BLAKE2B a016402e9165d64b8998df1f4aa76b6345400e8a3aa909941244fec21112edc05977c1f4464b3679f44aded3addf3174794e075db546d585da836f36d1771df1 SHA512 7171818533dba2c1cf19fc0dd4fc0884502e007c9fe8669dc8131a927ba1a5b14322a8ba1f465ff1aac5bd8e61a8fd17c632ea4b1e321469595d144a752546d2
+DIST drupal-8.5.5.tar.gz 15786935 BLAKE2B ba4ba412402c366be9499131913f42e4457dab149c3624a7fa72d6f4f051096d5194fc90a344a22e5da46180adfa446caa428f3a20c322d2f6bde0c80c5acb17 SHA512 bc0fe05a798f5a791e6a5777b308ff815f5c75105b9c40c0d7ac855fdd5de46192b7fdad213f4d267e89b8b50844fdcb52c24c470f3f6c01ec5ee59d2a982637
diff --git a/www-apps/drupal/drupal-8.5.5.ebuild b/www-apps/drupal/drupal-8.5.5.ebuild
new file mode 100644
index 000000000000..ec2dacba2d14
--- /dev/null
+++ b/www-apps/drupal/drupal-8.5.5.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+ virtual/httpd-php
+ accelerator? ( ||
+ (
+ dev-php/xcache
+ (
+ >=dev-lang/php-5.5[opcache]
+ dev-php/pecl-apcu
+ )
+ )
+ )
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}