summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-12-05 19:03:16 +0100
committerDavid Seifert <soap@gentoo.org>2016-12-05 19:40:21 +0100
commitc0587fa6588c986ef73d1bc1cf444eaaa47f97bb (patch)
tree23f9d51c0bbf3ce8238a4dab625be30ce4d2c4f2
parentdev-cpp/libbackend-elements: Remove old (diff)
downloadgentoo-c0587fa6588c986ef73d1bc1cf444eaaa47f97bb.tar.gz
gentoo-c0587fa6588c986ef73d1bc1cf444eaaa47f97bb.tar.bz2
gentoo-c0587fa6588c986ef73d1bc1cf444eaaa47f97bb.zip
dev-cpp/libcult: Remove old
Closes: https://github.com/gentoo/gentoo/pull/3022
-rw-r--r--dev-cpp/libcult/Manifest1
-rw-r--r--dev-cpp/libcult/files/1.4.6-fix-compilation-with-gcc-4.7.patch57
-rw-r--r--dev-cpp/libcult/files/libcult-1.4.6-cpp14.patch163
-rw-r--r--dev-cpp/libcult/libcult-1.4.6-r1.ebuild87
-rw-r--r--dev-cpp/libcult/metadata.xml8
-rw-r--r--profiles/package.mask1
6 files changed, 0 insertions, 317 deletions
diff --git a/dev-cpp/libcult/Manifest b/dev-cpp/libcult/Manifest
deleted file mode 100644
index 2be1c500e6f0..000000000000
--- a/dev-cpp/libcult/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST libcult-1.4.6.tar.bz2 51036 SHA256 f1b51023880440d3e673bf9c3d2b034f1e16511b33ab006cd9f7d937246e48ac SHA512 4a3a3a2967bf8c8eaf47b028bbd475245d89ba746352b62a0e8fdc80ba912e90a928e2f4c863812b86e4c3881294d816a822c0f63a0aea2edc3f08d80365b3fd WHIRLPOOL 4bbf5e4ff7bef4c0c086b2c0be318c733b545f5910e72876ccf967d138df0d3de3b3c1f368147d64fd42828a7eecf1c3a5884c397f964df23dc0308ed8e13b43
diff --git a/dev-cpp/libcult/files/1.4.6-fix-compilation-with-gcc-4.7.patch b/dev-cpp/libcult/files/1.4.6-fix-compilation-with-gcc-4.7.patch
deleted file mode 100644
index f7b169a7cde2..000000000000
--- a/dev-cpp/libcult/files/1.4.6-fix-compilation-with-gcc-4.7.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From 2ef8e0426baad35a3438f9497005c3e3391e23f0 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Tiziano=20M=C3=BCller?= <tm@dev-zero.ch>
-Date: Fri, 1 Jun 2012 10:12:33 +0200
-Subject: [PATCH 2/2] fix compilation with gcc-4.7
-
----
- cult/mm/evptr.hxx | 4 ++--
- cult/mm/shptr.hxx | 4 ++--
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/cult/mm/evptr.hxx b/cult/mm/evptr.hxx
-index 18f232c..ed0bd93 100644
---- a/cult/mm/evptr.hxx
-+++ b/cult/mm/evptr.hxx
-@@ -70,7 +70,7 @@ namespace Cult
- Evptr&
- operator= (Evptr const& ep)
- {
-- assign (ep.cp_ ? ep.cp_ : ep.p_, ep.c_);
-+ this->assign (ep.cp_ ? ep.cp_ : ep.p_, ep.c_);
-
- return *this;
- }
-@@ -79,7 +79,7 @@ namespace Cult
- Evptr&
- operator= (Evptr<Y> const& ep)
- {
-- assign (ep.cp_ ? ep.cp_ : ep.p_, ep.c_);
-+ this->assign (ep.cp_ ? ep.cp_ : ep.p_, ep.c_);
-
- return *this;
- }
-diff --git a/cult/mm/shptr.hxx b/cult/mm/shptr.hxx
-index a5e1257..6630b1c 100644
---- a/cult/mm/shptr.hxx
-+++ b/cult/mm/shptr.hxx
-@@ -45,7 +45,7 @@ namespace Cult
- Shptr&
- operator= (Shptr const& ap)
- {
-- assign (ap);
-+ this->assign (ap);
- return *this;
- }
-
-@@ -53,7 +53,7 @@ namespace Cult
- Shptr&
- operator= (Shptr<Y> const& ap)
- {
-- assign (ap);
-+ this->assign (ap);
- return *this;
- }
-
---
-1.7.8.5
-
diff --git a/dev-cpp/libcult/files/libcult-1.4.6-cpp14.patch b/dev-cpp/libcult/files/libcult-1.4.6-cpp14.patch
deleted file mode 100644
index b35712248fb7..000000000000
--- a/dev-cpp/libcult/files/libcult-1.4.6-cpp14.patch
+++ /dev/null
@@ -1,163 +0,0 @@
-Fix compilation with GCC 6.x (C++14 as default standard). Remove throw
-specificator from function declaration when compilation is performed with
-standard >= C++11. Adds one cast to argument in C++11, C++14.
-Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=593928
-
---- a/cult/cli/file-arguments.hxx
-+++ b/cult/cli/file-arguments.hxx
-@@ -46,8 +46,12 @@
- {
- if (i >= size ())
- throw Bounds ();
--
-- args_.erase (args_.begin () + i);
-+
-+#if __cplusplus < 201103L
-+ args_.erase (args_.begin() + i);
-+#else
-+ args_.erase ((Containers::Vector<String>::ConstIterator)(args_.begin () + i));
-+#endif
- }
-
- private:
---- a/cult/mm/new.cxx
-+++ b/cult/mm/new.cxx
-@@ -140,7 +140,12 @@
- using namespace Cult;
-
- Void*
--operator new (Size s) throw (MM::StdBadAlloc)
-+operator new (Size s)
-+#if __cplusplus < 201103L
-+throw (MM::StdBadAlloc)
-+#else
-+noexcept(false)
-+#endif
- {
- return MM::allocate (s, *MM::counted);
- }
---- a/cult/mm/new.hxx
-+++ b/cult/mm/new.hxx
-@@ -255,7 +255,13 @@
- }
-
- Cult::Void*
--operator new (Cult::Size) throw (Cult::MM::StdBadAlloc);
-+operator new (Cult::Size)
-+#if __cplusplus < 201103L
-+throw (Cult::MM::StdBadAlloc)
-+#else
-+noexcept(false)
-+#endif
-+;
-
- Cult::Void*
- operator new (Cult::Size,
---- a/cult/sched/condition.cxx
-+++ b/cult/sched/condition.cxx
-@@ -12,6 +12,9 @@
- {
- Condition::
- ~Condition ()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
- {
- if (Int e = pthread_cond_destroy (&cond_))
- throw Implementation (e);
---- a/cult/sched/condition.hxx
-+++ b/cult/sched/condition.hxx
-@@ -19,7 +19,11 @@
- class Condition: public NonCopyable
- {
- public:
-- ~Condition ();
-+ ~Condition ()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
-+ ;
-
- Condition (Mutex& mutex);
-
---- a/cult/sched/mutex.cxx
-+++ b/cult/sched/mutex.cxx
-@@ -12,6 +12,9 @@
- {
- Mutex::
- ~Mutex ()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
- {
- if (Int e = pthread_mutex_destroy (&mutex_))
- throw Implementation (e);
---- a/cult/sched/mutex.hxx
-+++ b/cult/sched/mutex.hxx
-@@ -17,7 +17,11 @@
- class Mutex: public NonCopyable
- {
- public:
-- ~Mutex ();
-+ ~Mutex ()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
-+ ;
-
- Mutex ();
-
---- a/cult/sched/spin.cxx
-+++ b/cult/sched/spin.cxx
-@@ -12,6 +12,9 @@
- {
- Spin::
- ~Spin ()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
- {
- if (Int e = pthread_spin_destroy (&spin_))
- throw Implementation (e);
---- a/cult/sched/spin.hxx
-+++ b/cult/sched/spin.hxx
-@@ -17,7 +17,11 @@
- class Spin: public NonCopyable
- {
- public:
-- ~Spin ();
-+ ~Spin ()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
-+ ;
-
- Spin ();
-
---- a/cult/sched/thread.cxx
-+++ b/cult/sched/thread.cxx
-@@ -196,6 +196,9 @@
-
- Thread::
- ~Thread ()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
- {
- tout << "thread is being destroyed.";
-
---- a/cult/sched/thread.hxx
-+++ b/cult/sched/thread.hxx
-@@ -30,7 +30,11 @@
-
- public:
- virtual
-- ~Thread ();
-+ ~Thread ()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
-+ ;
-
- Thread (Void* (*StartRoutine) (Void*), Void* arg = 0);
-
diff --git a/dev-cpp/libcult/libcult-1.4.6-r1.ebuild b/dev-cpp/libcult/libcult-1.4.6-r1.ebuild
deleted file mode 100644
index 51d7f8fd6b15..000000000000
--- a/dev-cpp/libcult/libcult-1.4.6-r1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit eutils toolchain-funcs versionator
-
-DESCRIPTION="A collection of C++ libraries"
-HOMEPAGE="http://kolpackov.net/projects/libcult/"
-SRC_URI="ftp://kolpackov.net/pub/projects/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc ppc64 x86"
-IUSE="examples"
-
-DEPEND="dev-util/build
- sys-devel/m4"
-RDEPEND=""
-
-src_prepare() {
- # never build the examples
- sed -i \
- -e 's| $(out_base)/examples/[[:alnum:]\.]*||' \
- -e '/examples\/makefile/d' \
- makefile || die "sed failed"
-
- epatch "${FILESDIR}/${PV}-fix-compilation-with-gcc-4.7.patch"
- epatch "${FILESDIR}/${P}-cpp14.patch" # bug #593928
-}
-
-src_configure() {
- mkdir -p build/{cxx/gnu,ld}
-
- cat >> build/configuration-dynamic.make <<- EOF
-cult_dr := y
-cult_threads := y
-cult_network := y
- EOF
-
- cat >> build/cxx/configuration-dynamic.make <<- EOF
-cxx_id := gnu
-cxx_optimize := n
-cxx_debug := n
-cxx_rpath := n
-cxx_pp_extra_options :=
-cxx_extra_options := ${CXXFLAGS}
-cxx_ld_extra_options := ${LDFLAGS}
-cxx_extra_libs :=
-cxx_extra_lib_paths :=
- EOF
-
- cat >> build/cxx/gnu/configuration-dynamic.make <<- EOF
-cxx_gnu := $(tc-getCXX)
-cxx_gnu_libraries :=
-cxx_gnu_optimization_options :=
- EOF
-
- cat >> build/ld/configuration-lib-dynamic.make <<- EOF
-ld_lib_type := shared
- EOF
-
- MAKEOPTS+=" verbose=1"
-}
-
-src_install() {
- dolib.so cult/libcult.so
-
- find cult -iname "*.cxx" \
- -o -iname "makefile" \
- -o -iname "*.o" -o -iname "*.d" \
- -o -iname "*.m4" -o -iname "*.l" \
- -o -iname "*.cpp-options" -o -iname "*.so" | xargs rm -f
- rm -rf cult/arch
-
- insinto /usr/include
- doins -r cult
-
- dodoc NEWS README documentation/[[:upper:]]*
- dohtml -A xhtml -r documentation/*
-
- if use examples ; then
- find examples -name makefile -delete
- # preserving symlinks in the examples
- cp -dpR examples "${D}/usr/share/doc/${PF}"
- fi
-}
diff --git a/dev-cpp/libcult/metadata.xml b/dev-cpp/libcult/metadata.xml
deleted file mode 100644
index acd00be69f92..000000000000
--- a/dev-cpp/libcult/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>dev-zero@gentoo.org</email>
- <name>Tiziano Müller</name>
- </maintainer>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 8d19dee9286f..0c8941c42ffe 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -366,7 +366,6 @@ dev-java/jaffl
# David Seifert <soap@gentoo.org> (29 Oct 2016)
# Unmaintained, broken, do not work with GCC 6
# Bugs #594506, #597780, removal in 30 days.
-dev-cpp/libcult
<dev-util/build-0.3.10
# David Seifert <soap@gentoo.org> (29 Oct 2016)