summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-04-07 18:23:24 +0200
committerPacho Ramos <pacho@gentoo.org>2024-04-07 18:43:53 +0200
commitc07572e7d4fea432b1364c98ca2c1f65450e0ac0 (patch)
treeb872cea56a6930535da3de8277f7867cc583ce6c
parentmedia-fonts/noto: Stabilize 20240229 x86, #928891 (diff)
downloadgentoo-c07572e7d4fea432b1364c98ca2c1f65450e0ac0.tar.gz
gentoo-c07572e7d4fea432b1364c98ca2c1f65450e0ac0.tar.bz2
gentoo-c07572e7d4fea432b1364c98ca2c1f65450e0ac0.zip
sys-firmware/sof-firmware: add 2024.03
Closes: https://bugs.gentoo.org/925179 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--sys-firmware/sof-firmware/Manifest1
-rw-r--r--sys-firmware/sof-firmware/sof-firmware-2024.03.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-firmware/sof-firmware/Manifest b/sys-firmware/sof-firmware/Manifest
index e5f413788abe..3069daf66e4f 100644
--- a/sys-firmware/sof-firmware/Manifest
+++ b/sys-firmware/sof-firmware/Manifest
@@ -1,2 +1,3 @@
DIST sof-firmware-2023.12.1.tar.gz 5446189 BLAKE2B a901637ba25df51152f04c7db5330b70a18c92363b102c061568a4c3a8a7e2fc506ac9783abe715f680a27be8a040d63b7dd5b62682979ccf1e4eaeb30789d83 SHA512 e0175f3af5336f23548efcf8fa302bafbb6122fd173273203f687c05ee17fab4e7bd457b27cc7a62fd25ea77708ffdbf9e1fe3880d3df1cf2196d7073c6f7677
DIST sof-firmware-2023.12.tar.gz 5427762 BLAKE2B 48169378609119555f9b655599cef55e5722be71fdfc8fb71b699188fcb3f62a68e217fc3fec8859cd3e1c252f046208d5123c961dd824bd9b6559bd1fb72325 SHA512 ed43e7597c93140b15499ba17bae1866dcf1e2959d910e81b3831e4db2224a1dcff790ef21afcd610d7cc9309251a08351bae1c959ded18e5e28a6b24ae99506
+DIST sof-firmware-2024.03.tar.gz 8161590 BLAKE2B 23d73ff3ab30b5134086bb21e606805a7d9667adf1a5598a3d31068ba0254dc4c34464ee3913eb3530a8124e3614eff9ba28fa731e9816b28980ea05834c1037 SHA512 1e9891d3891f5a4413a77a68ea6d3a2e6ead8c1a67eaa7e9aaf30871753617ffce19bd3b85ebcbb617e606646f6aa0e1dafee5279c294ec72ef4b2885e009f72
diff --git a/sys-firmware/sof-firmware/sof-firmware-2024.03.ebuild b/sys-firmware/sof-firmware/sof-firmware-2024.03.ebuild
new file mode 100644
index 000000000000..ac48a808c83e
--- /dev/null
+++ b/sys-firmware/sof-firmware/sof-firmware-2024.03.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Sound Open Firmware (SOF) binary files"
+HOMEPAGE="https://www.sofproject.org https://github.com/thesofproject/sof https://github.com/thesofproject/sof-bin"
+SRC_URI="https://github.com/thesofproject/sof-bin/releases/download/v${PV}/sof-bin-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/sof-bin-${PV}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ media-libs/alsa-lib
+ sys-libs/glibc
+"
+
+QA_PREBUILT="usr/bin/sof-ctl
+ usr/bin/sof-logger
+ usr/bin/sof-probes"
+
+src_install() {
+ dodir /lib/firmware/intel
+ dodir /usr/bin
+ FW_DEST="${D}/lib/firmware/intel" TOOLS_DEST="${D}/usr/bin" "${S}/install.sh" || die
+}
+
+pkg_preinst() {
+ # Fix sof-ace-tplg directory symlink collisions
+ local sofpath="${EROOT}/lib/firmware/intel/sof-ace-tplg"
+ if [[ ! -L "${sofpath}" && -d "${sofpath}" ]] ; then
+ rm -r "${sofpath}" || die
+ fi
+}