summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-09-02 10:23:23 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-09-02 10:32:32 +0300
commitc076f1b7efd64f4f9bc05e54cf3df3eb69a888a0 (patch)
tree144b4da20f125cab944df6fa89110bda19fe1881
parentnet-im/neochat: drop 1.2.0 (diff)
downloadgentoo-c076f1b7.tar.gz
gentoo-c076f1b7.tar.bz2
gentoo-c076f1b7.zip
media-video/yle-dl: add 20220830
- skip some non-working tests, - update license to GPL-3+. Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--media-video/yle-dl/Manifest1
-rw-r--r--media-video/yle-dl/yle-dl-20220830.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/media-video/yle-dl/Manifest b/media-video/yle-dl/Manifest
index 92aa77ec9e84..a305c355c874 100644
--- a/media-video/yle-dl/Manifest
+++ b/media-video/yle-dl/Manifest
@@ -1 +1,2 @@
DIST yle-dl-20220704.tar.gz 69784 BLAKE2B 4eed09f2531693a45683958f245df7251fe1df6736443b16b4b6079c25b656fcc53d92147456b80e4144766965b5147bf17c5db0b1c73a8d4c3f519c4639d8f2 SHA512 2aba4ef471b487d174d32762d12f8d6da0f40d0709a4f894dbf7f3d0717e347929dee9f620f795b298b8c714f6d433bb8f8321eeba61648a4684eacc0796711f
+DIST yle-dl-20220830.tar.gz 72087 BLAKE2B 1ee31b399daca34ed1ec5bb51fcb38ce439249a4b205e2f0f7219ddd3a438e3a8719c92836ad165112acb7506a5501bb53bb8073960bc2a26635d8eff90dfa8f SHA512 e3ec7c81259901a243f19689666eef415a23f264a04b7f281be11e200f914a0fddea871637afa1e85169bc565f01cbcc0ff91dd800bb07af5b0e6e577041b940
diff --git a/media-video/yle-dl/yle-dl-20220830.ebuild b/media-video/yle-dl/yle-dl-20220830.ebuild
new file mode 100644
index 000000000000..c721a6b525a6
--- /dev/null
+++ b/media-video/yle-dl/yle-dl-20220830.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download media files from Yle Areena"
+HOMEPAGE="https://aajanki.github.io/yle-dl/ https://github.com/aajanki/yle-dl"
+SRC_URI="https://github.com/aajanki/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Requires an active internet connection during tests,
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="media-video/ffmpeg
+ net-misc/wget
+ >=dev-python/attrs-18.1.0[${PYTHON_USEDEP}]
+ >=dev-python/ConfigArgParse-0.13.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/progress[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+BDEPEND="test? (
+ ${RDEPEND}
+ media-video/ffmpeg[gnutls]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+DOCS=( COPYING ChangeLog README.fi README.md yledl.conf.sample )
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # Skip 404'd files.
+ sed -i -e "/def test_radio_series_redirect():/i@pytest.mark.xfail(reason='Video expired.')" \
+ -e "/def test_radio_metadata_2020():/i@pytest.mark.xfail(reason='Video expired.')" \
+ -e "/def test_radio_episodes_sort_order_latest_last_source():/i@pytest.mark.xfail(reason='Video expired.')" \
+ -e "/def test_radio_episodes_sort_order_latest_first_source():/i@pytest.mark.xfail(reason='Video expired.')" \
+ -e "/def test_radio_latest():/i@pytest.mark.xfail(reason='Video expired.')" \
+ tests/integration/test_areena_radio_it.py || die
+}
+
+src_install() {
+ docompress -x "/usr/share/doc/${PF}/yledl.conf.sample"
+ distutils-r1_src_install
+}
+
+pkg_postinst() {
+ elog "Sample configuration file has been installed to "
+ elog " /usr/share/doc/yle-dl-${PVR}/yledl.conf.sample"
+ elog
+ optfeature "youtube-dl download engine" net-misc/youtube-dl net-misc/yt-dlp
+}